Linux vim选择colorscheme后,为何Xshell下打开Vim后背景色全变黑色,而且只有黑色!

andyInn 2014-08-07 10:38:28
我在虚拟机Vmware上装了Fedora 17,本机操作系统为Win7 64-bit,本机安装Xshell 通过SSH登录fedora进行C开发。

比较喜欢几个vim colorscheme,比如darkburn、wombat256和solarized,但是我发现这三个vim颜色主题在终端和Xshell上都会将xshell预设的背景覆盖掉,只有黑色背景(不知道是不是只有我这样),尝试过很多方法都不行。

xshell和vim对256色的支持也做过了修改如下


PS:我在Fedora中打开终端编辑vim也是一样的,背景全黑。。。

我也怀疑是不是我的设置有问题,但是重新做了一个虚拟机系统,只配vim colorscheme后还是不能正确显示其背景色,xshell下还是只有黑色,抓狂了!

我发现网上做的vim配色推荐几乎全是用MacVIM演示截图,在mac os下测试很简单,没有任何问题。
Linux下面用应该也不会有问题才对。。。

以solarized.vim 为例说明一下,完全按照
https://github.com/altercation/vim-colors-solarized
这里的步骤操作的,我希望结果是这样的
只要达到这个效果就行。

请教vim达人,如何设置才能达到随着vim colorscheme的切换,xshell在vim编辑状态下能完全按照colorscheme设定的颜色表示?现在只要应用solarized.vim,background=dark模式能成功就行[因为solarized还有一个light模式],就是完全和示例图一样的效果。
另外说明我不喜欢其他的colorscheme,所以请大神们告知哪里出问题了,多谢!

...全文
8659 点赞 收藏 4
写回复
4 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
fhy1994 2016-05-11
今天研究了半天发上配置文件 看了官方文档 https://github.com/altercation/ethanschoonover.com/tree/master/projects/solarized/vim-colors-solarized



syntax enable
"syntax on
set t_Co=256
"set background=dark
set background=light
let g:solarized_termcolors=256
colorscheme solarized
set ts=4
set expandtab
set number
set numberwidth=1
“set cursorline
回复
引用 1 楼 hangelsing 的回复:
太奇葩了,我先把xshell背景色设置为solarized_dark.xcs,然后t_Co=8,最后选择colorscheme=solarized就可以了。 不管怎么说总算搞定了,以后就可以快乐地开发咯~~~ 有图有真相
没明白LZ怎么解决的,我也遇到这个问题了啊,求再详细一些。 我的terminal本身没有配陈solarized
回复
月影晓风 2014-08-08
楼主给力!!赞一个!!!
回复
andyInn 2014-08-08
太奇葩了,我先把xshell背景色设置为solarized_dark.xcs,然后t_Co=8,最后选择colorscheme=solarized就可以了。
不管怎么说总算搞定了,以后就可以快乐地开发咯~~~
有图有真相

回复
相关推荐
发帖
非技术区
创建于2012-11-23

418

社区成员

非技术问题的乐园
申请成为版主
帖子事件
创建了帖子
2014-08-07 10:38
社区公告
暂无公告