Eclipse中某一项目下,ctrl+左键的快捷键无效

zzz5667547 2014-08-25 05:43:09
Eclipse中某一项目下,ctrl+左键的快捷键无效。
我想通过此快捷键,链接到jsp。
很奇怪,同一个Eclipse下,两个项目,一个可以用“ctrl+左键”链到jsp和类文件,另一个只能链接到类。
已经确认window-->preferences-- >General-->Editors-->Text Editors-->hyperlink. 全部勾上。
以下struts配置信息,jsp路径也没有问题,并且系统运行正常。

<action path="/send" parameter="method" scope="request"
type="com.mysend.action.SendAction">
<forward name="search"
path="/send/search.jsp" />
<forward name="list"
path="/send/list.jsp" />
</action>

注:只有一个项目出现该情况,workspace中的其他项目都正常
...全文
72225 点赞 收藏 17
写回复
17 条回复
切换为时间正序
请发表友善的回复…
发表回复
qq_37370450 2017-02-28
只服你, 快速精准解决问题。
回复
qq_36799407 2016-11-23
为毛你们说的方法对我的eclipse没效果呢
回复
今晚搞搞震 2016-11-16
我的myeclipse的maven项目,右键Maven4MyEclipse——Update Project...,然后就可以了
回复
小九鼎 2016-08-05
赞二楼,我已经放弃治疗,习惯了F3
回复
cai13151 2016-06-01
引用 3 楼 wesesdon 的回复:
xml的默认打开方式改换下,以前也遇到同意的问题。
牛鼻自古出二楼
回复
pleasexiayibu 2016-05-05
七楼牛逼,成功解决困扰我两天的问题,太坑爹了,本来用idea 的,现在用会Eclipse各种坑
回复
baidu_34386281 2016-03-22
引用 7 楼 zzz5667547 的回复:
[quote=引用 楼主 zzz5667547 的回复:] Eclipse中某一项目下,ctrl+左键的快捷键无效。 ...... 注:只有一个项目出现该情况,workspace中的其他项目都正常
今天有个同事也是不能链接进去。花了好长时间,又是重装插件(各种报错,此处略去一万只草泥马),又是看英文文档(翻译工具加看不懂,又是一万只草泥马)。最后发现问题是,打开XML文件格式默认是Spket XML Editor格式(爽!~) ------------------------ 以下是修改为XML Editior打开方法(为什么我发帖后,自己解决问题不能给自己分?? 一只草泥马) Window -> Preferences -> General -> Editors -> File Associations File types: *.xml Associated editors:XML Editor*** -> Default 在Associated editors选择框里点击“XML Editor*** ”,点击“Default”按钮。 [/quote] 我的情况是,鼠标指向目标类之后,再按ctrl按键+鼠标左键,始终没反应。结果是:必须要先按下ctrl按键,再把鼠标指针移到目标类才能跳转。嘛的,用惯了sourceinsight,首次使用eclipse真不适应。eclipse咋能搞这种限制啊,让我误以为不能跳转。
回复
拾荒者老大 2016-03-04
今天刚好遇到,也是刚好 只有一个项目出现该情况. 为了省事,把工程Close,然后再重新双击打开,然后就解决了 不知道你们这样是否能行
回复
wangbingran163 2015-12-10
七楼太给力了!!!感觉有时间应该把eclipse彻底熟悉一下!
回复
wujierd 2014-11-21
好牛逼,已经解决困扰了两天的牛皮癣问题。
回复
zzz5667547 2014-08-28
引用 楼主 zzz5667547 的回复:
Eclipse中某一项目下,ctrl+左键的快捷键无效。 ...... 注:只有一个项目出现该情况,workspace中的其他项目都正常
今天有个同事也是不能链接进去。花了好长时间,又是重装插件(各种报错,此处略去一万只草泥马),又是看英文文档(翻译工具加看不懂,又是一万只草泥马)。最后发现问题是,打开XML文件格式默认是Spket XML Editor格式(爽!~) ------------------------ 以下是修改为XML Editior打开方法(为什么我发帖后,自己解决问题不能给自己分?? 一只草泥马) Window -> Preferences -> General -> Editors -> File Associations File types: *.xml Associated editors:XML Editor*** -> Default 在Associated editors选择框里点击“XML Editor*** ”,点击“Default”按钮。
回复
回复
Intboy 2014-08-26
回复
zzz5667547 2014-08-25
引用 3 楼 wesesdon 的回复:
xml的默认打开方式改换下,以前也遇到同意的问题。
也试过了,谢谢大家的帮助。 本人秉着死磕自己的学习态度,终于找到解决问题的办法了,但具体的问题原因不知道。 window-->preferences-- >Validation-->Web Project Settings中,将Context root修改为一下。 注:这里path="/send/list.jsp“ 之前的Context root是send,但是我改成其他的,如send2就OK。 另外一个项目也是,如果和path路径的第一个单词相同就会出现 ”ctrl+鼠标左击“或F3链不到JSP的问题。
回复
xml的默认打开方式改换下,以前也遇到同意的问题。
回复
zzz5667547 2014-08-25
引用 1 楼 blackspoon123 的回复:
我也有此问题,时好时坏,偶尔重启可解决此问题,但是出现这种问题,F3还是好用的,你可以试下。
试过了, “ctrl+左键”可以的,F3可以;ctrl+左键不可以的,F3同样不可以。。。
回复
漆黑之勺 2014-08-25
我也有此问题,时好时坏,偶尔重启可解决此问题,但是出现这种问题,F3还是好用的,你可以试下。
回复
发动态
发帖子
Java EE
创建于2007-09-28

6.6w+

社区成员

J2EE只是Java企业应用。我们需要一个跨J2SE/WEB/EJB的微容器,保护我们的业务核心组件(中间件),以延续它的生命力,而不是依赖J2SE/J2EE版本。
申请成为版主
社区公告
暂无公告