weblogic9.2 spring 3.2 struts2.3 的JDK问题

zhang80718 2014-09-09 10:31:29
以前我用的tomcat6.0 spring3.2 struts2.3 jdk1.6的环境 正常使用
然后我换成了tomcat6.0 spring3.2 struts2.3 jdk1.5的环境,也可以正常运行。我换1。5就是为了测试sping3.2可以在1.5下正常使用。

最后使用 weblogic9.2 spring3.2 struts2.3 jdk1.5
在eclipse下weblogic服务能正常启动。但是一在浏览器上运行,就提示java.lang.UnsupportedClassVersionError: Bad version number in .class file


不好意思,就20分了


...全文
127 点赞 收藏 10
写回复
10 条回复
zhang80718 2014年09月09日
还是报错误啊。 java.lang.UnsupportedClassVersionError: Bad version number in .class file
回复 点赞
zhang80718 2014年09月09日
谢谢啊,我实验一下去
回复 点赞
蜗牛- 2014年09月09日
停掉weblogic服务器,清理一下缓存 使用jdk1.5来编译class文件,然后打包去weblogic上面去部署
回复 点赞
蜗牛- 2014年09月09日
引用 5 楼 zhang80718 的回复:
我用eclipse 编译的时候,使用的就是weblogic下的jdk
先把eclipse 下生成的class文件全都删除掉,然后build workspace,使用weblogic自带的jdk来生成一份class文件 然后 部署到服务器上面去试试看 部署的时候,使用update,update的新路径给新的文件包的路径
回复 点赞
zhang80718 2014年09月09日
来人帮帮我吗
回复 点赞
zhang80718 2014年09月09日
和服务器是一样的
回复 点赞
zhang80718 2014年09月09日
这个选的是1.5
回复 点赞
lgc8023 2014年09月09日
你编译的项目不能高于你服务器的jdk版本, 你右击项目,proerties---java compiler---compiler compliance level
回复 点赞
zhang80718 2014年09月09日
我用eclipse 编译的时候,使用的就是weblogic下的jdk
回复 点赞
蜗牛- 2014年09月09日
看看服务器上的java 的具体版本号,使用低于服务器版本号的jdk进行java文件的编译
回复 点赞
发动态
发帖子
Web 开发
创建于2007-09-28

5.2w+

社区成员

34.1w+

社区内容

Java Web 开发
社区公告
暂无公告