在mac上使用GLSL编程的一个问题,不知道怎么解决

sanstete 2014-10-19 01:37:55
我在编写一个自己的着色器的时候,编译出现了问题。上面说我的mac不支持4.10版本,但是我的mac确实就是支持openGL4.10的。不知道怎么办,求教。
下面是着色器源码:
//.fp
#version 410

out vec4 vFragColor;
in vec4 vVaryingColor;

void main(void)
{
vFragColor = vVaryingColor;
}


//.vp
#version 410
in vec4 vColor;
in vec4 vVertex;

out vec4 vVaryingColor;

void main(void)
{
vVaryingColor = vColor;
gl_Position = vVertex;
}
...全文
253 回复 打赏 收藏 转发到动态 举报
写回复
用AI写文章
回复
切换为时间正序
请发表友善的回复…
发表回复

3,882

社区成员

发帖
与我相关
我的任务
社区描述
C/C++ 其它技术问题
社区管理员
  • 其它技术问题社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧