centos6.5 linux 上装Jdk 提示ash: /usr/local/jdk7/bin/java: No such file or directory [问题点数:30分]

Bbs1
本版专家分:70
结帖率 66.67%
Bbs1
本版专家分:0
Bbs1
本版专家分:0
Bbs1
本版专家分:0
linux下使用phpize 安装 phpredis扩展
对Linux很不熟悉,折腾了些时间,把redis扩展安装好,其中遇到不少的问题,作个记录。n(1)下载源码包n到redis中文网:http://www.redis.net.cn/clients/#php(或官网),下图:nnn到github,链接:https://github.com/phpredis/phpredis/releases,下载2.2.8版本到 /<em>usr</em>/<em>local</em>/src
安装spark报错java路径不对
/Volumes/ds/service/spark-2.4.0-<em>bin</em>-hadoop2.7/<em>bin</em>/spark-class: line 71: n/Library/Java/JavaVirtualMachines/<em>jdk</em>1.8.0_201/Contents/Home/<em>bin</em>/<em>java</em>: No such <em>file</em> or <em>directory</em>nnn正确的路径在/Library/Java/JavaVirt...
Tomcat-8.0.26报错,这是个坑大家不要在踩了
启动tomcat报错,没有/<em>bin</em>下的*.sh的权限rn# tomcat-8.0.26/<em>bin</em>/startup.sh         rnrnCannot find tomcat-8.0.26/<em>bin</em>/catalina.shrnThe <em>file</em> is absent or does not have execute permissionrnThis <em>file</em> is needed to run thi
腾讯云部署完tomcat,开启./startup.sh后报错,找不到logs/catalina.out
error<em>提示</em>:touch: cannot touch ‘/<em>usr</em>/<em>local</em>/tomcat/apache-tomcat-8.0.50-src/logs/catalina.out’: No such <em>file</em> or <em>directory</em>nnnn/<em>usr</em>/<em>local</em>/tomcat/apache-tomcat-8.0.50-src/<em>bin</em>/catalina.sh: line 456: /...
CentOS安装PHP版本切换(和出现的centos出现-bash: /usr/bin/php: 没有那个文件或目录解决方法)
如果安装PHP版本过低,或者切换版本nn1.首先,删除centos上面的PHPnnn# yum remove php-commonnn2.引入yum源nnCentOS 6.x 源nnnn nnn # rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpmn n n # rpm -Uvh http...
linux中输入jps命令报错
-b<em>ash</em>: /mnt/software/<em>jdk</em>1.7.0_07/<em>bin</em>/jps: /lib/ld-<em>linux</em>.so.2: bad ELF interpreter: No such <em>file</em> or <em>directory</em>rnrnrnroot登录后安装:rnyum install glibc.i686
linux下的安装mysql与遇到一些常见问题的解决方法
本地的安装环境: centos6.9rn1、下载rnrnrnmysql官网地址:rnhttp://dev.mysql.com/downloads/mysql/5.6.html#downloadsrn我是用的版本:5.6.33,通用版,<em>linux</em>下64位rn  也可以直接复制64位的下载地址,通过命令下载:wget http://dev.mysql.com/get/Downloads/MySQL-5
在Centos下用alternatives命令切换各个版本的jdk的方法
自己通过rpm安装了个<em>jdk</em>1.8,默认安装在/<em>usr</em>/<em>java</em>中,应调试需要,在服务器的/<em>usr</em>/<em>local</em>/<em>java</em>目录里安装<em>jdk</em>-6u25-<em>linux</em>-x64.<em>bin</em>,默认创建/<em>usr</em>/<em>local</em>/<em>java</em>/<em>jdk</em>1.6.0_25,需要切换着使用JDK执行如下命令:rn[root@iZ23udjr1lgZ <em>java</em>]# alternatives --install /<em>usr</em>/<em>bin</em>/jav
Centos下kafka 单机配置部署详解
前提:Linux版本:CentOS release 6.6 (Final) nJDK版本:<em>jdk</em>-7u71-<em>linux</em>-x64.tar.gz nzookeeper版本:zookeeper-3.3.6.tar.gz nkafka版本:kafka_2.11-0.9.0.1.tgz1、安装JDK步骤1:新建路径/<em>usr</em>/<em>java</em>, 并在其下解压 <em>jdk</em>-7u71-<em>linux</em>-x64.tar.gzmkdir
python2更新Python3遇到的问题
Mac下安装配置Python2和Python3并相互切换使用@TOCn我遇到的问题虽然升级成功但是当我在控制台输入python命令的时候看到的还是旧版本Python2.7,n其实这就是因为系统默认的路径没切换过来,一般初学者如果使用Mac学习Python的话,系统是自带python2的,而我升级的时候则是用的 brew install python3。这里是存在一个问题nn 接下来就要看具体步骤了...
Jenkins安装及使用(CentOS6.5)
前置条件n安装<em>jdk</em>1.7或以上版本n安装gitn安装maven n安装添加Jenkins库到yum库,Jenkins将从这里下载安装。sudo wget -O /etc/yum.repos.d/jenkins.repo http://pkg.jenkins-ci.org/redhat/jenkins.reponsudo rpm --import https://jenkins-ci.org/red
Linux下Erlang&RabbitMQ服务安装配置
版权声明:本文为博主StarskyBoy的原创文章,未经博主允许不得转载。https://blog.csdn.net/StarskyBoy/article/details/81059439nnRabbitMQ是流行的开源消息队列系统,是AMQP(Advanced Message Queuing Protocol高级消息队列协议)的标准实现,用erlang语言开发。RabbitMQ据说具有良好的性能...
:bash: usr/local/3.4.1/bin/arm-linux-gcc: 没有该文件或目录 解决方法!
网上一般出现这种问题都是一些依赖的东西没有安装出现的问题,如果排除了这些问题,那么请试一试我的方法。1、 进入你的交叉编译工具的目录执行 ldd arm-poky-<em>linux</em>-gnueabi-gcc,会出现一些依赖的关系,下面是我的信息提醒:<em>linux</em>-vdso.so.1 (0x00007ffe24557000) libm.so.6 =&amp;gt; /home/xufan/tbox/poky/1.6....
caffe过程中的错误(一)
make test时报错:n/<em>bin</em>/sh: /<em>usr</em>/<em>local</em>/cuda/<em>bin</em>/nvcc: No such <em>file</em> or <em>directory</em>nawk: syntax error at source line 1n context isn{exit  >>>  nawk: illegal statement at source line 1nCXX src/caffe/test/
virtualenvwrapper的安装及问题解决
n安装virtualenvwrappernnnnnyum install python-setuptools python-develnpip install virtualenvwrapper # <em>linux</em>下nn********************************************npip install virtualenvwrapper-win # windows下nn2...
linux安装node避坑
<em>linux</em> centos7 64位搭建node环境nn运行 node -v 如果报错b<em>ash</em>: ./node: cannot execute <em>bin</em>ary <em>file</em>nn可能是下载的node版本不对,请核对是否是<em>linux</em> centos7 64位版的nodenn安装node如下:nn1、wget https://nodejs.org/dist/v8.11.1/node-v8.11.1-<em>linux</em>-...
ubuntu18.04创建虚拟环境时提示bash: /usr/local/bin/virtualenvwrapper.sh: 没有那个文件或目录 的解决办法
错误原因:nUbuntu安装了2.7和3.x两个版本的python,在安装时使用的是sudo pip3 install virtualenvwrappern在我运行的时候默认使用的是python2.x,但在python2.x中不存在对应的模块。n(virtualenvwrapper.sh文件内容如下:):nif [ &quot;$VIRTUALENVWRAPPER_PYTHON&quot; = &quot;&quot; ] thennV...
usr/local/bin/zsh"没有文件或目录问题">"/usr/local/bin/zsh"没有文件或目录问题
本人正在学<em>linux</em> 装ubuntu 16.04后按网上教程 安装zsh后发现无法root  显示: /<em>usr</em>/<em>local</em>/<em>bin</em>/zsh 没有文件或目录rn百度了一下需要更改 /etc/passwd 第一项"root:x:0:0:root:/root:/<em>usr</em>/<em>local</em>/<em>bin</em>/zsh"中正确的"zsh目录"  我的zsh目录是"/<em>usr</em>/<em>bin</em>/zsh"rn所以应改为"root:x:0:0:
解决/usr/bin/env: php: 没有那个文件或目录
这个问题应该是找不到php的执行文件,把env会通过$PATH所指定的路径去寻找php的可执行文件rnrnphp执行文件其实在/<em>usr</em>/<em>local</em>/php/<em>bin</em>/php这里,所以我们可以为这个文件添加一个软链接:rnln -s /<em>usr</em>/<em>local</em>/php/<em>bin</em>/php /<em>usr</em>/<em>local</em>/<em>bin</em>/php
完美解决linuxjdk版本与安装版本不一致
最近重新安装了centos7,针对以前遇到的Java版本不一致的情况,提出了另一种方法,该方法简单易行,容易理解.
Hbase的搭建(伪分布式)
http://www-eu.apache.org/dist/hbase/rn在这里下载  stable/hbase-1.1.5-<em>bin</em>.tar.gzrnrnrnsudo tarrn-zxf ~/Downloads/hbase-1.1.5-<em>bin</em>.tar.gz -C /<em>usr</em>/<em>local</em>sudo mvrn/<em>usr</em>/<em>local</em>/hbase-1.1.5 /<em>usr</em>/<em>local</em>/hbasesudo virn
file or directory" 与 当前工作目录问题">Erlang 编译时出现"no such file or directory" 与 当前工作目录问题
初学Erlang,编译.erl文件时,<em>提示</em>:rn>1 c(some_module)rnrn./some_module.erl:none: no such <em>file</em> or <em>directory</em>rnerrorrnrn这是由于.erl文件并未在Erlang当前工作目录中导致。rn在Erlang shell中输入如下函数,获取当前工作目录:rn>1 pwd().rn可以使用如下函数切换工作目录:rn>1 c
ZooKeeper安装过程(单机模式)
1.从http://mirror.bit.edu.cn/apache/zookeeper/上面找到你想要的版本,我找到的是rn  http://mirror.bit.edu.cn/apache/zookeeper/zookeeper-3.4.9/zookeeper-3.4.9.tar.gzrn2.切换到自己想要的下载目录,下载压缩包rn  cd /optrn  wget http://mirror
hexo异常:/usr/bin/env: node: 没有那个文件或目录
一.问题描述发现自己Deepin2014 上用GitHub + Hexo搭建个人博客,但是每次重新启动系统时显示错误 n n自己明明搭建好了环境啊!npm命令都可以使用啊,但时hexo 版本也查看不到,还是一样 n二.解决办法执行nvm ls查看版本,再执行下列命令 n n0.11改为你的版本号,比如我的是v0.11.11,发现一切正常了,又可以发布博客了。不过这只是解决了当下的问题,可能下次重启又
非root用户(普通用户) protobuf安装
root用户/protobuf安装参考http://blog.csdn.net/tdmyl/article/details/31811317rn安装包也可以联系1365728210@qq.comrn$./configure    rn$make&&make install报错如下:(prefix默认为/<em>usr</em>/<em>local</em>/)rntest -z "/<em>usr</em>/<em>local</em>/lib/pkgconfig"
linux下安装JDK以及修改path路径的方法
首先检查<em>linux</em>中是否已经安装<em>jdk</em>[root@bogon <em>bin</em>]# rpm -qa|grep <em>java</em>n//如果有会出下边的情况ntzdata-<em>java</em>-2012c-1.el6.noarchn<em>java</em>-1.6.0-open<em>jdk</em>-1.6.0.0-1.45.1.11.1.el6.i686n卸载[root@bogon <em>bin</em>]# rpm -e --nodeps <em>java</em>-1.6.0-open<em>jdk</em>
升级到mac 10.13.1 cocoaPod Ruby路径出错问题
刚升级到升级到mac 10.13.1。发现pod用不了,Ruby路径出错rnzsh: /<em>usr</em>/<em>local</em>/<em>bin</em>/pod: bad interpreter: /System/Library/Frameworks/Ruby.framework/Versions/2.0/<em>usr</em>/<em>bin</em>: no such <em>file</em> or <em>directory</em>rn这是Ruby下午硬编码路径改变造成的。rn重新初始化运行p
Linux安装jdk1.8配置后java命令不能用,提示权限不够
Linux安装<em>jdk</em>1.8时走到最后一步,检查<em>jdk</em>配置是否生效时,突然碰出一个问题来。rn<em>提示</em>:b<em>ash</em>: /<em>usr</em>/<em>java</em>/<em>jdk</em>1.8/<em>bin</em>/<em>java</em>: 权限不够rn解决rn这时需要Linux连接Xshell,在Xshell中rn输入命令:chmod +x /<em>usr</em>/<em>java</em>/<em>jdk</em>1.8/<em>bin</em>/<em>java</em>rnrnrn注:rn1. chmod:改变权限的方法rn2. +:代表添加权限rn
linux安装MYSQL遇到的问题
####启动MYSQL服务时出现无法创建/var/log/mariadb/mariadb.log n错误信息: nStarting MySQL.touch: cannot touch ‘/var/log/mariadb/mariadb.log‘: No such <em>file</em> or <em>directory</em> nchmod: cannot access ‘/var/log/mariadb/mariadb.log
安装airflow——踩坑
环境:<em>centos6.5</em>; mysql Ver 14.14 Distrib 5.1.73,nn主要参考这个文档……nnhttps://blog.csdn.net/kk185800961/article/details/78431484nn1、遇到的大坑:nnn[root@hadoopdn-04 ~]# /<em>usr</em>/<em>local</em>/python27/<em>bin</em>/airflow webserver -p 80...
Linux下安装Nginx完整教程及常见错误解决方案
1.Nginx安装环境rnNginx是C语言开发,建议在<em>linux</em>上运行,本教程使用Centos7.0作为安装环境.rn1)gccrn安装nginx需要先将官网下载的源码进行编译,编译依赖gcc环境,如果没有gcc环境,需要安装gccrn需要执行的命令:yum install gcc-c++ rn2)PCRErnPCRE(Perl Compatible Regular Expressions)是一
Linux用extundelete恢复误删文件
误删后应急处理nExtundelete安装n操作流程n常见错误nextundelete No such <em>file</em> or <em>directory</em> while creating <em>directory</em>nUnable to set proper <em>file</em> sizen感想误删后应急处理n立刻umount误删文件所在磁盘,或立刻强行关机n千万不要在未umount磁盘情况下正常关机,因为关机时会写入一些文件,导致部分文
安装Apache等程序路径usr/binusr/local/bin区别安装完配置自动启动
n n n 首先注意<em>usr</em> 指 Unix System Resource,而不是Usern/<em>usr</em>/<em>bin</em>下面的都是系统预装的可执行程序,会随着系统升级而改变n/<em>usr</em>/<em>local</em>/<em>bin</em>目录是给用户放置自己的可执行程序的地方,推荐放在这里,不会被系统升级而覆盖同名文件n如果两个目录下有相同的可执行程序,谁优先执行受到PATH环境变量的影响,比如我的一台服务器的PAT...
Linux系统安装VMware Tools和同W7共享文件遇到的问题
我用的系统为CentOS6.5 minimal版本 nminimal版本默认不启动网络,所以要自己配置。vi /etc/sysconfig/network-script/ifcfg-eth01 NM_CONTROLLED="no" #修改为no不依赖VMware NetworkManager控制n2 ONBOOT="yes" #修改为yes设置开机启动NetworkMan
centos安装jdk1.8时出现没有/lib/ld-linux.so.2:这个文件
-b<em>ash</em>: /<em>usr</em>/<em>local</em>/<em>jdk</em>/<em>jdk</em>1.8.0_181/<em>bin</em>/<em>java</em>: /lib/ld-<em>linux</em>.so.2: bad ELF interpreter: No such <em>file</em> or <em>directory</em> n安装完后nnn <em>java</em> -version n 查看版本出现: n nnn原因是:没有那个文件或目录,找了很久发现需要安装glibc.i686nnnn使用命令:sudo...
Jenkins安装节点时遇到jdk安装错误
Warning: no key algorithms provided; JENKINS-42959 disabled n[02/28/18 15:19:44] [SSH] Opening SSH connection to 172.17.20.177:22. n[02/28/18 15:19:44] [SSH] SSH host key matches key in Known Hosts fi...
usr/local/share/man/man1": 文件已存在">编译问题解决:mkdir: 无法创建目录"/usr/local/share/man/man1": 文件已存在
  编译遇到一个怪问题:nnnmkdir: 无法创建目录"/<em>usr</em>/<em>local</em>/share/man/man1": 文件已存在nnnn  这问题可够怪异的。怎么办?nnnsudo mv /<em>usr</em>/<em>local</em>/share/man/man1 /<em>usr</em>/<em>local</em>/share/man/man1.baknn  再编译,即可。为什么有这样的怪问题,吾亦不明白。n...
HBase集群部署(完全分布式)及部署过程遇到问题浅析解决
环境nOS: Ubuntu 16.04 LTSnJava: open-<em>jdk</em>1.8.0_111(需要1.7+)nHadoop: hadoop-2.7.3nZookeeper: zookeeper-3.4.9nHbase: hbase-1.2.4n集群机器n IPn HostNamen Mastern RegionServer 10.100.3.88n Mastern yesn no
Linux下安装及配置Nexus-2.12.0
环境与工具:nnn虚拟机:VMware 12 Pron n操作系统:CentOS6.8n nnexus版本:nexus-professional-2.12.0-01n n操作Linux的工具:Xshell 5nn注:Nexus服务器运行时需要JDK的支持,可参考以下链接进行配置:nnLinux下配置JDK及环境变量nn1.Nexus官网下载安装包(选择后缀为*.tar.gz的文件):nnnNexu...
Nginx在Linux下的安装与配置,以及遇到问题的解决整理
1、资源下载:可以到nginx官网下载最新包http://nginx.org/,或者我这边使用的nginx-1.10.0.tar.gz。n2、将下载的资源上传到/<em>usr</em>/<em>local</em>目录下,注意:如果遇到文件无法移动或报没有权限,应该是账号不是root用户,可以使用su root命令切换。n3、安装nginx,在/<em>usr</em>/<em>local</em>下解压nginx-1.10.0.tar.gz,并进入nginx-
关于shell脚本提示No such file or directory的解决办法和原因
 在执行刚编写完的shell脚本时,报错现象:解决办法:   vim模式打开这个shell脚本,查看编码格式后设置成unix编码   具体操作:            vim shellarr.sh打开脚本,ctrl+c进入输入:命令的格式,输入:set ff?,查看格式是否是<em>file</em>format=unix           如果不是,设置成unix           :set ff=unix...
Redis2.8.13安装配置
【1】下载Redis安装包rnwgethttp://download.redis.io/releases/redis-2.8.13.tar.gzrn注:wget 时<em>提示</em> -b<em>ash</em>:wget command not found,很明显没有安装wget软件包。一般<em>linux</em>最小化安装时,wget不会默认被安装,这里是CentOS 6.3 32位系统rnrn解决方法:(本人采用的是yum安装yum -
Linux安装jdk1.8以及出现的问题
1.用Xftp将<em>jdk</em>压缩包传到虚拟机中,可以在<em>usr</em>目录下新建一个文件夹Java,将其放在<em>usr</em>/<em>java</em>文件目录下n          在Linux中新建文件夹:(1)可以直接通过Xftp在里边新建n                                                  (2)也可以在虚拟机中通过命令新建:cd /<em>usr</em>
Mac终端不管输入什么指令都显示No such file or directory
写了一个python文件,在Mac终端输入指令总是显示:npython: can’t open <em>file</em> ‘这是我的文件名’: [Errno 2] No such <em>file</em> or <em>directory</em>n看了半天,发现是环境变量的事 .b<em>ash</em>_pro<em>file</em>不知道怎么的被删除了n接下来就是解决这个问题了:Mac上找不到.b<em>ash</em>_pro<em>file</em>该怎么办?n1、创建 .b<em>ash</em>_pro<em>file</em>n(1)...
Spark安装部署
Spark安装部署安装Scala环境wget https://downloads.lightbend.com/scala/2.12.1/scala-2.12.1.tgz ntar -zxvf scala-2.12.1.tgz nmv scala-2.12.1 /home nsudo vim /etc/pro<em>file</em> nexport JAVA_HOME=/<em>usr</em>/lib/jvm/<em>java</em>-7-open
centos7运行脚本提示: 没有那个文件或目录 :No such file or directory
在windows下编好shell脚本传到centos7上运行,<em>提示</em>nn: 没有那个文件或目录 nn:No such <em>file</em> or <em>directory</em>nn是dos格式与unix格式冲突导致nn解决办法nn重定向到:https://blog.csdn.net/u012506661/article/details/73603408nn以后老老实实用VIMnnn...
安装keepalived, 以及安装时遇见的问题
安装keepalived1、下载keepalived安装包。官网地址2、上传到<em>linux</em>相关目录,并且用tar -xvf 报名解压,解压后相关目录如下图:3、在当前目录执行 ./configure命令3.1如果出现类似错误,说明安装失败。n configure: error: n !!! OpenSSL is not properly installed on your system. !
手动安装kubernetes1.8.6集群
手动安装kubernetes集群,通过安装过程可以了解kubernetes的组成部分。 n本安装过程全部采用下载二进制安装包的方式安装,k8s镜像直接从谷歌下载,所以要所有节点配置好科学上网,如何配置科学上网就不在这里介绍了。nn采用三个节点安装,vmnode1作为主节点,由于节点少主节点也当做node节点使用。nnnnn 节点名称n ipn 组件nnnn vmnode1n 192.16...
【深入理解Java虚拟机】之自己编译JDK(已经完成,其中有自己遇到的各种问题及解决办法)
(深入理解Java虚拟机 第二版 书中1.6 实战:自己编译JDK) n个人笔记,仅供参考系统:CentOS 6.5 nOpenJDK:OpenJDK 7u1、获取源码。 n两种方式: n① 直接官网下载 n② 通过Mercurial代码版本管理工具获取。说一下第二种方式: n首先安装Mercurial代码版本管理工具yum install mercurial安装之后clone源码hg clone
64位系统安装32位交叉工具链时No such file or directory的解决办法
64位系统安装32位交叉工具链时Nornsuch <em>file</em> or <em>directory</em>的解决办法 rnrnrn 在安装交叉工具链的时候,明明已经将路径添加到/etc/environment里面了,而且在命令行输入:arm-<em>linux</em>- 然后按tab键能够补全很多命令出来,在编译程序的时候却<em>提示</em>: rnrnrn b<em>ash</em>:rn/gcc-3.4.5-glibc-2.3.6/<em>bin</em>/arm-<em>linux</em>-g
linux下pip使用可能遇到的问题
今天想在实验楼上找项目练练手,为了偷懒,<em>linux</em>环境直接就用了win10内置的WSL(Windows内置的Ubuntu子系统,有着比虚拟机更高的系统权限,而且文件目录跟windows下一致)。在使用pip安装pillow库时出现了问题,解决后记录如下:rnrnrn1、lgc@Orankarl:~/.pip$ sudo pip install pillownThe <em>directory</em> '/home
Linux安装最新版git
本文旨在讲述如何在<em>linux</em>上安装最新版的git。nn1、查看当前git版本:git --versionn查看最新版git:访问https://www.kernel.org/pub/software/scm/git/n或者https://github.com/git/git/releasesn2、官网下载:nwget https://Github.com/Git/Git/archive
Centos7离线安装Mysql_解压包安装
<em>linux</em>离线安装mysql
关于解决bash: /usr/lib/command-not-found: /usr/bin/python3: 解释器错误: 没有那个文件或目录的问题
/<em>usr</em>/<em>bin</em>/python3: 解释器错误: 没有那个文件或目录nn网上搜罗里许许多多的办法,都没有解决nn这些奇奇怪怪的也是在解决问题的路途中逐步的被一步步的加上去的nn真的手残装了超级多的python,鬼知道我经历了什么???nnnn无数次吐槽???我没有么我有啊nn直到最近开了一门叫做Linux系统教程的课才知道网上那些奇奇怪怪的代码是什么意思nn由于安的版本太多了,链接指在哪也忘记了...
linux初始对比
[panyuejie@VMQTTEST01 ~]$ cd /etcrn[panyuejie@VMQTTEST01 etc]$ lsrnadjtime            csh.cshrc                gnupg        ld.so.conf      nsswitch.conf   rc                sasl2           sysctl.con
Ubuntu下提示/usr/bin/env: node: 没有那个文件或目录
由于Ubuntu下已经有一个名叫node的库,因此Node.js在ubuntu下默认叫nodejs,需要额外处理一下http://stackoverflow.com/questions/18130164/nodejs-vs-node-on-ubuntu-12-04sudo ln -s /<em>usr</em>/<em>bin</em>/nodejs /<em>usr</em>/<em>bin</em>/node
zookeeper启动报mkdir: 无法创建目录"": 没有那个文件或目录
Using config: /<em>usr</em>/<em>local</em>/<em>java</em>/zookeeper-3.4.6/<em>bin</em>/../conf/zoo.cfgngrep: /<em>usr</em>/<em>local</em>/<em>java</em>/zookeeper-3.4.6/<em>bin</em>/../conf/zoo.cfg: 没有那个文件或目录nmkdir: 无法创建目录&quot;&quot;: 没有那个文件或目录nStarting zookeeper ... STARTEDnn nn解决方...
Linux下执行可执行文件提示:No such file or directory的解决方法
最近在Linux下安装交叉编译链工具,解压完成后执行却<em>提示</em>:No such <em>file</em> or <em>directory</em>。查了一下发现我是64位的Ubuntu系统但是执行的是32位程序,缺少32位lib库所以无法执行。rn  tips: uname命令可打印系统信息rn<em>file</em>命令可打印文件信息 rn  解决方法: rn安装i386架构及系列库rn  root权限下 rndpkg --add-archite
mac os升级到10.13后 cocoa pods不能使用的问题解决
n n n iphone8,iphoneX相继问世,iOS11应运而生(
spark 启动
[root@name01 conf]# pwdn/<em>usr</em>/<em>local</em>/spark/spark-1.4.0/confn[root@name01 conf]# ../s<em>bin</em>/start-dfs.shnb<em>ash</em>: ../s<em>bin</em>/start-dfs.sh: No such <em>file</em> or <em>directory</em>n[root@name01 conf]# lsndocker.properties.templa
安装webbench出现的错误
安装webbenchnnn wget http://home.tiscali.cz/~cz210552/dist<em>file</em>s/webbench-1.5.tar.gz n tar -zxvf webbench-1.5.tar.gz n cd webbench-1.5 n make &amp;amp;amp;amp;&amp;amp;amp;amp; make installnnnmake 时报错nnn 在安装编译webbench的时候, ...
linux安装elasticsearch6.2.4及安装过程中出现的问题解决
一.安装环境CentOS7(我之前使用centOS6.x,安装完成后启动报错显示<em>linux</em>版本过低,所以推荐使用高版本的CentOS)下载地址centOS下载二.下载elasticsearch在安装elasticsearch之前需要安装<em>jdk</em>1.8x<em>jdk</em>下载地址点击打开链接下载完成后放入/<em>usr</em>/<em>java</em>/[root@<em>local</em>host admin]# cd /<em>usr</em>/<em>java</em>/n[root@l...
linux下报错/usr/bin/env: node: 没有那个文件或目录
出现原因rn命令:nw-gyp configure --target=0.12.3rnrnwindows下为node,<em>linux</em>下为nodejs.rnrn解决方案rn1、为node增加链接rnsudo ln -s /<em>usr</em>/<em>bin</em>/nodejs /<em>usr</em>/<em>bin</em>/nodern2、找出出错代码将node手动改为nodejs
安装kibana
说明:此次部署中kibana是安装在另外的一台主机上,因此,需要重新安装JDK,详细见第一篇nn1、kibana的主配置文件/kibana/config/kibana.ymlnnn#监听端口,默认为5601nnserver.port: 5601nn#监听主机nnserver.host: &quot;192.168.32.129&quot;nn#指定elasticsearch的URLnnelasticsearch.ur...
centos系统安装杀毒软件clamav
创建clamav用户和存放病毒库目录nn nnn#clamav用户和用户组nngroupadd clamav &amp;amp;&amp;amp; useradd -g clamav clamav &amp;amp;&amp;amp; id clamavnnn#日志存放目录nnmkdir -p /<em>usr</em>/<em>local</em>/clamav/logs     nntouch /<em>usr</em>/<em>local</em>/clamav/logs/clamd.logn...
linux安装jdk报错无法执行二进制文件
    今天本来美滋滋的在<em>linux</em>上安装<em>jdk</em>,一顿操作之后一个<em>java</em> -version甩出,结果给我报错,说无法执行二进制文件!What?什么鬼?    好,先检查是不是环境变量没有配置好,检查完了没问题。    这就奇怪了,一般<em>jdk</em>不行都是环境变量的问题啊,于是我直接到<em>jdk</em>的<em>bin</em>目录下执行<em>java</em>命令,也是报错。突然一想,二进制文件,为什么这里面的都是二进制文件,叮~特么不会是我的l...
mac安装rz,sz文件操作指令
一、需要用到wget指令,先安装wget指令:rn    rnrnrn curl -O http://ftp.gnu.org/gnu/wget/wget-1.13.4.tar.gzn tar -xzvf wget-1.13.4.tar.gzn cd wget-1.13.4n ./configure --with-ssl=openssln maken
inotifywait实现文件监控
应用场景nn文件监控可以配合rsync实现文件自动同步,例如监听某个目录,当文件变化时,使用rsync命令将变化的文件同步。(可用于代码自动发布)nnnn安装nnnoitify下载地址:http://github.com/downloads/rvoicilas/inotify-tools/inotify-tools-3.14.tar.gznnnncd inotify-tools-3.14n./co...
Linux下批处理文件存在却报错:no such file or directory
如果确定文件存在,执行却报错误:no such <em>file</em> or <em>directory</em>一般都是因为这个文件时从windows或者其他系统上面上传过来的,解决办法也很简单,删除之后在Linux环境下重写一份,如果文件过长的话就只新建空文件,然后远程编辑即可。...
usr/bin/java": 没有那个文件或目录">nohup: 无法运行命令"/usr/bin/java": 没有那个文件或目录
1. ./zkServer.sh startnn2.jpsnn没有QuorumPeerMain进程nn3.  ./zkServer.sh statusnnJMX enabled by defaultnUsing config: /home/wdz/hadoopProperties/zookeeper-3.4.6/<em>bin</em>/../conf/zoo.cfgnError contacting servic...
【mysql工具错误】解决备份数据库提示"mysqldump: command not found"问题
设置软链接(在根目录下执行)ln -fs /<em>usr</em>/<em>local</em>/mysql/<em>bin</em>/mysqldump /<em>usr</em>/<em>bin</em>ln -fs /<em>usr</em>/<em>local</em>/mysql/<em>bin</em>/mysql /<em>usr</em>/<em>bin</em>注意:/<em>usr</em>/<em>local</em>/mysql/<em>bin</em>/mysqldump是你mysql的安装目录
git通过gitosis来管理权限(三)
首先,git服务器的安装参见nhttp://blog.csdn.net/lyhdream/article/details/49561645nn这篇文章的一小节。nnn开始安装gitosisn一、首先安装python工具:napt-get install python-setuptoolsn二、获取并安装gitosis:n进入/tmp目录(将要安装的gitosis文件克隆到该目录
Linux升级openssh及问题总结
升级步骤:n[root@db 1]# yum install pam-develnnn[root@db 1]# pwdn/home/1n[root@db 1]# lsnopenssh-7.1p2  openssl-1.1.0-pre3  zlib-1.2.8n[root@db 1]# ssh -VnOpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar
误卸载linux自带的rpm包
之前没有注意,一不小心把主机A rpm包给卸载了,使用rpm时<em>提示</em>:-b<em>ash</em>: rpm: command not foundn于是各种无助啊。但是应该有两个思路可以试一下:nn1.使用yum安装rpm包,将丢失的rpm包重新下载,然后安装。nn2.使用源代码编译安装nn但是我的系统不能使用外网,于是各种郁闷啊。尝试从其他主机拷贝一个rpm命令试试,没想到真成功了。
系统自带的/usr/bin里面的python和python2.7等
今天升级python2.7.6的时候,用了句ln -sf /<em>usr</em>/<em>local</em>/<em>bin</em>/python python之类的代码,把以前的python删除了导致整个系统崩溃,后来在虚拟机里面拷贝了出来,再覆盖以前的就好了,大家需要就下载吧
解决'GLIBC_2.14' not found问题时遇到的坑
下面先说一下遇到的坑:n1、在make过程中出现如下错误:n/<em>usr</em>/<em>bin</em>/install: `include/limits.h' and `/opt/glibc-2.14/include/limits.h' are the same <em>file</em>nn2、在make install过程中出现如下错误:nCan't open configuration <em>file</em> /opt/glibc-2.14/etc/ld.so.conf: No such <em>file</em> or <em>directory</em>
Solr(二)——Solr单机部署
(1)安装JDK和配置相关环境变量rn(2)下载Solr:http://www.apache.org/dyn/closer.lua/lucene/solr/6.6.0rn(3)移动Solr二进制分发包到安装目录下并解压,比如将solr安装在/opt目录下rntar -zxvf solr-6.6.0.tgz(4)修改solr目录到所有者为指定的用户组和用户,不建议以root权限运行solrrncho
pip打不开,提示没有文件或目录
pip打不开,<em>提示</em>:rnrnyakumo_17@MacBook~$piprnrnrnrn-b<em>ash</em>: /<em>usr</em>/<em>local</em>/<em>bin</em>/pip: /<em>usr</em>/<em>local</em>/opt/python/<em>bin</em>/python2.7: bad interpreter: No such <em>file</em> or <em>directory</em>rnrn根据地址找过去,pip文件都在,无法通过重新安装pip解决。rnrn解决方法:rnrn打开
解决linux中zookeeper,tomcat等依赖jdk的程序自启动失败问题
问题现象:n在etc/pro<em>file</em>中配置了如下命令:n/home/hadoop/zookeeper/<em>bin</em>/zkServer.sh start &n/run/ayena/solr/tomcat/<em>bin</em>/startup.sh &nn系统启动后用jps查看进程,发现zookeeper和tomcat均未启动。nnn原因:n配置<em>java</em>环境变量时,将JAVA_HOME配置在了etc/p
Hive第一课配置安装
Hive简介:nn    基于Hadoop的一个数据仓库工具,构建于hadoop的hdfs和mapred之上,用于管理和查询结构化/非结构化数据的数据仓库。可以将结构化的数据文件映射为一张数据库表,并提供类SQL查询功能。nn     Hive将HQL语句转译成M/RJob,然后按照MR的计算框架在Hadoop执行,也可以把HQL中的表、字段转换为HDFS中的文件(夹)以及文件中的列。这套
Caffe - Ubuntu 安装及问题解决
Caffe - Ubuntu 安装及问题解决nnnUbuntu14.04nCUDA 8.0ncuDNNnnnnnCaffe 安装nnnStep 1 CUDA安装 n要结合使用 Caffe 和 NVIDIA GPU,需要安装CUDA 工具包. nStep 2 cuDNN 安装nn下载适用于Linux的cuDNN库,这里需要注册加速计算开发人员计划; n下载后,解压缩文件并将其复制到CUDA目录,...
linux安装MySql问题汇总
1.rpm安装,安装MySQL时出现不兼容n# rpm -ivh MySQL-server-5.5.52-1.<em>linux</em>2.6.x86_64.rpm nnnwarning: MySQL-server-5.5.52-1.<em>linux</em>2.6.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEYnPreparing...
redis(1)——Ubuntu下安装redis
redis安装rn rn1、首先需要安装gcc,一般Ubuntu系统都已经提前安装好了rnsudo apt-get install gccrn2、把下载好的redis-3.2.11.tar放到 /<em>usr</em>/<em>local</em> 文件夹下rn3、进行解压 tar -zxvf redis-3.2.11.tarrn4、进入到redis-3.2.11目录下,进行编译 make,这个地方需要使用sudo指令,不然会报错
usr/java": 权限不够"">解决办法:无法创建目录"/usr/java": 权限不够"
ubuntu 17.04系统无法创建目录"/<em>usr</em>/<em>java</em>": 权限不够"的解决办法
安装mysql5.7出现的问题
n执行/<em>usr</em>/<em>local</em>/mysql/<em>bin</em>/mysql_install_db --user=mysql --basedir=/<em>usr</em>/<em>local</em>/mysql/ --datadir=/<em>usr</em>/<em>local</em>/mysql/data时,出现如下错误nn2018-12-10 10:31:32 [WARNING] mysql_install_db is deprecated. Please consider...
06: 完全分布式 、 节点管理 、 NFS网关
TopnnNSD ARCHITECTURE DAY06nn案例1:安装与部署n 案例2:Hadoop词频统计n 案例3:节点管理n 案例4:NFS配置nnn1 案例1:安装与部署nn1.1 问题nn本案例要求:nn对mapred和yarn文件进行配置n 验证访问Hadoopn1.2 方案nn在day05准备好的环境下给master (nn01)主机添加ResourceManager的角色,在nod...
关于freeswitch1.5在ubuntu14.04上安装遇到的问题1
2017年7月7日rn环境:ubuntu14.04-192.168.1.223-局域网主机rn安装freeswitch1.5rn    公司内一直用的是freeswitch1.5版本,需要我在局域网主机上安装freeswitch1.5版本,我在官网上只发现了一个1.5版本的,可能是我不会找,经过下载编译安装,到最后我检测freeswitch的版本的时候有意外发现显示的是1.9版本,可能是我安装方法
如何将mysql运行在非默认目录(/usr/local/mysql)中
本文以新加一个mysql实例为例。例如服务器上已经安装了3306端口的mysql服务,需要再启一个3308端口的mysql服务。rnrn   假设mysql安装在/<em>usr</em>/<em>local</em>/mysql路径下,找一个磁盘空间剩余比较大的盘,如/data1,把3308端口的mysql的数据保存在/data1下rn#mkdir /data1/mysql_3308rn#mkdir /data1/mysql_33
修改 /usr/bin/java 的指向
修改 /<em>usr</em>/<em>bin</em>/<em>java</em> 的指向update-alternatives --install "/<em>usr</em>/<em>bin</em>/<em>java</em>" "<em>java</em>" "/<em>usr</em>/<em>java</em>/<em>bin</em>/<em>java</em>" 1nupdate-alternatives --config <em>java</em>
linux下mysql启动失败问题解决(CentOS7)
错误信息: nn[ERROR] /<em>usr</em>/s<em>bin</em>/mysqld: Can't create/write to <em>file</em> '/var/run/mysqld/mysqld.pid' (Errcode: 2 - No such <em>file</em> or <em>directory</em>)n2018-10-16T12:58:13.166990Z 0 [ERROR] Can't start server: can't creat...
CentOS安装Python3时常遇到的问题总结
安装包下载rnpython3的Linux安装源码都可以在rnhttps://www.python.org/downloads/source/rn下面找到,可以在windows端下载之后远程送到Linux(服务器或虚拟机),也可以直接在Linux终端使用wget命令来获取。rn例如,下载python3.7.2版本源码:rnwget https://www.python.org/ftp/python/3.7.2...
【MySQL】centos6中/etc/init.d/下没有mysqld启动文件,怎么办
如果/etc/init.d/下面没有mysqld的话,service mysqld start也是不好使的,同样,chkconfig mysqld on也是不能用nn解决办法:nn将mysql的mysql.server这个文件替换上去即可nn首先到mysql的目录中,查找下nnn[root@test6_100 mysql]# find ./* -name mysql.servern./suppor...
Redis安装异常解决办法
官网地址:http://redis.io/rnrn官网下载地址:http://redis.io/downloadrnrn rnrn1. 下载Redis源码(tar.gz),并上传到Linuxrnrn2. 解压缩包:tar zxvf redis-2.8.17.tar.gzrnrn3. 进入解压缩后的文件夹:cd redis-2.8.17rnrn4. 编译源码:makernrn(1)若出现如下<em>提示</em>,则
MYSQL 启动报错
我先说一下我安装mysql的操作吧:1、开始的时候,安装mysql,是那种解压缩就能用的软件包。我把它解压后,拷贝到/<em>usr</em>/<em>local</em>/ 目录下,并把名字命名为mysql。2、建立用户mysql。[root@<em>local</em>host ~]# useradd mysql3、修改权限。[root@<em>local</em>host ~]# chown -R mysql:mysql /<em>usr</em>/<em>local</em>/mysql4、初始...
Node.js 安装遇到的问题及解决路径(二)
接上文,以下为Linux系统下通过源码编译安装的方式。rnrnrn#  tar xvf node-v0.10.28.tar.gz rn#  cd node-v0.10.28 rn#  ./configure rn# make rn# make install rn# cp /<em>usr</em>/<em>local</em>/<em>bin</em>/node /<em>usr</em>/s<em>bin</em>/ rn rn查看当前安装的Node的版本 rnrn# node -
Web Api 的 路由机制
ASP.NET Web API 是一种框架,用于轻松构建可以访问多种客户端(包括浏览器和移动设备)的 HTTP 服务。 ASP.NET Web API 是一种用于在 .NET Framework 上构建 RESTful 应用程序的理想平台。所以我们要想学习web api 就要去了解它的路由机制。MVC和web api的路由机制的主要区别是web api 使用的是http 方法而不是url 的路径。本
20072008\无线识别装置设计下载
20072008\无线识别装置设计 20072008\无线识别装置设计 20072008\无线识别装置设计 相关下载链接:[url=//download.csdn.net/download/SLY85103026/2623979?utm_source=bbsseo]//download.csdn.net/download/SLY85103026/2623979?utm_source=bbsseo[/url]
系统集成项目管理工程师教程1下载
系统集成项目管理工程师教程 pdf完整版 相关下载链接:[url=//download.csdn.net/download/smallkun1010/3026581?utm_source=bbsseo]//download.csdn.net/download/smallkun1010/3026581?utm_source=bbsseo[/url]
苹果笔记本1181驱动.asix_ethernet_XP下载
苹果笔记本1181驱动.asix_ethernet_XP 苹果笔记本1181驱动.asix_ethernet_XP 苹果笔记本1181驱动.asix_ethernet_XP 相关下载链接:[url=//download.csdn.net/download/jshaier/3115794?utm_source=bbsseo]//download.csdn.net/download/jshaier/3115794?utm_source=bbsseo[/url]
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 java学习笔记jdk7 java jdk7学习
我们是很有底线的