maven install Failed to execute goal org.apache.maven.plugins:maven-war-plugin:2 [问题点数:20分,结帖人danruoshui315]

Bbs1
本版专家分:90
结帖率 66.67%
Bbs9
本版专家分:50487
版主
Blank
Github 绑定github第三方账户获取
Blank
优秀版主 优秀大版主
2015年8月优秀大版主
2015年9月优秀大版主
Blank
黄花 2015年2月 Java大版内专家分月排行榜第二
2014年3月 Java大版内专家分月排行榜第二
Blank
蓝花 2014年9月 Java大版内专家分月排行榜第三
2014年6月 Java大版内专家分月排行榜第三
2014年2月 Java大版内专家分月排行榜第三
2013年11月 Java大版内专家分月排行榜第三
2013年10月 Java大版内专家分月排行榜第三
Bbs1
本版专家分:90
maven学习总结:几个常用的maven插件
我们使用<em>maven</em>做一些日常的工作开发的时候,无非是想利用这个工具带来的一些便利。比如它带来的依赖管理,方便我们打包和部署运行。这里几个常见的插件就是和这些工程中常用的步骤相关。   <em>maven</em>-compile-plugin     这个插件就如同名字所显示的这样,用来编译源代码的。最开始碰到这个插件是在于有的时候我们下载了一些工程需要编译的时候,比如我们输入命令:mvn <em>install</em> ,
关于maven的pom报plugins错误的解决办法
Failure to transfer org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:pom:2.7.1 from http:/xxxxxxxxxxxxxx/<em>maven</em>2 was cached in the local repository, resolution will not be reattempted until the update
使用mavenmaven-shade-plugin插件时需要注意的一个问题
<em>maven</em>-shade-plugin插件有个配置属性:createDependencyReducedPom 注意这个属性,它默认值为true. 如果你用这个插件来deploy,或者发布到中央仓库 这个属性会缩减你的pom文件,会把你依赖的干掉 正确的做法是把这个值改成false org.apache.<em>maven</em>.plugins <em>maven</em>-shade-plugin
MAVEN项目部署到tomcat7问题
使用的是Tomcat 7, 1、需要修改pom.xml中部署的url地址,将http://localhost:8080/manager改http://localhost:8080/manager/text 2、给tomcat用户权限分配上,需要同时具备manager-gui和manager-script权限,我在遇到该问题时,就是忘了分配manager-script权限。 正确的
Maven deploy发布问题
1、<em>maven</em>发布包到私服仓库时,问题报错信息如下: [ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-deploy-plugin:2.5:deploy (default-deploy) on project coordinate-config: Deployment <em>failed</em>: repository element ...
关于maven 操作中断导致 maven clean失败的分析
看了网上介绍的方法,大概意思是: 1:找到本地<em>maven</em>仓库把org.apache.<em>maven</em>.plugins:<em>maven</em>-clean-plugin:2.4.1对应的_remote.repositories 删光 重新clean 这种方法的确可行。 2.如果按照以上方法还是不能解决的话,我这里还有一个简单粗暴的方法。 直接把你要打包的项目的 target 里的jar或者war 包删除再重新...
Maven总结(打war包错误)
<em>maven</em>解决打war包找不到web.xml
maven 使用时,遇到的错误,及解决办法
1、使用<em>maven</em>命令行(mvn archetype:create -DgroupId= xx DartifactId=simple -DpackageName=xx), 创建一个项目时,一直报下面的错误:[ERROR] Could not find <em>goal</em> 'create' in plugin org.apache.<em>maven</em>.plugins:<em>maven</em>-archetype-plugin:3.
maven 常用插件配置详解
先将我用到的自定义变量贴过来,防止插件中出现一些变量,大家不理解    Java代码            tools      UTF-8     project.build.name:  用来定义war包名称   project.build.sourceEncoding:  用来定义资源文件的编码格式   下面开始讲解常用的<em>maven</em>插件配置  
Hadoop 0.23编译常见错误
0) 要是下面的错误你都碰到了。。说明你开发环境没搞好,用下面这个命令吧。 yum group<em>install</em> "Development Libraries" 1) 报错: "[ERROR] Failed to <em>execute</em> <em>goal</em> org.codehaus.mojo:make-<em>maven</em>-plugin:1.0-beta-1:autoreconf (autorecon
Ambari 2.6.1源码编译问题汇总
1、[INFO] Ambari Admin View .................................. FAILURE[ERROR] Failed to <em>execute</em> <em>goal</em> org.codehaus.mojo:exec-<em>maven</em>-plugin:1.6.0:exec (Bower <em>install</em>) on project ambari-admin: Command exec...
maven-war-plugin报错遇到的问题解决
注释掉build里面的plugin,然后添加上相对应的jar包地址,进行<em>maven</em>的update                 cn.xygk           server-api           1.0                    org.apache.<em>maven</em>.plugins        <em>maven</em>-compiler-plugin      
maven学习--maven编译时包无法下载的问题
前言今天在编译运行一个<em>maven</em>项目时编译失败,查看了一下报错原因,如下:[ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-checkstyle-plugin:2.17:check (checkstyle) on project labmanagement: Execution checkstyle of <em>goal</em> org.a
学习Maven遇到的一些坑
学习Maven遇到的一些坑 Maven新建webapp项目index.jsp报错 解决办法:直接在pom.xml文件中添加jar包支持 dependency> groupId>javax.servletgroupId> artifactId>javax.servlet-apiartifactId> version>3.1.0version> depen
Maven故障排除
一、警告 Report plugin org.apache.<em>maven</em>.plugins:<em>maven</em>-project-info-reports-plugin has an empty version. 在Run As》》Run Configuration中配置<em>maven</em>的Goals为org.apache.<em>maven</em>.plugins:<em>maven</em>-site-plugin:3.3:site后,R
Ambari源码编译
Ambar为Apache基金会的一个顶级项目。作为一个为Hadoop系统提供一站式维护的工具,ambari支持通过web页面/RestfulApi的方式进行对集群的一键部署,最重要的是可以自己编写部署脚本部署自己的分布式系统。这个是富有价值的,现在有的公司使用的是自研的分布式框架,想要自动部署大多也是自研一套分布式框架。现在Ambari的出现,缓解了这个问题,用户只需要使用python按照规则编写
使用springboot+maven出现的问题
问题描述: springboot 在执行<em>maven</em> <em>install</em> 时候出现以下错误Failed to <em>execute</em> <em>goal</em> org.springframework.boot:spring-boot-<em>maven</em>-plugin:1.4.2.RELEASE:repackage (default) on project springcloud-common: Execution defaul
maven常见异常与解决
异常1:[ERROR] Failed to <em>execute</em> <em>goal</em> on project biz_zhuhai: Could not resolve dependencies for project biz_zhuhai:biz_zhuhai:jar:0.0.1-SNAPSHOT: Failed to collect dependencies for [com.maywide.ibh:lib34...
Maven父子项目打包子项目出现Failed to collect dependencies问题
错误如下: Failed to <em>execute</em> <em>goal</em> on project project-name: Could not resolve dependencies for project xxx.xxx.xxx.xx:jar:1.0: Failed to collect dependencies for [xxx.xxx.xxx.xxx:jar:1.0 (compile), ......]
自动化项目部署过程可能遇到的各种BUG
不断补充中。。 0、<em>maven</em> 启动 测试用例 报错问题。 错误日志如下。 ***********************日志bigan************************************* [ERROR] Failed to <em>execute</em> <em>goal</em> com.github.eirslett:frontend-<em>maven</em>-plugin:1.0:npm (npm inst
使用maven管理项目protobuf文件自动编译配置
使用<em>maven</em>管理项目时,确实包的管理方便了很多,使用protobuf时,在pom文件中需要增加以下编译插件。具体的配置参数可以到https://www.xolstice.org/protobuf-<em>maven</em>-plugin/index.html 进行查阅依赖的包:&amp;lt;dependency&amp;gt; &amp;lt;groupId&amp;gt;io.grpc&amp;lt;/groupId&amp;gt; &amp;l...
Jenkins部署Maven项目时提示找不到JDK问题的解决方案
今天我将一个Maven Web项目在Jenkins中配置自动构建部署时,遇到报错:No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK? 经过搜索和分析,是需要在pom.xml中明确的指明JDK所在目录。
dubbo-admin构建报错
刚从GitHub下载下来的dubbo-admin直接构建汇报如下错误,原因是<em>maven</em>库里没有该dubbo的jar包。[INFO] Scanning for projects... [WARNING] [WARNING] Some problems were encountered while building the effective model for com.alibaba:dubbo-a
maven-shade-plugin打Jar包的相关问题
问题如下:问题1:使用<em>maven</em>-shade-plugin插件,打超级JAR包时,运行<em>maven</em> <em>install</em>出错如下。Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-shade-plugin:2.0:shade (default) on project QMServer: Execution default of <em>goal</em> org.a
Maven 运行时报错
首先看一下报错的日志: [ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-compiler-plugin:3.5:compile (default-compile) on project <em>maven</em>-first: Execution default-compile of <em>goal</em> org.apache.<em>maven</em>.pl...
maven项目集成sonar,执行sonar:sonar 命令时候报错.
我使用的是sonar4.1 版本,mysql5.6报错信息如下:[ERROR] Failed to <em>execute</em> <em>goal</em> org.sonarsource.scanner.<em>maven</em>:sonar-<em>maven</em>-plugin:3.4.0.905:sonar (default-cli) on project practise: Unable to <em>execute</em> SonarQube: Fail to ...
maven 札记
Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-gpg-plugin:1.5:sign (sign-artifacts) on project ***   加 -Dgpg.skip=true
maven build报错解决方案
 <em>maven</em>打包成war时,报错:Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-war-plugin:2.1.1:war (default-war) on project web_nanchang: Error assembling WAR: webxml attribute is required 原因:找不到web.xm
Maven与jetty问题集锦
1、在Maven的pom.xml配置jetty的插件 org.eclipse.jetty jetty-<em>maven</em>-plugin 9.3.6.v20151106 start-jetty pre-integration-test run
Maven_ERROR无效的目标版本
[ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-complier-plugin:3.1:compile (default-compile) on project xxx:Fatal error compliling: 无效的目标版本: 1.7 -> [Help 1]   查看<em>maven</em>环境 C:\Users\Admi
Maven项目通过mvn clean package打包编译器版本变为1.5以及resource目录下配置文件未打入到包中的问题
Maven项目通过mvn clean package打包编译器版本变为1.5以及resource目录下配置文件未打入到包中的问题 一、Maven项目通过mvn clean package打包编译器版本变为1.5 通过mvn clean package -D<em>maven</em>.test.skip=true打包时,报如下错误: -source 1.5 中不支持 diamond 运算符 以及各种...
运行jetty-maven-plugin时,出现错误
[ERROR] Failed to <em>execute</em> <em>goal</em> org.eclipse.jetty:jetty-<em>maven</em>-plugin:9.4.0.v20161208:run (default-cli) on project kind-perm-web: Execution default-cli of <em>goal</em> org.eclipse.jetty:jetty-<em>maven</em>-plugin:9.4.0
搭建自己的SpringBoot initializer构建服务器最后执行mvn clean install -Pfull报错
报错内容如下: [INFO] Scanning for projects… [INFO] ———————————————————————— [INFO] Reactor Build Order: [INFO] [INFO] Spring Initializr [pom] [INFO] S...
Maven install 出错解决方法
[ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-<em>install</em>-plugin:2.3.1:<em>install</em> (default-<em>install</em>) on project  com/hs/moonbox/admin-api: Failed to <em>install</em> metadata  C:/Users/wang/.m2/repos
打包Spring Boot工程
在intellij idea 中,需要在<em>maven</em>中 新建 Run configuration,对应的command-line 为 :clean <em>install</em> spring-boot:repackage Pom.xml代码   "http://<em>maven</em>.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XML
Maven 环境下使用 proguard-maven-plugin 插件混淆你的源码
摘要 a、ProGuard(http://proguard.sourceforge.net/) 是比较出色的 Java 代码混淆工具,可以有效的保护与优化你的代码。当然这里说的保护是防止恶意抄袭,通过混淆造成反编译阅读困难。但逻辑与内容并不会加密,仔细分析还是可以获得一些信息。 b、proguard-<em>maven</em>-plugin 是 Maven 中的 ProGuard 插件,可以非常方便的在你做
maven生命周期和phase goal
在idea中执行plugins下的<em>install</em>:<em>install</em>出现了The packaging for this project did not assign a file to the build artifact错误引出了对Maven生命周期以及phase <em>goal</em>的学习。 下面是这个问题在stackoverflow上找的回答: 地址:http://stackoverflow.com/q
Maven项目部署到tomcat+部署中的各种问题
第一次写东东,心情有点儿小激动,因为今天刚刚把<em>maven</em>在tomcat上跑起来,所以趁热打铁,写写过程中经历的很多小挫折以及心中狂奔过的无数个草泥马。     还是先写如何配置吧,没接触<em>maven</em>的我,以为只要直接<em>maven</em> build,然后run起来就可以在tomcat上飞快的奔跑起来,真是好多时候真心觉得自己每天都不带脑子的。虽然我内心也在挣扎,好像我什么都没在tomcat上干过,但是我就想
Maven项目部署使用问题及注意点
配置<em>maven</em>时,Goals中输入clean tomcat7:run,然后选择工作空间(workspace),选择要启动的项目目录。 项目从SVN迁出后,需将项目转换成Maven项目。选择Configure,然后选择Convert to Maven Project。 以此执行上述命令。 common-app中,本地路径如上图。 然后修改:C:\Windows\System3
findbugs-maven-plugin:3.0.0求助,hadoop源码编译报错,已安装过findbugs并尝试了多个版本
main:[INFO] Executed tasks[INFO] [INFO] --- hadoop-<em>maven</em>-plugins:2.7.5:protoc (compile-protoc) @ hadoop-hdfs ---[INFO] [INFO] &amp;lt;&amp;lt;&amp;lt; <em>maven</em>-source-plugin:2.3:test-jar (default) &amp;lt; generate-sour...
Maven+scala+spark常见问题总结
Maven常见问题总结
maven 编译hadoop错误解决
hadoop编译错误 mvn   eclipse:eclipse  [INFO] ------------------------------------------------------------------------ [INFO] Reactor Summary: [INFO] [INFO] Apache Hadoop Main ....................
使用com.google.code.maven-replacer-plugin插件为前端代码自动添加版本号
通过<em>maven</em>-replacer-plugin插件可以为打包的前端文件中所引用的JS、CSS文件添加版本号,从而在每次代码重新部署后可及时更新用户缓存。 配置过程如下: 配置日期输出格式,默认日期按照yyyy-MM-ddTHH:mm:ss格式输出,作为版本戳较为不美观 &amp;lt;properties&amp;gt; &amp;lt;<em>maven</em>.build.timestamp.format&amp;gt;yy...
maven插件报错之解决
用m2eclipse创建Maven项目时报错 分类: Java 2011-11-04 10:12 3074人阅读 评论(0) 收藏 举报 <em>maven</em>eclipsebuilddependenciesauthorizationplugins 用m2eclipse创建Maven项目时报错 问题: Could not calculate build pl
新建maven项目时pom.xml文件第一行报org.apache.maven.plugin.war.WarMojo的解决方法
新建<em>maven</em>项目的时候pom.xml文件第一行报错,如下: 出现这个错误的原因是 org.apache.<em>maven</em>.plugins<em>maven</em>-war-plugin这个插件的默认的版本在jdk1.7下有问题,指定2.1.1版本后就没有问题了,修改为下面(在pom.xml中添加如下代码就可以了
Maven之maven插件(有讲到tool.jar找不到的解决办法)
这是接上一篇文章,上一篇文章太长了,这是接着上一篇文章主要讲一些<em>maven</em>的插件的使用。 1、SQL Maven Plugin 在tian-parent中添加 org.codehaus.mojo sql-<em>maven</em>-plugin</arti
jenkins 用 Maven 打包出现 找不到符号 问题的解决方法
1 发现问题今天用 持续集成工具 jenkins 打包一个新项目,出现了很多错误:... [ERROR] [ERROR] \ideaProjects\xxx\ProjectService.java:[201,73] 错误: 找不到符号 [ERROR] [ERROR] -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the e
Maven之使用SVN版本号
1.有时候我们在项目中需要给js,css加版本参数来避免浏览器缓存,比如 Html代码   script type="text/javascript" src="/js/jquery-1.8.2.min.js?v=${v?if_exists}">script>    这个时候,我们可以使用项目的svn版本号来作为参数(时间戳也是一种选择)。那么我们如何使用mave
maven打包采用svn版本号做版本管理
针对jar、war包,采用<em>maven</em>进行打包时,采用svn版本号进行版本管理,提供程序获取查看写入的版本号 获取svn版本号写入mainfest文件(jar、war)采用buildnumber-<em>maven</em>-plugin插件 pom.xml示例 http://<em>maven</em>.apache.org/
使用cargo-maven2-plugin插件自动化部署项目时遇到的问题
在《Maven实战》第239页-----使用cargo实现自动化部署,其中部署至本地web容器有两种方式,分别为standalone模式和existing模式,我选择的是existing模式,下面是我的配置,在account-web的pom文件中: org.codehaus.cargo    cargo-<em>maven</em>2-plugin    1.0             
使用wagon-maven-plugin插件自动部署项目
该插件的<em>maven</em>依赖为: org.codehaus.mojo wagon-<em>maven</em>-plugin 1.0 插件的文档地址为: http://www.mojohaus.org/wagon-<em>maven</em>-plugin/ 主要提供如下几个<em>goal</em> wagon:upload-single uploads the specified file to a remot
org.mybatis.generator版本不对应错误
错误代码[ERROR] Failed to <em>execute</em> <em>goal</em> org.mybatis.generator:mybatis-generator-<em>maven</em>-plugin:1.3.2:generate (default-cli) on project unkown: http://www.mybatis.org/dtd/mybatis-generator-config_3_0.dtd -> [H
maven 打包 negative time 异常的问题
如果错误如下:证明文件的更新时间不一致 [ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-war-plugin:2.5:war (default-war) on project buyersystem: Execution default-war of <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>
maven 插件之 AutoConfig 工具使用笔记
AutoConfig 是一款 <em>maven</em> 插件,主要用于 Maven 项目打包使用。在我们的工作中,会将自己写的代码打成 jar 包或者 war 包发布到各种环境上。一般地,不用的环境所使用的数据库、缓存的配置是不同的。我们完全可以手工修改不用环境的配置,当然这种做法是非常耗费精力的。好在, <em>maven</em> 为我们提供了 profile 机制,但我在工作中还觉得它不够好,因为它把我的数据库用户名和密码配
maven的pom报plugins却是的解决方法
转自http://blog.sina.com.cn/s/blog_90aad2c90101lce4.html <em>maven</em>的pom报plugins却是的解决方法. 引用 Failure to transfer org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:pom:2.7.1 from http://repo1.<em>maven</em>.org/mave
通过swagger2markup+asciidoctorj生成html和pdf文档并解决asciidoctorj生成的pdf文件中文显示不全问题(maven方式及java代码方式)
通过swagger2markup+asciidoctorj生成html和pdf文档(<em>maven</em>方式及java代码方式) 任务:通过同事的json文件生成相应的html和pdf文档 前言 开始时swagger2markup和asciidoctorj是什么都不知道,只能百度,看官方文档(翻译。。。), 遇到问题就一头雾水,完全不知道哪里出了问题,要怎么决解,百度上资料(中文?)也是寥
maven的pom报plugins缺失的解决方法
<em>maven</em>的pom报plugins却是的解决方法. 引用 Failure to transfer org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:pom:2.7.1 from http://repo1.<em>maven</em>.org/<em>maven</em>2 was cached in the local repository, resolution will n
CAS4.0 导入MAVEN编译错误
报错如下: [ERROR] Failed to <em>execute</em> <em>goal</em> com.mycila.<em>maven</em>-license-plugin:<em>maven</em>-license-plugin:1.9.0:check (default) on project cas-server: Resource C:\xxx\cas-server-4.0.0/src/licensing/header.txt not foun
刚安装maven后,编译项目时报错:插件org.apache.maven.plugins:maven-resources-plugin:2.6或其中一个依赖项无法解决......
错误: ............................... ............................... 从中央下载:https://repo.<em>maven</em>.apache.org/<em>maven</em>2/org/apache/<em>maven</em>/plugins/<em>maven</em>-resources-plugin/2.6/<em>maven</em>-resources-plugin-2.6.pom [信...
执行maven [goal]命令的含义
<em>goal</em> phase lifecycle这几个概念的区别我不赘述了,我前一篇博文便转载了,网上也大把大把的资料。 这篇文章说的是,例如执行 mvn archetype:generate 此类执行<em>goal</em>语句,冒号的两边分别代表什么含义。 它对应的含义是 mvn goa
Maven之错误
<em>maven</em>工程提示pom.xml无法解析org.apache.<em>maven</em>.plugins:<em>maven</em>-resources-plugin:2.6 Description Resource Path Location TypeExecution default-resources of <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-resources
Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:
[code=HTML]rn[INFO] ------------------------------------------------------------------------rn[ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-compiler-plugin:2.3.2:compile (default-compile) on project clothing: Compilation failurern[ERROR] Unable to locate the Javac Compiler in:rn[ERROR] C:\Program Files\Java\jre6\..\lib\tools.jarrn[ERROR] Please ensure you are using JDK 1.4 or above andrn[ERROR] not a JRE (the com.sun.tools.javac.Main class is required).rn[ERROR] In most cases you can change the location of your Javarn[ERROR] <em>install</em>ation by setting the JAVA_HOME environment variable.rn[ERROR] -> [Help 1]rn[ERROR] rn[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.rn[ERROR] Re-run Maven using the -X switch to enable full debug logging.rn[ERROR] rn[ERROR] For more information about the errors and possible solutions, please read the following articles:rn[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureExceptionrnrn[/code]rnrn[code=XML]rn rn rn rn org.apache.<em>maven</em>.pluginsrn <em>maven</em>-compiler-pluginrn 2.3.2rn rn 1.6rn 1.6rn UTF-8rn rn rn rn org.apache.<em>maven</em>.pluginsrn <em>maven</em>-war-pluginrn 2.1.1rn rn testrn rn rn rn org.apache.<em>maven</em>.pluginsrn <em>maven</em>-dependency-pluginrn rn rn <em>install</em>rn <em>install</em>rn rn sourcesrn rn rn rn rn rn org.mortbay.jettyrn <em>maven</em>-jetty-pluginrn 6.1.10rn rn 0rn foorn 9999rn rn rn rn start-jettyrn pre-integration-testrn rn runrn rn rn 0rn truern rn rn rn rn rn rn[/code]rn
Failed to execute goal org.apache.maven.plugins:maven-idea-plugin:2.2.1: idea
[WARNING]rn[WARNING] Some problems were encountered while building the effective settingsrn[WARNING] expected START_TAG or END_TAG not TEXT (position: TEXT seen ...\n \n\t\n\t\ua0\ua0\ua0\ua0\ua0\ua0 [Help 1]rn[ERROR]rn[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switrnch.rn[ERROR] Re-run Maven using the -X switch to enable full debug logging.rn[ERROR]rn[ERROR] For more information about the errors and possible solutions, please rearnd the following articles:rn[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MissingProjectrnException
Jib构建你的第一个java镜像
jib Official:GoogleContainerTools/jib 本文示例完整demo github地址 https://github.com/moxingwang/jib 想要了解并且使用jib,首先你得知道或者使用过docker,在这个基础上才能够明白jib是干什么得,解决了什么问题。 首先我们先看一个例子,如何将一个spring-boot项目简单容器化...
Avro序列化操作(1):环境搭建和Schema处理
环境: Intellij 15.0.3 Maven avro 1.8.0Avro是一个数据序列化系统。 它提供以下: 1 丰富的数据结构类型 2 快速可压缩的二进制数据形式 3 存储持久数据的文件容器 4 远程过程调用RPC 5 简单的动态语言结合功能,Avro和动态语言结合后,读写数据文件和使用RPC协议都不需要生成代码,而代码生成作为一种可选的优化只值得在静态类型语言中实现。
maven install 报错解决方案
Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-compiler-plugin:3.3:compile
maven执行报错不支持diamond运算符
写了一些java代码,执行mvn <em>install</em>的时候报错:根据其中ERROR提示找到StudentDao.java第32行代码如下:List stuList = new ArrayList();其中的<>符号不被<em>maven</em>目前使用的jdk版本支持,且ERROR中提示<em>maven</em>-compiler-plugin:3.1……-source 1.5中不支持,请使用-so
使用maven的tomcat插件启动时报错问题
1、最近在学习Apache下的一个权限框架shiro。在eclipse上建了一个web项目,使用<em>maven</em>引入对应的依赖。在spring和springMVC等配置都准备好后,准备跑一下JSP页面确保环境没问题,跑的时候使用的也是<em>maven</em>的tomcat7插件,在pom.xml的插件配置处配置如下:&amp;lt;build&amp;gt; &amp;lt;finalName&amp;gt;shiro&amp;lt;/finalName...
项目升级OpenJDK11所遇到的各种坑之jacoco-maven-plugin
升级OpenJDK11之后,本身项目中有用到jacoco-<em>maven</em>-plugin进行代码覆盖检查。但是当进行<em>maven</em> <em>install</em>的时候总会报如下的错误: [ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:2.18.1:test (default-test) on project web...
使用idea开发maven项目遇到问题
idea <em>maven</em>构建提示diamond 运算符
maven启动tomcat报错
2016-10-26 14:46:14 org.apache.catalina.startup.Embedded start 信息: Starting tomcat server 2016-10-26 14:46:14 org.apache.catalina.core.StandardEngine start 信息: Starting Servlet Engine: Apache Tomca
Hive源码编译常见问题
笔者将自己编写的UDF函数集成到Hive编译过程中遇到了如下几个问题,如果你在编译过程中也遇到了类似的问题,可以参考下面的解决方法。Hive 通过Maven来编译,命令如下$ mvn clean package -Phadoop-2,dist -DskipTests 问题一 异常信息:Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-co
maven手动安装远程仓库中找不到的jar到本地仓库
只需要使用一个<em>maven</em>命令即可:  mvn <em>install</em>:<em>install</em>-file -Dfile=(jar本地地址)/root/IdeaProjects/keta-customer/lib/patchca-0.5.0.jar -DgroupId=com.github.bingoohuang(groupId) -DartifactId=(artifactId)patchca -Dversion
Maven Build报错:Failed to execute goal org.apache.maven.plugins:maven-surefire-plu
先上代码:rn[b]pom.xml文件:[/b]rn[code=text]rnrnrn rn com.company.esbrn skybus-parentrn 1.5-SNAPSHOTrn rn 4.0.0rnrn obern mulernrnrn obern obe subject mulernrn rn rn companyrn http://10.123.78.58/nexus/content/groups/company/rn rn truern alwaysrn rn rn rn company-publicrn http://10.123.78.58/nexus/content/groups/public/rn rn rn nexus-central-pluginrn http://oss.sonatype.org/content/groups/public/rn rn rnrn rn rn companyrn http://10.123.78.58/nexus/content/groups/company/rn rn truern alwaysrn rn rn rn company-publicrn http://10.123.78.58/nexus/content/groups/public/rn rn rn nexus-publicrn http://oss.sonatype.org/content/groups/public/rn rnrn rnrn rn rn company-snapshotsrn http://10.123.78.58/nexus/content/repositories/snapshotsrn rn rn company-releasesrn http://10.123.78.58/nexus/content/repositories/releasesrn rn rnrnrn rn rn com.company.esbrn skybus-commonrn 1.5-SNAPSHOTrn rn rn ibeOpenClientrn ibeOpenClientrn 1.0rn rn rn ibeclientrn ibeclientrn 1.1rn rn rn ibeclientrn rmi4IbeInfrn 1.0rn rn rn obeproxyrn obeproxyrn 1.6.0rn rn rn service4obeClientrn service4obeClientrn 2.0rn rn rn hangyirn hangyirn 2.0rn rn rn hangyinewrn hangyinewrn 1.0rn rn rn pnrparsern pnrparsern 3.0rn rn rn com.companyrn apiparserrn 1.0rn rn rn com.company.bravorn bravo-utilrn 3.0.0-SNAPSHOTrn rn rn com.companyrn apiparserrn 1.0.0-SNAPSHOTrn rn rn rn rn rn rn org.apache.<em>maven</em>.pluginsrn <em>maven</em>-source-pluginrn 2.1.2rn rn truern rn rn rn attach-sourcesrn verifyrn rn jar-no-forkrn rn rn rn rn rn rnrn[/code]rnrn[b]报错信息:[/b]rn[code=text]rn[INFO] Scanning for projects...rn[WARNING] rn[WARNING] Some problems were encountered while building the effective model for com.travelsky.esb:obe:mule:1.5-SNAPSHOTrn[WARNING] 'dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: com.travelsky:apiparser:jar -> version 1.0 vs 1.0.0-SNAPSHOT @ line 125, column 15rn[WARNING] rn[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.rn[WARNING] rn[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.rn[WARNING] rn[INFO] rn[INFO] ------------------------------------------------------------------------rn[INFO] Building obe 1.5-SNAPSHOTrn[INFO] ------------------------------------------------------------------------rn[WARNING] The POM for xmlbeans:xbean:jar:2.5.0 is missing, no dependency information availablern[WARNING] The POM for spring-jdbc:spring-jdbc:jar:3.0.3.RELEASE is invalid, transitive dependencies (if any) will not be available, enable debug logging for more detailsrn[WARNING] The POM for com.travelsky:apiparser:jar:1.0.0-SNAPSHOT is missing, no dependency information availablern[WARNING] The artifact ant:ant:jar:1.7.0 has been relocated to org.apache.ant:ant:jar:1.7.0rn[INFO] rn[INFO] --- <em>maven</em>-clean-plugin:2.4.1:clean (default-clean) @ obe ---rn[INFO] Deleting D:\workspace\obe\targetrn[INFO] rn[INFO] --- <em>maven</em>-mule-plugin:1.6:attach-test-resources (default-attach-test-resources) @ obe ---rn[INFO] attaching test resource D:\workspace\obe\src\main\apprn[INFO] rn[INFO] --- <em>maven</em>-resources-plugin:2.6:resources (default-resources) @ obe ---rn[INFO] Using 'UTF-8' encoding to copy filtered resources.rn[INFO] Copying 5 resourcesrn[INFO] rn[INFO] --- <em>maven</em>-compiler-plugin:2.3.2:compile (default-compile) @ obe ---rn[INFO] Compiling 74 source files to D:\workspace\obe\target\classesrn[WARNING] \workspace\obe\src\main\java\com\travelsky\esb\services\obe\components\AVComponent.java:[31,31] 警告:com.sun.image.codec.jpeg.TruncatedFileException 是 Sun 的专用 API,可能会在未来版本中删除rn[WARNING] \workspace\obe\src\main\java\com\travelsky\esb\services\obe\components\AVForObeComponent.java:[31,31] 警告:com.sun.image.codec.jpeg.TruncatedFileException 是 Sun 的专用 API,可能会在未来版本中删除rn[INFO] rn[INFO] --- <em>maven</em>-resources-plugin:2.6:testResources (default-testResources) @ obe ---rn[INFO] Not copying test resourcesrn[INFO] rn[INFO] --- <em>maven</em>-compiler-plugin:2.3.2:testCompile (default-testCompile) @ obe ---rn[INFO] Not compiling test sourcesrn[INFO] rn[INFO] --- <em>maven</em>-surefire-plugin:2.14.1:test (default-test) @ obe ---rn[INFO] ------------------------------------------------------------------------rn[INFO] BUILD FAILURErn[INFO] ------------------------------------------------------------------------rn[INFO] Total time: 2.864srn[INFO] Finished at: Thu Nov 20 08:36:37 CST 2014rn[INFO] Final Memory: 19M/47Mrn[INFO] ------------------------------------------------------------------------rn[ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:2.14.1:test (default-test) on project obe: Execution default-test of <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:2.14.1:test <em>failed</em>: Plugin org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:2.14.1 or one of its dependencies could not be resolved: Failed to collect dependencies for org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:jar:2.14.1 (): Failed to read artifact descriptor for org.apache.<em>maven</em>.plugin-tools:<em>maven</em>-plugin-annotations:jar:3.2: The repository system is offline but the artifact org.apache.<em>maven</em>.plugin-tools:<em>maven</em>-plugin-tools:pom:3.2 is not available in the local repository. -> [Help 1]rn[ERROR] rn[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.rn[ERROR] Re-run Maven using the -X switch to enable full debug logging.rn[ERROR] rn[ERROR] For more information about the errors and possible solutions, please read the following articles:rn[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionExceptionrnrn[/code]rnrn[b]运行方式:[/b]rn[img=https://img-bbs.csdn.net/upload/201411/20/1416447015_620848.png][/img]rnrn请大婶帮忙看一下,十分谢谢!
Maven实战(三)---插件动态打包
Maven在用插件动态打war包的时候出现这样的错误: [ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-war-plugin:2.5:war (default-war) on project MavenProj1: Error assembling WAR: webxml attribute is required (o
cargo-maven2-plugin插件版本与tomcat版本不兼容问题
将Web项目自动部署到tomcat服务器时,遇到了cargo-<em>maven</em>2-plugin插件版本与tomcat版本不兼容问题,其中pom.xml中相关配置信息如下: &amp;lt;groupId&amp;gt;org.codehaus.cargo&amp;lt;/groupId&amp;gt; &amp;lt;artifactId&amp;gt;cargo-<em>maven</em>2-plugin...
maven中无法下载依赖
Could not resolve dependencies for projectFailed to <em>execute</em> <em>goal</em> on project otsstreamreader: Could not resolve dependencies for project com.alibaba.datax:otsstreamreader:jar:0.0.1-SNAPSHOT: Could not ...
求救:关于eclipse maven :Failed to execute goal org.apache.maven.plugins:maven-compil
[ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-compiler-plugin:2.3.2:compile (default-compile) on project wms: Compilation failurern[ERROR] Failure executing javac, but could not parse the error:rn[ERROR] 错误: 读取C:\Users\Administrator\.m2\repository\net\sf\jasperreports\jasperreports\4.7.1\jasperreports-4.7.1.jar时出错; error in opening zip filern[ERROR] 错误: 读取C:\Users\Administrator\.m2\repository\jfree\jfreechart\1.0.12\jfreechart-1.0.12.jar时出错; error in opening zip filern[ERROR] 错误: 读取C:\Users\Administrator\.m2\repository\eclipse\jdtcore\3.1.0\jdtcore-3.1.0.jar时出错; error in opening zip filern[ERROR] 错误: 读取C:\Users\Administrator\.m2\repository\org\apache\poi\poi-ooxml-schemas\3.7\poi-ooxml-schemas-3.7.jar时出错; error in opening zip filern[ERROR] 错误: 读取C:\Users\Administrator\.m2\repository\org\codehaus\groovy\groovy-all\1.7.5\groovy-all-1.7.5.jar时出错; error in opening zip filern[ERROR] 警告: [options] 未与 -source 1.6 一起设置引导类路径rn[ERROR] 5 个错误rn[ERROR] 1 个警告rn[ERROR] -> [Help 1]rn[ERROR] rn[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.rn[ERROR] Re-run Maven using the -X switch to enable full debug logging.rn[ERROR] rn[ERROR] For more information about the errors and possible solutions, please read the following articles:rn[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureExceptionrnrn这要是这几天换了开发环境 使用的64位的win7,eclipse和jdk都是32位的 因为之前查到32位的程序可以在64位上运行,希望各位前辈给出指导,我已经试过一些办法,网上查询加上自己乱搞无果才来求救的,麻烦各位了。 rn对了 它提示的那几个jar包在本地是有的
运行maven clean报错解决
[ERROR] Failed to <em>execute</em> <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-clean-plugin:2.4.1:clean (default-clean) on project cboss-framework: Execution default-clean of <em>goal</em> org.apache.<em>maven</em>.plugins:<em>maven</em>-clean-
编译开源监控cat报错
照着CAT的安装部署教程编译CAT,报错了: [ERROR] Failed to <em>execute</em> <em>goal</em> org.unidal.<em>maven</em>.plugins:plexus-<em>maven</em>-plugin:2.2.0:plexus (generate plexus component descriptor) on project cat-client: The plugin org.unidal.ma...
IDEA 通过maven 创建项目问题解决
错误:<em>maven</em> [ERROR] Maven execution terminated abnormally (exit code 1)解决:File | Settings | Build, Execution, Deployment | Build Tools | Maven | RunnerVM-Options: -DarchetypeCatalog=internal在创建项目的时候在prop...
源码编译zepplin踩过的那些坑
最近项目需要从源码安装zepplin,所以就来试下源码安装。 官方教材: http://zeppelin.apache.org/docs/0.7.3/<em>install</em>/build.html Step1. 确定系统环境和需要的各软件版本 Centos6.7 Orace JDK1.8 Hadoop 2.6.0-cdh5.10.2 hbase 1.2.0-cdh5.10.2 spark 2.
[war打包]在maven-antrun-plugin复制更改了配置文件但是maven-war-plugin打包出来配置文件没变化(草稿)
前言 &amp;amp;amp;背景介绍 在某个java-web项目中,需要根据<em>maven</em>的profile的配置进行properties文件的切换, 例如,项目的配置文件结构如下: 在resources文件夹下面分别有profiles文件夹及conf文件夹【重点关注】, profiles下面有三个环境,分别是dev,test,product,而conf的配置文件都是跟随开发人员选择的环境【dev,te...
Maven之——插件配置与解析
摘要: 掌握插件配置、插件解析依赖机制、常用插件仓库、对Maven插件以及仓库做出总结。
maven查找所有依赖的license类型
mvn project-info-reports:dependencies
dubbo-admian的打包和平台搭建
本文简单介绍下dubbo-admin的搭建过程,包括dubbo-admin的打包细节,以及在打包过程中jdk8的一些坑的解决。
rocketmq-console-ng编译后jar
rocketmq-console-ng 编译后的jar, jdk1.7 已配置好rocketmq服务, rocketmq.config.namesrvAddr=127.0.0.1:9876 项目访问url;http://127.0.0.1/rocketmq 项目启动java -jar rocketmq-console-ng-1.0.0.jar
maven常用插件plugin配置详解
先将我用到的自定义变量贴过来,防止插件中出现一些变量,大家不理解    Java代码            tools      UTF-8     project.build.name:  用来定义war包名称   project.build.sourceEncoding:  用来定义资源文件的编码格式   下面开始讲解常用的<em>maven</em>插件配置
win10下导jar包入Maven仓库出错的解决方法
[ERROR] The <em>goal</em> you specified requires a project to <em>execute</em> but there is no POM in this directory (F:\jars). Please verify you invoked Maven from the correct directory. -> [Help 1] ——在win10下的解决方案在把ja
学习maven的各种问题
之前学习的时候网上找的资料,依旧各种乱,反正都弄下来了。  Maven常见问题解决 1. The container 'Maven Dependencies' references non existing library 解决方法,将eclipse中<em>maven</em>插件中“resolve dependencies from workspace projects”的选项取消  
maven的pom报plugins错误的解决方法.
转载来源:http://blog.sina.com.cn/s/blog_90aad2c90101lce4.html <em>maven</em>的pom报plugins错误的解决方法. 引用 Failure to transfer org.apache.<em>maven</em>.plugins:<em>maven</em>-surefire-plugin:pom:2.7.1 from http://repo1.<em>maven</em>.
导入CXF实例中的maven项目报错
今天想学习下CXF的开发,于是上apache官网下载了一个apache-cxf-2.7.8.zip包,解压缩后在samples目录下找了找,准备导入wsdl_first_soap12项目研究下,由于这是个<em>maven</em>工程,于是在springsource中以<em>maven</em>工程方式导入这个项目,可惜导入就报错了   报错信息: ArtifactTransferException: Failure to
maven依赖的项目无法打包
今天在一个子项目开发完成准备做另外的子项目,但需要依赖已经做好的子项目,始终无法打成jar包,最终在网上找到解决方法。将<em>maven</em>里面的***.lastUpdate 和 _remote.properties删除后,cmd执行mvn clean <em>install</em>就成功了 ***.lastUpdate 和 _remote.properties是什么? Maven在下载仓库中找不到相应资源时,
maven-war-plugin根据环境打包资源
声明:本文参考资料来自互联网 J2EE项目在开发时,需要根据不同环境适配资源文件,<em>maven</em>提供了war-plugin这款打包插件,方便完成这个适配。 首先配置<em>maven</em> profile,再次不再详述,参见官方文档。demo中,prod的资源依旧放在src/main/resources中,dev、qa资源置于src目录外。可根据实际情况调整。 dev
Maven错误总结
错误1 导入<em>maven</em>后,项目报错,其中点开pom文件后,报错情况如图: 单击顶端的Overview后侧的红色提示,弹出如下详细信息。 仔细查看上图中的详细信息,发现错误原因是缺少了jar包“org.apache.commons:commons-lang3:jar:3.3.2”. 打开<em>maven</em>中设置的jar包路径文件夹,并找到缺少jar包的具体路径,删除该文件夹。 按住alt+F5,弹出如图对话...
maven 启动 报错 Fatal error compiling: 无效的目标发行版
http://news.tuxi.com.cn/news/119999990123162/31622105.html http://lyking2001.iteye.com/blog/837440 ******************************************************************** ERROR] Failed to <em>execute</em> go
jenkins maven编译打包找不到依赖库的解决办法
今天开发人员工程环境中新引入了json-lib-2.4.jar,通过jenkins调用<em>maven</em>自动编译打包一直报错找不到此依赖包, 具体如下: [ERROR] Failed to <em>execute</em> <em>goal</em> on project SP_FrontStage: Could not resolve dependencies for project com.hddata.steganalysis:S
jquery/js实现一个网页同时调用多个倒计时(最新的)
jquery/js实现一个网页同时调用多个倒计时(最新的) 最近需要网页添加多个倒计时. 查阅网络,基本上都是千遍一律的不好用. 自己按需写了个.希望对大家有用. 有用请赞一个哦! //js //js2 var plugJs={     stamp:0,     tid:1,     stampnow:Date.parse(new Date())/1000,//统一开始时间戳     ...
Acdsee12.0中文破解版下载
Acdsee12.0中文破解版,直接解压缩安装就行了,什么都不用管 相关下载链接:[url=//download.csdn.net/download/caozhaoyuan2000/3597546?utm_source=bbsseo]//download.csdn.net/download/caozhaoyuan2000/3597546?utm_source=bbsseo[/url]
网页视频播放插件下载
最近做的一个项目,网页中需要播放视频。 这里包括 我自己做的java工程的jsp里的 demo 和 js插件包..。 不用下载其他播放插件,轻巧简捷 只需两步: 1.把代码全部复制,更改一下视频路径 2.把js包放入项目里。然后访问html或者jsp页面即可 下面Html 或jsp页面代码 拷过去 改一下视频路径(有一些汉字注释 可以删掉) <script type="text/javascript" src="<%=request.getContextPath()%>/js/player/images/swfobject.js"></script> <div class="video" 相关下载链接:[url=//download.csdn.net/download/maxwell_chia/8297631?utm_source=bbsseo]//download.csdn.net/download/maxwell_chia/8297631?utm_source=bbsseo[/url]
GIF Movie Gear V4.2.3 汉化版下载
GIF动画制作软件,几乎有需要制作GIF动画的编辑功能它都有,无须再用其它的图型软件辅助。它可以处理背景透明化而且做法容易,做好的图片可以做最佳化处理使图片减肥,另外它除了可以把做好的图片存成GIF的动画图外,还可支援PSD,JPEG,AVI,BMP,GIF,与AVI格式输出。 相关下载链接:[url=//download.csdn.net/download/coodoy/2267946?utm_source=bbsseo]//download.csdn.net/download/coodoy/2267946?utm_source=bbsseo[/url]
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 python基础教程2 python培训2个月
我们是很有底线的