微信注册页,能用jquery吗?想兼容尽可能多的移动端浏览器

banditgao 2015-06-17 10:35:54


如上,需要开发一个微信上看的注册页,最上面还有一个小图,有验证码。

功能是:需要验证字段合法性、需要异步验证验证码(通过才能提交)、用ajax提交到别的域。

只对非移动端的系统熟悉一些,只会硬写原生js还有jquery稍微熟悉一些。

所以想用jquery,肯定需要兼容主流系统的移动浏览器。

不知道选jquery哪个版本比较好,听说还有jquery-mobile版本,到底怎么选,请帮我推荐一下。另外需要注意些什么?

谢谢啊!

...全文
315 6 打赏 收藏 转发到动态 举报
写回复
用AI写文章
6 条回复
切换为时间正序
请发表友善的回复…
发表回复
Lucky_502 2015-08-07
  • 打赏
  • 举报
回复
为什么我写做的一个类似摇一摇的功能微信内置浏览器完全不支持JQ?无论哪个版本,就连
$(document).ready(function(){ alert("123");}
这句话都不支持
KK3K2005 2015-06-17
  • 打赏
  • 举报
回复
微信注册页么 应该是在微信中打开 就是用微信自己的内置浏览器 兼容要求很低 直接写吧 jq后面的版本应该都没问题
Go 旅城通票 2015-06-17
  • 打赏
  • 举报
回复
微信对部分的js功能不支持,不过ajax,dom操作这种是没有问题的。移动端浏览器如chrome应该都支持
蝶恋花雨 2015-06-17
  • 打赏
  • 举报
回复
没问题。可以。还可以用flat-ui
香蕉猪 2015-06-17
  • 打赏
  • 举报
回复
需要兼容主流系统的移动浏览器,,,那就html5+css3+jq就是了。。。。 就注册页面而言,,,原生jq就行了。。。没必要搞jq-mobile,之前我用jq-mobile,,,有局限性,,,并不是那么好用。。。
banditgao 2015-06-17
  • 打赏
  • 举报
回复
热心人真不少,楼主我还需要再学习啊,谢谢谢谢
移动端兼容性问题解决方案

87,885

社区成员

发帖
与我相关
我的任务
社区描述
Web 开发 JavaScript
社区管理员
  • JavaScript
  • 无·法
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧