gradle配置不成功,求助贴 [问题点数:40分]

Bbs1
本版专家分:7
结帖率 40%
Bbs5
本版专家分:3947
版主
Blank
签到新秀 累计签到获取,不积跬步,无以至千里,继续坚持!
Blank
回归勋章 授予重新回归CSDN的真爱粉用户,我们不会让你失望哒!
Blank
GitHub 绑定GitHub第三方账户获取
Blank
红花 2015年7月 移动开发大版内专家分月排行榜第一
Bbs1
本版专家分:7
Bbs1
本版专家分:0
Bbs7
本版专家分:24438
Blank
GitHub 绑定GitHub第三方账户获取
Blank
红花 2018年12月 移动开发大版内专家分月排行榜第一
2018年11月 移动开发大版内专家分月排行榜第一
2018年10月 移动开发大版内专家分月排行榜第一
2018年3月 移动开发大版内专家分月排行榜第一
2018年1月 移动开发大版内专家分月排行榜第一
2017年12月 移动开发大版内专家分月排行榜第一
2017年11月 移动开发大版内专家分月排行榜第一
2017年10月 移动开发大版内专家分月排行榜第一
2017年9月 移动开发大版内专家分月排行榜第一
2015年11月 移动开发大版内专家分月排行榜第一
2015年10月 移动开发大版内专家分月排行榜第一
Blank
黄花 2019年7月 移动开发大版内专家分月排行榜第二
2018年4月 移动开发大版内专家分月排行榜第二
2016年4月 移动开发大版内专家分月排行榜第二
Blank
蓝花 2017年8月 移动开发大版内专家分月排行榜第三
2016年7月 移动开发大版内专家分月排行榜第三
2015年12月 移动开发大版内专家分月排行榜第三
solve Error:Could not find common.jar (android.arch.core:common:1.0.0). Searched in the following
Error:Could not find common.jar (android.arch.core:common:1.0.0).Searched in the following locations:    https://jcenter.bintray.com/android/arch/core/common/1.0.0/common-1.0.0.jar对于这个问题,问题出在app build...
新装Android Studio中Gradle下载慢、Could not get resource 'https://jcenter.bintray.com/...'问题
Gradle是一个版本控制以及灵活构建app的应用,但Gradle的使用有很多坑: 比如Android Studio(以下简称AS)在构建第一个新工程的时候自动下载<em>gradle</em>速度很慢.. 或者Gradle在自动下载网络库的时候经常Could not get resource 'https://jcenter.bintray.com/...' 本文来解决这些问题: 问题一:Gradle在A...
第一次构建 android studio 项目的时候 dl.google.com/下的包加载不了
小白入坑安卓,新建的工程一直在构建项目,但是有如下错误: 开头为 dl.google.com/ 的包都不能下载下来,但是开头为 jcenter.bintray.com 的包都能下载下来 。 似乎不是网
Android Studio:Error:Could not find com.android.tools.build:gradle:XXX解决方法
Android Studio下的 Error:Could not find com.android.tools.build:<em>gradle</em>:XXX解决方法
bug: Could not get resource 'https://jcenter.bintray.com/com/
android studio 编译时碰上了 &amp;gt; Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/<em>gradle</em>/1.3.1/<em>gradle</em>-1.3.1.pom'. &amp;gt; Could not HEAD 'https://jcenter.bintray.co...
转 com.android.tools.build:gradle:X.XX.XX:gradle.jar 插件无法下载问题
转自 com.android.tools.build:<em>gradle</em>:X.XX.XX:<em>gradle</em>.jar 插件无法下载问题 在使用Android Studio 这个IDE时,出现com.android.tools.build:<em>gradle</em>:X.XX.XX:<em>gradle</em>.jar 插件无法下载问题 可能的原因就是网速不好或者依赖仓库的下载网址被墙了,可以<em>配置</em>代理试试。比如,android stu...
Gradle sync failed: Could not HEAD 'https://dl.google.com/问题
Gradle sync failed: Could not HEAD ‘https://dl.google.com/dl/android/maven2/com/android/tools/build/<em>gradle</em>/3.1.0/<em>gradle</em>-3.1.0.pom’ 解决 最近使用 IDEA<em>配置</em>SDK进行android编程,项目<em>gradle</em> sync 一直失败,内心崩溃,查看原因,dl.google.c...
Gradle安装遇到的坑
话说: 各位读者盆友,晚上好!寡人小美哈。这里分享下今天遇到的一个小坑,也是花了点时间才想到解决方案。 目录 一、问题背景 二、解决方案 三、总结 环境:Mac Book Air 难度系数:★☆☆ ☆☆ 建议用时:30min 一、问题背景 Mac下面安装Gradle,还不简单得跟玩似的?是的,确实很简单。下载个<em>gradle</em>.3.5的包,<em>配置</em>.bash_profile的...
Android Studio三种方式导入外部资源 以及 报错处理
android studio提供了三种方式导入外部资源:1. Library dependency – 在线添加、需联网下载2. File dependency – 从本地添加一些jar包(要先将jar包拷贝到项目的libs文件夹下)3. Module dependency – 从本地添加带有源码的库工程(要先 import Moudle 将库工程导入项目中) 其中第三种方式导入会报一些错误,这里
build:gradle:1.2.3 available for offline mode.
Error:No cached version of com.android.tools.build:<em>gradle</em>:1.2.3 available for offline mode. <a href=
Android Studio不能获取远程依赖包的解决方法
       最近被一个AS的sync问题困扰,在引入远程依赖包的时候,会出现一个sync错误,提示找不到这个类库。然而,并不是所有的工程都会出现这个问题,有的工程引入同样的类库却没有问题。        Error:(25, 13) Failed to resolve: com.jakewharton:butterknife:5.1.1        网上查了下(http://stack...
android studio报错Failed to resolve
![图片说明](https://img-ask.csdn.net/upload/201903/06/1551857507_118422.png) 不记得做了什么事 就突然这样 新建项目可以运行 这个项目用很久之前的代码 也是不能运行 帮忙解决可发红包 qq291808500
Android Studio3.0升级gradle遇到的坑
升级了android studio3.0后,对于文件的搜索和方法中参数的使用,是一个重大的改变,但升级<em>gradle</em>后,缺出现很多的问题。个人整理一下,希望对大家有所帮助。 说明:我原来的环境是as2.3+gralde2.14.1+plugin2.2.3 升级后的环境是:as3.0+<em>gradle</em>4.2.1+plugin3.0.0 1、 Error:(82, 0) Ca
请教大家,我的Android Studio在Gradle进行Sync时出现了问题,该怎么解决呢?
org.<em>gradle</em>.internal.resource.transport.http.HttpRequestException: Could not GET 'https://dl.google.
Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.1.2/gradle-3
在google之后,看到一片小文章写到的,对我有用把这个勾选一下就可以了
AS gradle Could not get resource
拖到现在才用 AS 3.2版本,唉~~~ 打开旧项目时报 “<em>gradle</em> Could not get resource ....... ” 。 是因为要下载旧项目中的<em>gradle</em>版本 ,例如 4.1 (AS 3.2 自带的<em>gradle</em> 版本是4.6)。如果没有翻墙,可能一直编译不了。 解决方法: <em>成功</em>安装 AS 3.2后,新建一个项目,把里面的<em>配置</em>复制到旧项目中 之后可能...
gradle build error : Could not get resource
bitcoinj: <em>gradle</em> clean build error: https://github.com/snowdream/react_native_helloworld/issues/2 It is because GFW, as you know. Solution: replace jcenter() with jcenter { url &quot;http://jcenter.bi...
Could not GET 'https://dl.google.com/dl/android/maven2...pom'
解决方案: 勾选之后,apply,ok,之后刷新项目或者 希望对你有帮助。
配置gradle错误问题
ofd-&gt;如果实在不行 就用原来的代码 再改一遍 不要太麻烦的改 问题永远解不完 一定要备份 问题 The APK file F:\hnswnew51\MXClient\build\outputs\apk\debug\MXClient-debug.apk does not exist on disk. 最右边的是重点 一定要注意 build的文件的使用 Error while Insta...
Windows下配置的环境变量未生效
Windows下<em>配置</em>的环境变量未生效
win7配置gradle环境变量失败
路径已经<em>配置</em>完毕,在cmd打印path是有<em>gradle</em>路径的,打印%<em>gradle</em>-home&也是<em>gradle</em>路径,但是就是打印<em>gradle</em> -version时提示geradle不是内部命令
Android Studio升到2.3后出现问题
Error:Server sent an unsupported extension: type_35 Error:A problem occurred configuring root project 'vsapp2-1'. > Could not resolve all dependencies for configuration ':classpath'. > Could not resolve org.greenrobot:greendao-<em>gradle</em>-plugin:3.2.0. Required by: project : > Could not resolve org.greenrobot:greendao-<em>gradle</em>-plugin:3.2.0. > Could not get resource 'https://jcenter.bintray.com/org/greenrobot/greendao-<em>gradle</em>-plugin/3.2.0/greendao-<em>gradle</em>-plugin-3.2.0.pom'. > Could not HEAD 'https://jcenter.bintray.com/org/greenrobot/greendao-<em>gradle</em>-plugin/3.2.0/greendao-<em>gradle</em>-plugin-3.2.0.pom'. > Server sent an unsupported extension: type_35 > Could not resolve com.tencent.bugly:tinker-support:1.0.8. Required by: project : > Could not resolve com.tencent.bugly:tinker-support:1.0.8. > Could not get resource 'https://jcenter.bintray.com/com/tencent/bugly/tinker-support/1.0.8/tinker-support-1.0.8.pom'. > Could not HEAD 'https://jcenter.bintray.com/com/tencent/bugly/tinker-support/1.0.8/tinker-support-1.0.8.pom'. > Server sent an unsupported extension: type_35
Studio中Gradle文件出问题的解决方式
Studio中Gradle文件出问题的解决方式   studio---android开发很好用的一款工具,有很多东西比起Eclipse很方便,但也会经常出现一些莫名其妙的错误    前几天公司后台弄好了,准备对接了,半个多月以来一直好好的项目突然就疯了,各种报错,各种解决,还是各种报错,并不是代码 问题,每次的错误都是在app的<em>gradle</em><em>配置</em>文件中报的,一会说<em>gradle</em>插件版本和stud
gradle文件中引入其他gradle文件
背景: 安卓项目中,<em>gradle</em>文件也逐渐变得臃肿起来,需要分开管理,否则一大堆在一起,就很难维护了。 解决方案: 采用apply from: 'xx.<em>gradle</em>'这样的语句就可以引入其他<em>gradle</em>文件了。 Demo(集成aspectj): 1.aspectj.<em>gradle</em> (存放目录: 项目根目录下) import org.aspectj.bridge....
使用apply from的gradle 插件脚本 不能访问某些class(Task)
2019独角兽企业重金招聘Python工程师标准&gt;&gt;&gt; ...
android studio gradle插件无法下载,Could not GET xxx, Received status code 400 from server: Bad Request
解决在Android项目<em>gradle</em> build时,总是报错Could not GET xxx, Received status code 400 from server: Bad Request的问题 在安卓项目编译的时候,<em>gradle</em>-xx-all.zip<em>配置</em>好了,还是不行,发现还是在去网络上下载东西,其实这时候下载的是<em>gradle</em>的编译插件,也就是build.<em>gradle</em>里的这个东西: ...
求问,Androidstudio 出现这种报错应该怎么办
Failed to resolve: com.android.databinding:baseLibrary:3.1.2 Failed to resolve: com.android.databind
org.gradle.api.resources.ResourceException: Could not get resource错误解决方法
1.点击File,打开setting: 2.搜索<em>gradle</em>,选择Android Studio,勾选上Enable embedded Maven repository即启用嵌入Maven 仓库 3.重新编译一遍,搞定!!!!!
解决IDEA gradle无法刷新的问题
参考 https://blog.csdn.net/qq_35434831/article/details/72235863 1、查看要导入项目的<em>gradle</em>版本,下载,直接services.<em>gradle</em>.org/distributions/<em>gradle</em>-4.0-milestone-2-all.zip 2、在setting查看idea的<em>gradle</em>路径 3、最终路径为 4、替换对...
as中Settings.gradle配置
Settings.<em>gradle</em>是整个Android里面<em>gradle</em>的最先执行的<em>配置</em>文件 他里面的内容主要就是为了告诉<em>gradle</em>这个project里面包含了多少个子projects需要编译 使用方法有两种: include ':app', ':lib1', ':lib2', ':lib3', ':lib4', 另外一种是...
Android Studio 初始化build.gradle下载资源失败
// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript {     repositories {         maven{ url 'http://maven.aliyun.com/nexus/content/groups/p...
aliyun maven用不了,解决办法
网上搜的,说再.m2的setting.xml中加上如上的<em>配置</em>,就可以访问下载阿里的maven仓库,但是我在创建的时候报错,下载不下来??然后百度了一个帖子,说修改成下面的<em>配置</em>就可以了:&amp;lt;mirror&amp;gt; &amp;lt;id&amp;gt;nexus-aliyun&amp;lt;/id&amp;gt; &amp;lt;mirrorOf&amp;gt;central&amp;lt;/mirrorOf&amp;gt; &amp;lt;name&amp;...
Android Studio Gradle 依赖第三方库连接超时 reader time out 或者 Could not download xxx 等问题的完美解决方案
Android Studio Gradle 依赖第三方库连接超时 reader time out 或者 Could not download xxx 等问题的完美解决方案 在新mac电脑上<em>配置</em>好了Androidstudio 开发环境和软件后,一新建项目就懵逼了,直接报错。博主被此类问题困扰了三天,在各种查资料,搜视频后,终于找到了解决方案,特此记录下来: 问题 解决方案如下 ...
Android 报错处理:read time out 或者 could not download ... could not get resource ...could not Get ...
可能原因: 网络问题,被墙,<em>配置</em>源地址不存在该文件 解决方案: 1、关闭代理 No Proxy,注释掉<em>gradle</em>.properties 文件下<em>配置</em>的网络代理 2、在项目的 Gradle 文件里,修改<em>配置</em>源(将 google() 和 jcenter() 换成下列中间几项),再sync,make project buildscript { repositories { ...
Gradle Received status code 403 解决方式
方法一:查看C:\Users\Administrator.C64-20190415FMK\.<em>gradle</em> 下面的<em>gradle</em>.properties文件,屏蔽后四行,如果已经屏蔽了 方法二: 查看项目的根目录下的build.<em>gradle</em> ,删除jcenter{ url "http://jcenter.bintray.com/"},不使用http repositories { go...
Maven和Gradle的使用问题
在企业中用Maven的多还是Gradle的多 以后的趋势是倾向于Gradle 呢? 还是说Maven会淘汰呢?
gradle中如何加入依赖的jar包?
我要在<em>gradle</em>部署的工程中加入fastdfs_client_v1.24.jar这个jar包,语法应该怎么写呢?大神求解!
Gradle中的lombok依赖报错
    最近,因为一些项目的原因,需要用到Lombok,lombok的安装如下:在IDEA环境中:(1)首先安装插件:(2)Enable annotation(3)下载依赖:这个是最坑的,因为这个时候官网提供的依赖如下:这边是provided,这个使用provided无法下载依赖,必须使用compile,原因不明。(4)使用lombok,记住导入的包为lombok.*...
Could not find com.android.tools.build:aapt2:3.2.1-4818971.
Android Studio升级到3.2.1后,运行项目报如下错: Could not find com.android.tools.build:aapt2:3.2.1-4818971. Searched in the following locations:     file:/D:/AndroidStudio/sdk/extras/m2repository/com/android/tools...
最新版gradle 运行没有反应
<em>配置</em>如下: distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME
gradle编译spring源码过程问题整理
最近在看spring boot ,发现好多是spring中的技术或概念,于是找了一本书《Spring源码深度解析.pdf》,开始学习下源码是从git上下的,先把https://github.com/spring-projects/spring-framework  克隆成我的项目,然后为了节省时间,下载zip的方式下载到本地,接下来就是导入到开发工具eclipse了,在cmd执行:<em>gradle</em> c...
AndroidStudio3.0及以上下载jar包失败,报错 UncheckedIOException、HttpRequestException、ArtifactResolveException等
Android Studio 3.0及以上报错 UncheckedIOException、HttpRequestException、ArtifactResolveException等等问题描述错误包括(最后附完整错误代码):尝试解决方案最终解决方案:完整的错误代码 问题描述 本人尝试的项目是使用okHttp.jar的一个网络APP,但这些个错误的解决方案适用于所有工程 错误包括(最后附完整错误代码...
Error:Could not install Gradle distribution from 'https://services.gradle.org/distributions/gradle-2
打开项目外层的build.<em>gradle</em>,将classpath的值换成studio中的<em>gradle</em>版本 classpath 'com.android.tools.build:<em>gradle</em>:2.1.0' distributionUrl=https\://services.<em>gradle</em>.org/distributions/<em>gradle</em>-2.10-all.zip 然后syncno
【Android studio】 新建项目后报错:Could not GET 'https://dl.google.com/dl/android/maven2/com/android/suppor……
Android studio 新建项目后报错:Could not GET ‘https://dl.google.com/dl/android/maven2/com/android/suppor……’ 点击链接下载一个appcompat-v7–26.1.0.pom的文件 rebuild 项目,发现还是报各种错 在网上找了很多解决办法,很多都说要修改代理,发现自己的代理也早就改了,enable也都...
报错 Error:Could not install Gradle distribution from 'https://services.gradle.org/distributions/gradl
http://stackoverflow.com/questions/32887623/errorcould-not-run-build-action-using-<em>gradle</em>-installation-<em>gradle</em>-2-4-android  上面网址是网上的解决方案,貌似不是理想的解决方案 我是这样解决的 点击AS 中 project structure  在SDK locatio
Android Studio 编译出错,求助!万分感谢!
这个项目是从eclipse中导入到Android Studio的 我一编译就出错,信息如下: Error:A problem occurred configuring root project '1'
关于Android studio的报错无法download某些文件的解决方法
问题背景的描述 我在之前的学校的Android开发课的时候使用了eclipse的开发,后来在网上找课的时候发现现在基本都用Android studio来开发,后面我准备安装Android studio,(我在使用ecipse来开发Android的时候是使用镜像代理来下载sdk和images的,以至于后来我在安装好Android studio的时候也照搬eclipse设置了代理)然后新建pr...
android studio 启动报错Error:Could not find common.jar 怎么解决啊!!!
Error:Could not find common.jar (android.arch.core:common:1.0.0). Searched in the following location
救命!!!!!!!!!关于Compilation failed的问题,详情请进
我写了个dbsql.java文件,在jbuild6下编译生成dbsql.class文件,用来封装连库等信息(db2数据库)。再写一个jsp文件来应用,在jbuild6环境下测试通过。然后高高兴兴将db
Adroid Studio无法找到maven_push.gradle文件
Error:(32, 0) Could not read script 'C:\Study\smarthome+\SmartHome+\maven_push.<em>gradle</em>' as it does not exist. Adroid Studio将GitHub上的开源项目导入时无法找到maven_push.<em>gradle</em>文件
导入工程出现“文件提前结束”错误,请大佬帮忙看看!
我导入别人的工程,之前这个工程在别的电脑上是编译通过了的,然后我把程序导入我的电脑就有如下报错: org.<em>gradle</em>.api.tasks.TaskExecutionException: Execut
AndroidStudio报错 Could not install Gradle distribution
Android Studi报错: Could not install Gradle distribution from 'http://services.<em>gradle</em>.org/distributions/<em>gradle</em>-xxx-all 解决办法: 先去下载<em>gradle</em>-xxx-all压缩包,然后解压到AndroidStudio安装路径下<em>gradle</em>目录,重启。
Android Studio中配置AndroidAnnotations,遇到的问题及解决方法
搞安卓开发以来,一直使用的Eclipse,Google出了AndroidStudio(简称AS)以后,一直忙于项目没有时间试试,今天装了一个适应一下,然后想在里面用上AndroidAnnotions(简称AA)(一个挺不错的开源框架,用起来特别方便,如果你现在在用Spring的注解,就会想在android中也来这么一个)。<em>配置</em>的时候遇到点问题!!!!! 1.首先,你可以上AndroidA
Android Architecture Components 下载依赖失败
最近想要 研究####Android Architecture Components 奈何本地的<em>gradle</em>一直拉不下源码,尝试切换到云服务器编译,依然落不下代码 提示错误FAILURE: Build failed with an exception.* What went wrong: A problem occurred configuring project ':app'. > Could
Android studio build遇到的问题Could not resolve com.android.support:multidex:1.0.1.
我一直不能引入这个support 包, Error:A problem occurred configuring project ':app'. > Could not resolve all de
androidstudio运行时总是报错
Error:Gradle: A problem occurred configuring root project 'MyApplication'. > Could not resolve all dependencies for configuration ':classpath'. > Cannot resolve external dependency com.android.tools.build:<em>gradle</em>:1.3.0 because no repositories are defined. Required by: :MyApplication:unspecified 不是代码问题,试过重新安装<em>配置</em>jdk和下载插件sdk,通过新生成项目验证运行效果和dos系统下javac的确定没问题; 现在是系统的资源文件build.<em>gradle</em>总是报1.3.0的错,网上下载了一个1.5.0的架包导进去,但是还是不行,请大神指点
Error:Unable to resolve dependency for ':app@debug/compileClasspath': Could not
我在更新android studio 之后 新建一个项目 出现如下错误: Error:Unable to resolve dependency for ':app@debug/compileClass
android studio 遇到的问题
![图片说明](https://img-ask.csdn.net/upload/201808/13/1534091585_761709.png) ``` dependencies { implementation fileTree(dir: 'libs', include: ['*.jar']) implementation 'com.android.support:appcompat-v7:26.+' implementation 'com.android.support.constraint:constraint-layout:1.0.2' testImplementation 'junit:junit:4.12' //androidTestImplementation 'com.android.support.test:runner:1.0.2' //androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2' } ``` 这三个依赖 注释掉 就没有问题不注释就会出现 Could not get resource 'https://dl.google.com/dl/android/maven2/junit/junit/4.12/junit-4.12.pom'. > Could not HEAD 'https://dl.google.com/dl/android/maven2/junit/junit/4.12/junit-4.12.pom'. Received status code 400 from server: Bad Reques 这种问题 怎么解决呢 很急
studio使用gradle成功build,idea却失败
报错如下: ``` Error:Gradle: A problem occurred configuring root project 'MyApplication1'. > Could not resolve all dependencies for configuration ':classpath'. > Could not resolve com.android.tools.build:<em>gradle</em>:2.2.2. Required by: :MyApplication1:unspecified > Could not resolve com.android.tools.build:<em>gradle</em>:2.2.2. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/<em>gradle</em>/2.2.2/<em>gradle</em>-2.2.2.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/<em>gradle</em>/2.2.2/<em>gradle</em>-2.2.2.pom'. Received status code 400 from server: Bad Request ``` 十分诡异!studio和idea 的 <em>gradle</em>设置几乎是一样的!<em>gradle</em>对应的版本也是存在的 ![图片说明](https://img-ask.csdn.net/upload/201704/20/1492659180_279864.png) 看了下网上很多文章,并没有解决问题! 是否有人遇到过相似问题,并且<em>成功</em>解决问题呢?
无法访问gradle的pom文件
如图,关掉ss代理访问国内链接 开关ss代理设置国外链接或者直接goole() 以下选项开关状态都试过 mac系统,没有设置as内代理,设置过代理也不行,求解决方案,快抓狂了。
intellij idea 创建Android提示Could not download protobuf-java.jar或者gradle project sync failed.basic func
提示:Could not get resource 'https://jcenter.bintray.com/com/google/protobuf/protobuf-java/3.4.0/protobuf-java-3.4.0.jar' 方法: 1、手动打开网址https://jcenter.bintray.com/com/google/protobuf/protobuf-java/3.4....
Could not resolve com.android.tools.build:gradle:3.1.3
从第三方sdk下载例子后,用androidstudio打开,sync后发现无法报错 Could not resolve com.android.tools.build:<em>gradle</em>:3.1.3 从网上查了好多这样的文章,大都是将下图中选项改为选中, 同时将build.<em>gradle</em>中进行相应修改: repositories { google() jcenter() ...
gradle与jenkins编译常见报错及解决
一、jenkins编译错误总结 1.错误一:   /data/jenkins/workspace/tv-child-release/tvApp/libraryPrj/lecore/src/com/letv/core/utils/DevicesUtils.java:1335: error: cannot find symbol
Could not GET 'https://xxxxx.pom'. Received status code 400 from server: Bad Request
一个中秋回来,打开Android Studio 就发现报这个错,各种百度,一上午了没有丝毫进展。然后下午翻墙以后,又谷歌许久,stackoverflow都翻遍了,依然没能找到解决办法。引号里面的这个东西点进去是可以正常访问的,返回我一个下载连接。可Android Studio就是不能访问,然后我就想到是不是Android Studio的网络<em>配置</em>问题,这才想起来以前不知道是因为sdk还是什么玩意儿下...
如何解决Unity打包Gradle build failed问题
问题: CommandInvokationFailure: Gradle build failed. F:/Program Files/Unity/2019.3.0b3/Editor/Data/PlaybackEngines/AndroidPlayer/Tools\OpenJDK\Windows\bin\java.exe -classpath "F:\Program Files\Unity\2019.3.0b3\Editor\Data\PlaybackEngines\AndroidPlayer\Tools\<em>gradle</em>\lib\<em>gradle</em>-launcher-5.1.1.jar" org.<em>gradle</em>.launcher.GradleMain "-Dorg.<em>gradle</em>.jvmargs=-Xmx4096m" "assembleRelease" FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ':unityLibrary:packageReleaseResources'. > Could not resolve all files for configuration ':unityLibrary:_internal_aapt2_binary'. > Could not resolve com.android.tools.build:aapt2:3.4.0-5326820. Required by: project :unityLibrary > Could not resolve com.android.tools.build:aapt2:3.4.0-5326820. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/aapt2/3.4.0-5326820/aapt2-3.4.0-5326820.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/aapt2/3.4.0-5326820/aapt2-3.4.0-5326820.pom'. > Connect to mirrors.opencas.ac.cn:80 [mirrors.opencas.ac.cn/124.16.75.211] failed: Connection timed out: connect > Could not resolve com.android.tools.build:aapt2:3.4.0-5326820. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/aapt2/3.4.0-5326820/aapt2-3.4.0-5326820.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/aapt2/3.4.0-5326820/aapt2-3.4.0-5326820.pom'. > Connect to mirrors.opencas.ac.cn:80 [mirrors.opencas.ac.cn/124.16.75.211] failed: Connection timed out: connect 尝试过论坛里的方法,目前JDK的版本是1.8.0,SDK的版本是26.1.1,之前是25,但是因为报错需要26,所以升级上去了,但是还是没有解决 怀疑是环境变量设置的问题,但是小弟并非计算机专业,没有办法非常系统的debug,麻烦各位大佬帮我看看具体是哪里出现了问题 ![图片说明](https://img-ask.csdn.net/upload/201909/20/1568912455_512805.png)![图片说明](https://img-ask.csdn.net/upload/201909/20/1568912467_242775.png)![图片说明](https://img-ask.csdn.net/upload/201909/20/1568912486_584120.png)![图片说明](https://img-ask.csdn.net/upload/201909/20/1568912494_751240.png)![图片说明](https://img-ask.csdn.net/upload/201909/20/1568912502_553839.png)![图片说明](https://img-ask.csdn.net/upload/201909/20/1568912507_195203.png)
解决Gradle 'app'project refresh failed 报错 Could not read cache value问题
报错信息:Error:Could not read cache value from '/Users/luochuan/.<em>gradle</em>/daemon/2.2.1/registry.bin'. 解决方法
android studio 使用realm后报错 apt替换成annotationProcessor,按照提示改了依旧没有效果。
如图
关于gradle报错的一点笔记
最近用android studio导入一个项目. android studio 版本 3.1.3 项目地址https://github.com/LibreShift/red-moon 报错是接二连三 Cause: dl.google.com:443 Configuration on demand is not supported by the current version of the And...
求教!刚装好的Android studio,做 一测试工程,就出现一大堆 Unable to resolve dependency for 的问题
求教!刚装好的Android studio,做 一测试工程,就出现一大堆 Unable to resolve dependency for ':app@debug/compileClasspath':
总结项目编译遇到的几个问题(Android Studio Mac系统)
总结项目编译遇到的几个问题希望自己的一些解决问题的经历可以分享给需要的各位问题1:Gradle's dependency cache may be corrupt (this sometimes occurs after a network connection timeout.)问题描述解决方案原因问题二:Connect to dl.google.com:443 no response问题描述解...
开发中遇到的各种坑爹错误及修改
一、eclipse android开发<em>配置</em> (1)、sdk更新失败               出错问题: 下载并解压sdk之后,点击sdk manager.exe 下载更新,出现网址找不到的问题。               解决方案:1、在C:\Windows\System32\drivers\etc的hosts文档的最后加上74.125.237.1    dl-ssl.google.c
Android Studio 编译出错错误:Could not execute build using Gradle distribution 怎么处理 谢谢
以下是提示错误: Gradle: FAILURE: Build failed with an exception. * What went wrong: Execution failed for ta
gradle环境问题(项目一直Refreshing)原因与解决办法
1.引子刚开始从Eclipse转到Android studio时经常出现各种环境问题,最主要的就是在导入github项目时<em>gradle</em>出现问题,本篇博客主要讲解为什么会出现这些问题以及解决办法。希望能帮到同样被这些问题折磨的朋友们。 先来几张大家熟悉的图片吧 2.概念介绍首先需要知道andoid studio中<em>gradle</em>有一个Gradle version 和一个Android Plugi
mysql8 idea启动tomcat报错:java.sql.SQLException: Could not retrieve transation read-only status server
主要原因是 pom中用的mysql connect java 还是老版本的,没有适应新版本mysql8我用的是ali的maven仓库,搜索mysql8可以看到有mysql-connector-java-8.0.11.jar但是我本地的pom却还是5.1.34太低了,所以升级一下。更改pom中mysql jar为&amp;lt;dependency&amp;gt;  &amp;lt;groupId&amp;gt;mysql&amp;lt;...
Android studio gradle 无法获取 pom文件
Android studio 3.1 导入app项目后,<em>gradle</em>无法获取 pom文件 参考如下博文: https://blog.csdn.net/zengmingen/article/details/79877676
android studio 3.1.2版本 databinding 问题
使用3.1.2版本的Android studio 每修改一次布局文件xml文件都需要执行一次 rebuild 操作 原本是为了节省时间不用findviewbyid的,现在倒好,时间更长了 有没有不用每
Android Studio 常见问题
1.Error:A problem occurred configuring project ':MaterialPreference'. > Could not resolve all dependencies for configuration ':MaterialPreference:_debugCompile'.    > Could not find com.android.supp
使用android studio的gradle新建项目时候出现No cached version listing 或Enable Gradle 'offline mode'
使用android studio的<em>gradle</em>新建项目时候出现 Error:Unknown host 'downloads.<em>gradle</em>.org'. Enable Gradle 'offline mode' and sync project       Learn about configuring HTTP proxies in Gradle 或者出现 Error:No cac
Android Studio 3.2.1最新版,更新后编译程序报错“Could not find method jackOptions() for argum”
<em>求助</em>各位大神,一不小心手欠更新了Android Studio到最新的patch,更新以后原来编译<em>成功</em>的工程现在Make一直失败: 【报错内容】Could not find method jackOpt
AndroidStudio报错
Gradle sync failed: Could not GET 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-stdlib-jr
Android Studio Gradle下载位置在哪?
![图片说明](https://img-ask.csdn.net/upload/201605/01/1462037118_707009.png) 找了半天不知道在哪儿下载- -|| 求告知
linux下的Gradle编译环境搭建与使用
<em>gradle</em> 安装 安装的前提是<em>配置</em>完成JDK环境:Linux下jdk的<em>配置</em> 1、在官网下载 2、解压安装包到目录 /root/A 3、打开环境文件 sudo vim /etc/profile 4、写入环境变量: export GRADLE_HOME=/root/A/<em>gradle</em>-2.0 export PATH=$GRADLE_HOME/bin:$PATH 5、环境变量生
Android Studio 无法获取pom
个人遇到的问题有两种方案: 一 第一种方案 1.关闭防火墙,参考第二种方案的第3步 二 第二种方案 1.build.<em>gradle</em>文件中增加Maven仓库 allprojects { repositories { jcenter() google() maven { url 'http://maven.aliyun....
问题解决Unable to resolve dependency for ':app@debugAndroidTest/compileClasspath': Could not resolve
android-studio File->Settings->Build, Execution, Deployment->Gradle->Uncheck Offline work option.
Android Studio 解决resolve dependencies 'classpath'卡住
想必很多人都遇到过这种情况,特别是初学者,而出现这种情况的大部分原因都是代理问题! 如果没有代理的同学请务必搞一个代理,如果不知道如何设置代理请先看下面部分"设置代理",否则可以直接跳到"二.解决问题" 一 设置代理: 在file-settings-Appearance & Behavior - System Settings - HTTP Proxy里面设置。 根据情况设
Gradle sync failed: Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/g
Gradle sync failed: Could not GET ‘https://dl.google.com/dl/android/maven2/com/android/tools/build/<em>gradle</em>/3.2.0/<em>gradle</em>-3.2.0.pom’. Received status code 400 from server: Bad Request Consult IDE log for...
Android studio 新建项目后报错:Could not GET 'https://dl.google.com/dl/android/maven2/com/android/...问题解决
【Android studio】新建项目会出现这样的报错信息,每次搞得自己都很头疼,然后解决了又忘了,下次遇到了又不知道该如何解决了,所以将这次遇到的情况记下来,免得下次再遇到又是各种碰壁。 下面是当时遇到问题的部分代码: Caused by: org.<em>gradle</em>.api.resources.ResourceException: Could not get resource '...
Unable to resolve dependency for ':app@debug/compileClasspath': Could not resolve com.android.suppor
android studio3.xx出现以下错误: Unable to resolve dependency for ':app@debug/compileClasspath': Could not resolve com.android.support:appcompat-v7:28.0.0-rc01.Open FileShow Details Unable to resolve depend...
Gradle sync failed: Could not find xxxx.xx 之 强制刷新Gradle dependencies
最近开发过程中遇到一问题,在使用<em>gradle</em>依赖得时候一直报找不到某个远程依赖得包,由于该包是自己开发的,上传到了jcenter,第一次上传的时候有些错误,然后一直依赖不<em>成功</em>,后来又重新修改以后上传了,并且<em>成功</em>了,但是依赖这边还是不<em>成功</em>,并且错误日志显示依赖的是jar,如下图: 但是我上传的明明是aar,为什么一直去找jar呢,怪不得找不到呢,后来怀疑是因为第一次上传的时候失败,然后去添加依...
android studio flutter代理设置问题classpath 'com.android.tools.build:gradle:3.2.1'
前提 初次安装flutter,通过代理设置加快速度安装首次更新数据,但在添加设备并开始打包编译时出现classpath找不到的情况 1.在初次启动IDE的时候会提示更新各种SDK包,此时一般会直接设置代理,我的系统时Ubuntu18.04,所以直接代理了本地vpn,127.0.0.1 端口1080 2.在编译打包的时候出现了找不到相关的包,原因是flutter三个默认<em>配置</em>的地方采用了Goog...
解决 Could not resolve com.android.tools.build:gradle:3.1.3
android studio 升级到3.1.3后总会遇到莫名其妙的错误,前几天刚解决了项目 dependencies报错的问题。 解决android studio 升级到3.0+之后 项目 dependencies报错问题 现在又遇到了<em>gradle</em>版本的问题, Could not get resource 'https://dl.google.com/dl/android/maven2/co...
Android Studio项目Gradle构建实践
文章主要描述Android Studio中使用Gradle构建的9个模块,主要有: 1、defaultConfig 2、buildType 3、flavor 4、sourceSet 6、Dependencies
Android Studio下项目编译出错could not find com.android.tools.buildgradle:2.2.2
今天更新Android Studio后打开Project,报如下错误: Error:Could not find com.android.tools.build:<em>gradle</em>:2.2.2. Searched in the following locations:     file:/D:/Program Files/Android/android-studio/<em>gradle</em>/m2reposi
Java学习的正确打开方式
在博主认为,对于入门级学习java的最佳学习方法莫过于视频+博客+书籍+总结,前三者博主将淋漓尽致地挥毫于这篇博客文章中,至于总结在于个人,实际上越到后面你会发现学习的最好方式就是阅读参考官方文档其次就是国内的书籍,博客次之,这又是一个层次了,这里暂时不提后面再谈。博主将为各位入门java保驾护航,各位只管冲鸭!!!上天是公平的,只要不辜负时间,时间自然不会辜负你。 何谓学习?博主所理解的学习,它是一个过程,是一个不断累积、不断沉淀、不断总结、善于传达自己的个人见解以及乐于分享的过程。
JavaScript 权威指南(第四版) 示例程序下载
非常强大而权威的JavaScript权威指南 示例程序,讲解细致、详细,示例代码多。 相关下载链接:[url=//download.csdn.net/download/qiuzhj119/2632818?utm_source=bbsseo]//download.csdn.net/download/qiuzhj119/2632818?utm_source=bbsseo[/url]
编写高质量代码改善C#程序的157个建议下载
编写高质量代码改善C#程序的157个建议 陆敏技著 机械工业出版社 2011.10 原书扫描版 相关下载链接:[url=//download.csdn.net/download/lc___l/5136716?utm_source=bbsseo]//download.csdn.net/download/lc___l/5136716?utm_source=bbsseo[/url]
labview教程下载
labview教程 相关下载链接:[url=//download.csdn.net/download/u011422295/5764239?utm_source=bbsseo]//download.csdn.net/download/u011422295/5764239?utm_source=bbsseo[/url]
相关热词 c# 二进制截断字符串 c#实现窗体设计器 c#检测是否为微信 c# plc s1200 c#里氏转换原则 c# 主界面 c# do loop c#存为组套 模板 c# 停掉协程 c# rgb 读取图片
我们是很有底线的