使用VS2010调试时碰到的问题,请大神们帮忙解决,谢谢

l69566 2015-07-25 10:42:44
大致代码如下所示,进行代码调试时我在SFX8_StartInvOnce函数处无法设置断点,断点会自动跳到SFX8_StartInvContinue处。单步调试时调用SFX8_StartInvOnce函数时会执行到SFX8_StartInvContinue函数里去。把StartInvOnce函数里的代码随更改下(加了条语句 int i=0;)又正常了。

class SFX8_Base
{
public:
SFX8_Base(void);
virtual ~SFX8_Base(void);
public:
virtual int SFX8_Free() = 0;
virtual int SFX8_RegisterInvDataCallBack(const char *pIPAddr,PRFID_InvDataFunc pInvFunc, void *context) = 0;
virtual int SFX8_StartInvOnce(const char *pIPAddr) = 0;
virtual int SFX8_StartInvContinue(const char *pIPAddr) = 0;
virtual int SFX8_TagRead(const char *pIPAddr, int nMBType, int nStartOffset, INT32U accessPassword, int nWor dLength, INT8U *pRBuffer) = 0;
protected:
char m_pAddr[32];
int m_nPort;
int m_nServType;
};


class SFX8_Client : public SFX8_Base
{
public:
SFX8_Client(void);
virtual ~SFX8_Client(void);
public:
int SFX8_Init(const char *pAddr, int nPort, int nServType);
int SFX8_Free();
int SFX8_RegisterInvDataCallBack(const char *pIPAddr,PRFID_InvDataFunc pInvFunc, void *context);
int SFX8_StartInvOnce(const char *pIPAddr);
int SFX8_StartInvContinue(const char *pIPAddr);
int SFX8_TagRead(const char *pIPAddr, int nMBType, int nStartOffset, INT32U accessPassword, int nWordLength, INT8U *pRBuffer);
protected:
int SFX8_Connect();
protected:
static DWORD WINAPI NETSDK_MsgFuncProc(LPVOID pParam);
static DWORD WINAPI NETSDK_HbFuncProc(LPVOID pParam);
public:
SOCKET m_hSocket;
};



int SFX8_Client::SFX8_RegisterInvDataCallBack(const char *pIPAddr,PRFID_InvDataFunc pInvFunc, void *context)
{
return 0;
}


int SFX8_Client::SFX8_StartInvOnce(const char *pIPAddr)
{
return 0;
}


int SFX8_Client::SFX8_StartInvContinue(const char *pIPAddr)
{
return 0;
}


int SFX8_Client::SFX8_TagRead(const char *pIPAddr, int nMBType, int nStartOffset, INT32U accessPassword, int nWordLength, INT8U *pRBuffer)
{
return 0;
}

...全文
79 3 打赏 收藏 转发到动态 举报
写回复
用AI写文章
3 条回复
切换为时间正序
请发表友善的回复…
发表回复
处处留心 2015-07-27
  • 打赏
  • 举报
回复
是不是你调试运行的源代码,和你看到的源代码不一致 如果是的话,需要重新编译,并修改配置,允许源代码不同
赵4老师 2015-07-27
  • 打赏
  • 举报
回复
重建所有
l69566 2015-07-25
  • 打赏
  • 举报
回复
刚才再次调试时看了下调用堆栈窗口,发现执行的确实是SFX8_StartInvOnce,但为什么调试光标却停留在SFX8_StartInvContinue处,截图如下:

16,371

社区成员

发帖
与我相关
我的任务
社区描述
VC/MFC相关问题讨论
社区管理员
  • 基础类社区
  • Web++
  • encoderlee
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告

        VC/MFC社区版块或许是CSDN最“古老”的版块了,记忆之中,与CSDN的年龄几乎差不多。随着时间的推移,MFC技术渐渐的偏离了开发主流,若干年之后的今天,当我们面对着微软的这个经典之笔,内心充满着敬意,那些曾经的记忆,可以说代表着二十年前曾经的辉煌……
        向经典致敬,或许是老一代程序员内心里面难以释怀的感受。互联网大行其道的今天,我们期待着MFC技术能够恢复其曾经的辉煌,或许这个期待会永远成为一种“梦想”,或许一切皆有可能……
        我们希望这个版块可以很好的适配Web时代,期待更好的互联网技术能够使得MFC技术框架得以重现活力,……

试试用AI创作助手写篇文章吧