jquery.bind方法在ie8下不兼容的问题

qqq999887 2015-08-25 10:04:01
有人使用过jsoneditor吗,
里面有用到bind的方法,在ie8下会报错
...全文
244 4 打赏 收藏 转发到动态 举报
写回复
用AI写文章
4 条回复
切换为时间正序
请发表友善的回复…
发表回复
qqq999887 2015-08-26
  • 打赏
  • 举报
回复
引用 2 楼 qqq999887 的回复:
[quote=引用 1 楼 jikeytang 的回复:] 用最新版试一下,他里边是不依赖jquery的。 https://github.com/josdejong/jsoneditor
你是说 jsoneditor吗,已经是最新版了吧 4.2.1[/quote] 下载了2.3.0版本的,倒是可以用了,不过又有新问题 样式 单独拿出来是正常的,但是我项目中,这个是要放在layer弹窗里面 应该是layer的样式影响到jsoneditor但是我在外面的main.css里面修改jsoneditor所在的div样式不会发生变化 难道是要在jsoneditor自己的css才可以吗
qqq999887 2015-08-25
  • 打赏
  • 举报
回复
引用 1 楼 jikeytang 的回复:
用最新版试一下,他里边是不依赖jquery的。 https://github.com/josdejong/jsoneditor
你是说 jsoneditor吗,已经是最新版了吧 4.2.1
豪情 2015-08-25
  • 打赏
  • 举报
回复
用最新版试一下,他里边是不依赖jquery的。 https://github.com/josdejong/jsoneditor
豪情 2015-08-25
  • 打赏
  • 举报
回复
引用 2 楼 qqq999887 的回复:
[quote=引用 1 楼 jikeytang 的回复:]
用最新版试一下,他里边是不依赖jquery的。
https://github.com/josdejong/jsoneditor


你是说 jsoneditor吗,已经是最新版了吧 4.2.1[/quote]
貌似没办法了,项目本身不支持ie8,修改起来可能比较麻烦。
https://github.com/josdejong/jsoneditor
Supported browsers: Chrome, Firefox, Safari, Opera, Internet Explorer 9+.

87,942

社区成员

发帖
与我相关
我的任务
社区描述
Web 开发 JavaScript
社区管理员
  • JavaScript
  • 无·法
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧