zoj第1292题,为什么我的java程序提交到网站上时总显示runtimeerror,我在本地计算机能运行的啊

q564414118 2015-09-14 12:33:44
题目如下:
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)


Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.


Output

Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input

1

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0


Sample Output

370370367037037036703703703670


代码如下:
import java.util.Scanner;
import java.math.BigInteger;
public class Test1292{
public static void main(String args[]){
int i;
Scanner scan=new Scanner(System.in);
int n=scan.nextInt();
scan.nextLine();
System.out.println();
outer:for(i=0;i<n;i++){
String a=scan.nextLine();
BigInteger a1=new BigInteger(a);
if(a.equals("0")){
System.out.println();
System.out.println(a1);
System.out.println();
continue outer;
}
out:while(true){
String b=scan.nextLine();
BigInteger b1=new BigInteger(b);
a1=a1.add(b1);
if(b.equals("0")){
System.out.println();
System.out.println(a1);
System.out.println();
break out;
}
}
}
}
}
...全文
165 回复 打赏 收藏 转发到动态 举报
写回复
用AI写文章
回复
切换为时间正序
请发表友善的回复…
发表回复

50,679

社区成员

发帖
与我相关
我的任务
社区描述
Java相关技术讨论
javaspring bootspring cloud 技术论坛(原bbs)
社区管理员
  • Java相关社区
  • 小虚竹
  • 谙忆
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧