Struts2偶尔出现的问题

yy7075 meiyoune yemeiyoune  2015-09-16 10:41:30
我用myeclipse创建一个Web Project,然后从别的项目下把struts2所需要web.xml和struts.xml复制到新建的项目下,提交到Tomcat以后在浏览器中输入地址找不到网页呢?这是为什么呢?弄得我每次都要去复制之前的项目才行,光复制这两个文件都无效的!
以下是web.xml的代码
<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://xmlns.jcp.org/xml/ns/javaee" xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee http://xmlns.jcp.org/xml/ns/javaee/web-app_3_1.xsd" id="WebApp_ID" version="3.1">
<display-name>springandstruts2</display-name>
<filter>
<filter-name>struts2</filter-name>
<filter-class>org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter</filter-class>
</filter>
<filter-mapping>
<filter-name>struts2</filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>

</web-app>


struts.xml的代码
<struts>

<constant name="struts.i18n.encoding" value="utf-8"></constant>
<constant name="struts.enable.DynamicMethodInvocation" value="false" />
<constant name="struts.devMode" value="true" />

<package name="default" namespace="/" extends="struts-default">
<action name="*">
<result>/WEB-INF/content/{1}.jsp</result>
</action>
</package>
</struts>
...全文
72 点赞 收藏 3
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
baidu_31006959 2015-09-16
1.改了东西首先要重新部署一下tomcat,确定起来了。 2.然后确定一下在浏览器中输入的地址是对的。
回复
Cabbage_gang 2015-09-16
为什么要复制呢.....挺好配置的啊 把一样的配置抠出来 记住地方 新建项目放进去就好啦!~ 不过正常来说 导包 web.xml struts.xml 就这三个啊 应该不会有什么问题啊
回复
java_cloub 2015-09-16
清空一下缓存
回复
相关推荐
发帖
Web 开发
创建于2007-09-28

8.0w+

社区成员

Java Web 开发
申请成为版主
帖子事件
创建了帖子
2015-09-16 10:41
社区公告
暂无公告