网站集不能匿名访问了,求指教

huakaihualuo0216 2015-09-28 03:43:04
开启了匿名的网站集,不能匿名访问了,只要一打开,就弹开登录框。下面的子网站开启的匿名没有问题,就网站集这一层,里面的内容都需要登录了。
之前曾出现过,通知不能匿名访问,后来通过将“受限用户权限锁定模式”关闭解决的。可是这次不知道是什么原因引起的,就是都不匿名了,就指教。
...全文
236 9 打赏 收藏 转发到动态 举报
写回复
用AI写文章
9 条回复
切换为时间正序
请发表友善的回复…
发表回复
huakaihualuo0216 2015-12-14
  • 打赏
  • 举报
回复
最后还是重新安排了。
  • 打赏
  • 举报
回复
1.清空一下IE缓存,关闭IE,然后重新登录一下Root Site试试。
2.看看site collection的site permission的Anonymous scope是否选择the whole site
3.验证一下你是针对哪个zone设置的Anonymous access,需要用设置Anonymous access的zone的URL访问site collection的URL才能实现匿名访问。
huakaihualuo0216 2015-10-08
  • 打赏
  • 举报
回复
引用 4 楼 linyustar 的回复:
看看是页面库的权限,看看母版页、页面布局、样式、图片,是不是都签入并且发布了,如果不登陆是白页还是部分不显示,都可以参考的。。多试试。。
还是没有找到原因,为什么子网站匿名正常呢?
  • 打赏
  • 举报
回复
試試用F12工具, HTTPwatch, 或是Fiddler 等工具去分析一下哪一層被擋. 可能只要根網站有一幅圖片有問題說不定
段传涛 2015-10-06
  • 打赏
  • 举报
回复
如果匿名已经开启了, 就是权限问题。 例如iis的权限 加上everyone
Justin-Liu 2015-09-29
  • 打赏
  • 举报
回复
审查最近做的修改
  • 打赏
  • 举报
回复
引用 楼主 xqx8213 的回复:
开启了匿名的网站集,不能匿名访问了,只要一打开,就弹开登录框。下面的子网站开启的匿名没有问题,就网站集这一层,里面的内容都需要登录了。 之前曾出现过,通知不能匿名访问,后来通过将“受限用户权限锁定模式”关闭解决的。可是这次不知道是什么原因引起的,就是都不匿名了,就指教。
是不是本來可以匿名訪問, 有一天突然就不行了? 查一下网站集这一层的權限有沒有被改過, 或是「頁面」有被改過
霖雨 版主 2015-09-29
  • 打赏
  • 举报
回复
看看是页面库的权限,看看母版页、页面布局、样式、图片,是不是都签入并且发布了,如果不登陆是白页还是部分不显示,都可以参考的。。多试试。。
huakaihualuo0216 2015-09-29
  • 打赏
  • 举报
回复
引用 1 楼 legendgod 的回复:
[quote=引用 楼主 xqx8213 的回复:] 开启了匿名的网站集,不能匿名访问了,只要一打开,就弹开登录框。下面的子网站开启的匿名没有问题,就网站集这一层,里面的内容都需要登录了。 之前曾出现过,通知不能匿名访问,后来通过将“受限用户权限锁定模式”关闭解决的。可是这次不知道是什么原因引起的,就是都不匿名了,就指教。
是不是本來可以匿名訪問, 有一天突然就不行了? 查一下网站集这一层的權限有沒有被改過, 或是「頁面」有被改過[/quote] 是这样的,可是现在找不到原因了。

3,242

社区成员

发帖
与我相关
我的任务
社区描述
企业开发 SharePoint
社区管理员
  • SharePoint社区
  • 霖雨
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧