linux 2.6.20做了哪些更新

xspace_time 2015-12-18 07:48:55
linux 2.6.20相比linux2.6.18有什么不同

用2.6.18的.config编译不过去

提示
The present kernel configuration has modules disabled.
Type 'make config' and enable loadable module support.
Then build a kernel with module support enabled.

...全文
172 2 打赏 收藏 举报
写回复
2 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
xspace_time 2015-12-18
都选择了y 保存还是提示同样的错误 至少编译过2.6.18了 所以make moudles应该或者不存在这项配置的问题吧 # Loadable module support # CONFIG_MODULES=y CONFIG_MODULE_UNLOAD=y # CONFIG_MODULE_FORCE_UNLOAD is not set CONFIG_MODVERSIONS=y CONFIG_MODULE_SRCVERSION_ALL=y CONFIG_KMOD=y CONFIG_STOP_MACHINE=y
  • 打赏
  • 举报
回复
云霏阳 2015-12-18
内核配置中没有支持模块,可以这么解决 make menuconfig,然后选择
  • Enable loadable module support ---> 退出保存,再make bzImage;make modules;
  • 打赏
  • 举报
回复
发帖
Linux_Kernel

4314

社区成员

Linux/Unix社区 内核源代码研究区
社区管理员
  • 内核源代码研究区社区
加入社区
帖子事件
创建了帖子
2015-12-18 07:48
社区公告
暂无公告