• 主页
  • ASP
  • .NET Framework
  • Web Services
  • VB
  • VC
  • 图表区
  • 分析与设计
  • 组件/控件开发
  • LINQ

aspx页面最上面<%@ Page Language="C#"...这一句提示没有终结点在侦听...

Gavava 学生  2016-07-14 09:56:12

如图,提示没有终结点在侦听。而且cs页面,根据ID也找不到控件。


新建网站,web窗口,拖一个控件,cs页面也找不到。
自动生成的using System.Linq 也报错

win10系统,vs 2015。
新建网站时选过framework4,4.5.2,4.6都有问题
试过重装framework4.5.X、4.6.X、vs,问题还在。

求大神指导。
...全文
160 点赞 收藏 12
写回复
12 条回复
Gavava 2016年07月16日
引用 11 楼 guwei4037 的回复:
[quote=引用 10 楼 bihaobo 的回复:] 好吧。。。我发现用管理员身份启动vs就好了。。。难道是权限的问题?
应该不是,感觉是你编辑器文本选择的模板不对,重启vs并重置一下vs设置应该就好了。[/quote] 重置之后还是没好。就先用管理员身份吧...之后有时间了重装一下系统...
回复 点赞
以专业开发人员为伍 2016年07月14日
再比如说你贴出的第3个画面,你不去解决上边的虚线处的问题,却只纠结下边的虚线处的问题,肯定是不行的。都不能对这个class进行完整编译,肯定会有一大堆相关的bug报告。那么你应该解决那些“就算是你的 this.Label1 写对了,也照样无法编译通过”的问题,先把这些无关的东西放到一边,不去考虑。
回复 点赞
以专业开发人员为伍 2016年07月14日
你贴出的那行小字并不是针对能贴出的虚线部分的。你没有给出虚线部分的错误解释(你把鼠标移到那里,才会显示;鼠标一旦移开就看不到了。所以你可能不会截屏)。只要把虚线部分的bug解决掉,那么其它一大堆异常也就没有了! 你可以把顶上那一行最后的“ %>”这3个字符重新手写一下,把之后的空格以及其它不可见字符删除掉。这一行应该不用手写,而是由asp.net 自动生成。一旦手写,如果出现个别字符错误。但是一旦出现问题还是小心地重新手写一遍。
回复 点赞
範先森 2016年07月14日
再新建一个也是这种情况么?
回复 点赞
Gavava 2016年07月14日
补充一下,虽然提示有错,但是运行时是正常的,添加新控件,赋值都是可以的。就是编辑的时候没有提示,并且显示错误。
回复 点赞
Gavava 2016年07月14日
引用 1 楼 bidisty 的回复:
系统丢文件了吧
我也觉得是环境的什么问题。 系统文件丢失是指?是要重装什么库吗?还是直接重装系统(觉得重装肯定能解决...但是太麻烦了..)
回复 点赞
Gavava 2016年07月14日
引用 2 楼 guwei4037 的回复:
看下项目的.net framework是否是3.5及以上,Linq要3.5及以上才支持的。
是4.5.2,Linq问题到不大,项目没有用到。主要是找不到aspx页面的元素。
回复 点赞
极简吧 2016年07月14日
看下项目的.net framework是否是3.5及以上,Linq要3.5及以上才支持的。
回复 点赞
bidisty 2016年07月14日
系统丢文件了吧
回复 点赞
极简吧 2016年07月14日
引用 10 楼 bihaobo 的回复:
好吧。。。我发现用管理员身份启动vs就好了。。。难道是权限的问题?
应该不是,感觉是你编辑器文本选择的模板不对,重启vs并重置一下vs设置应该就好了。
回复 点赞
Gavava 2016年07月14日
好吧。。。我发现用管理员身份启动vs就好了。。。难道是权限的问题?
回复 点赞
Gavava 2016年07月14日
引用 7 楼 sp1234 的回复:
你贴出的那行小字并不是针对能贴出的虚线部分的。你没有给出虚线部分的错误解释(你把鼠标移到那里,才会显示;鼠标一旦移开就看不到了。所以你可能不会截屏)。只要把虚线部分的bug解决掉,那么其它一大堆异常也就没有了! 你可以把顶上那一行最后的“ %>”这3个字符重新手写一下,把之后的空格以及其它不可见字符删除掉。这一行应该不用手写,而是由asp.net 自动生成。一旦手写,如果出现个别字符错误。但是一旦出现问题还是小心地重新手写一遍。
那段提示是鼠标放到波浪线上之后显示的,我是用的截屏键截屏然后再截成小图的。我搜提示里的内容,没有找到是这个地方出问题的案例。 最上面那句我重写了,还是有波浪线。我觉得后面控件找不到可能和这个有关。aspx没有和cs关联上。 对于Linq的引用,我觉得是文件丢失,或者没有添加。我在添加引用选项里找不到System.Linq的选项。我试过重装framework4.5 、4.6,新建项目选择4.5.2。Linq的引用还是有问题。
回复 点赞
发动态
发帖子
.NET技术社区
创建于2007-09-28

4.9w+

社区成员

66.8w+

社区内容

.NET技术交流专区
社区公告
暂无公告