Unknown verification type [95] in stack map frame [95] in stack map frame 的解决

SuperBBBZ 2017-02-09 11:06:01
接手上个人的项目,发现升级AS后运行不了,出现了这样的错误
Error:Execution failed for task ':transformClassesWithMultidexlistForDebug'.
> java.io.IOException: Can't read [D:\workspace\project2\haocaimao2\build\intermediates\transforms\jarMerging\debug\jars\1\1f\combined.jar] (Can't process class [com/tencent/wxop/stat/al.class] (Unknown verification type [95] in stack map frame))


后来查了查是混淆的原因,根据网上提供的思路解决了,但是教程上有点细节问题,所以重新写一遍,让各位少走弯路!
1.查看AndroidStudio所使用的proguard的版本,每个人的地址不同,是在androidstudio安装目录下的
路径为D:\Program Files\Android\Android Studio\gradle\m2repository\net\sf\proguard\proguard-base




根据AndroidStudio所使用的proguard版本去官网上下载源码,

地址为:https://sourceforge.net/projects/proguard/files/proguard/

2.下载好proguard后,解压,在src\proguard\classfile文件当中找到源码的ClassConstant.java类,

然后将ATTR_StackMapTable 的值修改成 "dummy"(原值为StackMapTable),


3.下载的proguard源码里面没有ant文件、proguard-android.txt、proguard-android-optimize.txt、proguard-project.txt文件,到自己下载sdk文件夹里面复制过来,

sdk的路径为D:\AndroidSDK\tools\proguard



4.使用ant 进行重新打包
(一)安装ant
到官方主页http://ant.apache.org下载新版(目前为Ant1.9.9)的ant,得到的是一个apache-ant-1.9.4-bin.zip的压缩包。将其解压到你的硬盘上。
下载地址如图



(二)配置环境变量
window中设置ant环境变量:
ANT_HOME C:/ apache-ant-1.9.9
path %apache-ant-1.9.9%\bin;%JAVA_HOME%\bin;
classpath %apache-ant-1.9.9%\lib;%JAVA_HOME%\lib;%JAVA_HOME%\lib\tools.jar
注意:
配置环境变量:我的电脑----属性-----高级----环境变量
由于path和classpath都有可能已经配置了jdk,所以我们要找到path和classpath添加上去,而不要新建,否者会覆盖,导致无法找到jdk,如果变量找不到,就不要用变量,直接贴上地址就行了,不懂留言

(三)验证ant
为了验证ant是否成功安装,可以进行如下操作:
依次选择:开始->运行->cmd,输入如下命令:ant
如果出现如下内容,说明安装成功:
Buildfile: build.xml does not exist!
Build failed

(四)、运行ant打包proguard
cmd进入proguard目录下的build.xml所在目录,如我的:
D:\Program Files\adt-bundle-windows-x86_64-20130729\sdk\tools\proguard\build
或者直接进去build目录下,摁着Shift+右键,会有在此处运行命令窗口的选项
然后运行ant便会在lib目录下重新生成新的的proguard.jar文件。



在lib里面找到jar文件,覆盖到sdk里面的proguard里面的jar包

注意:这里可能有人发现新版下载proguard没有build文件夹,是buildspcrit文件夹,这时只要把它改成build的名字就行了,再进去里面打包,不改的话打包会报错,提示过时的api等等

5.将打包好的文件覆盖掉原来的文件,注意还要在覆盖缓存当中的文件,路径为

C:\Users\A\.gradle\caches\modules-2\files-2.1\net.sf.proguard\proguard-base\4.11\76730af417bb42da22b16e49f49e67863382b9bd

如果有多个版本,则多个版本均覆盖。

注意:第五步可做可不做,我的问题是做到第四步就行了,第5步找不到文件,估计是改版的原因

6,进到as里面重新运行,成功


如果有其他问题请留言

参考博客:
http://www.cnblogs.com/huangbei1990/p/6097782.html
...全文
539 8 打赏 收藏 举报
写回复
8 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
qq_32929105 2017-11-10
没有用的,还是不行
  • 打赏
  • 举报
回复
单飞的梦 2017-07-11
你好,想问下Ant 构建时提示的wtk.home怎么设置
  • 打赏
  • 举报
回复
-Max- 2017-07-05
哥们 在不 你那个第五步 怎么覆盖?
  • 打赏
  • 举报
回复
  • 打赏
  • 举报
回复
我打包的时候没有成功,请问这个怎么解决
  • 打赏
  • 举报
回复
csDavy 2017-05-01
你好,我最近也是遇到这个问题,照着你的方法去做了,还是出现这个错误。你帮我看下是不是哪里出错了
  • 打赏
  • 举报
回复
Kevin_s_gun 2017-03-07
按照你的步骤做了,还是报这个错误 这个pom文件不需要管吗
  • 打赏
  • 举报
回复
SuperBBBZ 2017-02-09
草,我是不是发错地方了
  • 打赏
  • 举报
回复
发帖
Android

7.9w+

社区成员

移动平台 Android
androidandroid-studioandroidx 技术论坛(原bbs)
社区管理员
  • Android
  • yechaoa
  • 失落夏天
加入社区
帖子事件
创建了帖子
2017-02-09 11:06
社区公告
暂无公告