Python pip安装模块一直报错 [问题点数:40分,结帖人Drugsc]

一键查看最优答案

确认一键查看最优答案?
本功能为VIP专享,开通VIP获取答案速率将提升10倍哦!
Bbs1
本版专家分:0
结帖率 100%
Bbs1
本版专家分:60
Bbs1
本版专家分:0
Python出现Could not find a version that satisfies the requirement openpyxl (from versions: )
<em>Python</em>使用<em>pip</em><em>安装</em>openyxl时出现错误:Could not find a version that satisfies the requirement openyxl (from versions: ),以及讲解<em>pip</em>和<em>pip</em>3的区别
Python packaging tools not found的问题解决
首先,我用的虚拟机装的linux系统,linux自带的python2.7,所以python的<em>安装</em>工具是python2的,当使用python3.6,也就是在在项目中设置python3.6的时候,系统自动调用的是python2的下载工具,所以就会有各种不明的no module出现。 这个时候的解决方法是,新增加<em>安装</em>python3命令窗口执行sudo apt install python3-<em>pip</em> 转载...
故障处理:pip10 升级后,PyCharm,python package tools not found
一、背景      升级pycharm 2018版前,当前mac系统未做升级,TSL/SSL证书的问题导致<em>pip</em>失效(mac系统的支持问题),当时为其他包做更新时,测试时升级了<em>pip</em>至<em>pip</em>10;升级系统至MacOS High Sierra(10.13.4)后,mac系统终于解决SSL问题,此时查看pycharm,发现<em>pip</em><em>安装</em>包不可用。 二、故障现象 <em>报错</em>现象1: 执行<em>pip</em>命令
centos7.3 安装scrapy出错Could not find a version that satisfies the requirement Twisted>=13.1.0
1错误原因,通过<em>pip</em> install <em>安装</em>scrapy是<em>报错</em>Could not find a version that satisfies the requirement Twisted>=13.1.0 (from Scrapy) (from versions: ) No matching distribution found for Twisted>=13.1.0 (from Scrapy)
Python中使用pip install --安装报错解决方法
D:\soft\tools\python\python3.7\Scripts&gt;<em>pip</em> install -U pytest Collecting pytest Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘ReadTimeout...
一招解决python pip install 安装库失败
PIP是python强大的<em>安装</em>利器,但是我们经常遇到<em>安装</em>库失败的问题,以下本人觉得最有效的解决方法: 1.打开 https://www.lfd.uci.edu/~gohlke/pythonlibs网站, 2.搜索(CTRL+F)需要<em>安装</em>的库的名称,比如pandas  3.找到对应自己系统的版本并下载,cp后面的数字时python的版本,如cp36代表python3.6版本,WIN后面的数...
pip安装python包出错:Could not find a version that satisfies the requirement skimage (from versions: )
https://yq.aliyun.com/articles/606769
解决pycharm 无法加载pip安装报错:python packing tools not found. install packing tools
Linux下打开 /opt/pycharm-xxxxx/helpers/packaging_tool.py windows下打开 C:\Program Files\JetBrains\PyCharm 2017.1.1\helpers\packaging_tool.py 找到下方代码: def do_install(pkgs): try: import <em>pip</em> e...
ERROR: No matching distribution found for selenium
问题: <em>安装</em> selenium <em>报错</em> 环境: python 3.7.3(python --version) 操作: <em>pip</em> install selenium <em>报错</em>: ERROR: Could not find a version that satisfies the requirement selenium (from versions: none) ERROR: No matching d...
windows下pip安装python模块报错解决方法
1.使用<em>pip</em><em>安装</em>python<em>模块</em>时<em>报错</em>如下 Exception: Traceback (most recent call last): File “C:\Program Files\<em>Python</em>36\lib\shutil.py”, line 544, in move os.rename(src, real_dst) PermissionError: [WinError 5] 拒绝访问。: ‘c:...
解决pycharm问题:module 'pip' has no attribute 'main',以及Error: Python packaging tool 'pip' not found
<em>报错</em>类型 更新<em>pip</em>之后,升级到10.0.1版本,Pycharm<em>安装</em>package出现<em>报错</em>:module ‘<em>pip</em>’ has no attribute ‘main’,<em>报错</em>如下: Traceback (most recent call last): File “C:\Program Files\JetBrains\PyCharm 2017.1.1\helpers\packaging_too...
安装pygame 一直出现这样的情况
已经升级了<em>pip</em> 但<em>一直</em>出现 Requirement 'pygame-1.9.4-cp37-cp37m-win32.whl' looks like a filename, but the file d
pycharm安装unittest模块报错:No matching distribution found for unittest
1、<em>报错</em>信息: Collecting unittest Could not find a version that satisfies the requirement unittest (from versions: ) No matching distribution found for unittest 2、原因: 选择unittest 找不到满足需求的unittest版本(来自版...
Python安装PIL报错:Could not find a version that satisfies the requirement PIL (from versions: )
起初<em>安装</em>命令是按照 <em>pip</em> install PIL来<em>安装</em>的 结果显示: 提示——Could not find a version that satisfies the requirement PIL (from versions: )No matching distribution found for PIL 错误原因: 现在已经用Pillow代替PIL,PIL较多用于2.7版本的Pyth...
pip安装pymongo模块报错:Could not find a version that satisfies the requirement pymongo(from version:)
<em>安装</em>VN.PY时,进行到<em>安装</em>pymongo步骤出现错误Could not find a version that satisfies the requirement pymongo(from version:)
Python 3.4安装pandas库时遇到的问题:no matching distribution found for numpy==1.9.3
Window XP 其实已经<em>安装</em>了numpy10.0.1,但在cmd中<em>pip</em> install pandas时提示:no matching distribution found for numpy==1.9.3。然后卸载了之前的numpy,又使用:<em>pip</em> install numpy==1.9.3,<em>安装</em>过程有点慢,等了好长时间,最终&quot;sucessful&quot;。然后:<em>pip</em> install pandas,仍...
关于解决Python使用pip安装pyjnius时的问题(windows平台)
环境准备: 1、 <em>安装</em> python 2.7版本并配置环境变量 path中加入 <em>Python</em>27 <em>Python</em>27\Scripts 两个路径 2、运行命令(按顺序执行) <em>pip</em> install selenium <em>pip</em> insta
【python】Python安装pip出错:no matching distribution found for xxx
在<em>安装</em>完python之后,<em>安装</em><em>pip</em>; 打开cmd,然后使用cd命令进入到<em>Python</em><em>安装</em>目录下的Scripts文件夹下,我的路径如下:C:\<em>Python</em>27\Scripts 然后使用命令:easy_install <em>pip</em>; 来<em>安装</em><em>pip</em>。 出现如下界面表示<em>pip</em><em>安装</em>成功: 问题1: 在<em>安装</em>成功了<em>pip</em>之后,使用命令<em>安装</em>包的时候: <em>pip</em> install sklearn <em>报错</em>:...
pip安装第三包报错 Could not find a version that satisfies the requirement pytest (from versions: )
Could not find a version that satisfies the requirement pytest (from versions: ) No matching distribution found for pytest 解决办法:主要是国内网络问题,所以使用豆瓣源<em>安装</em> <em>pip</em> install 包名 -i http://pypi.douban.com/simple/ --t...
python3.7.2 安装pip报错(已解决!)
<em>报错</em>如下: 错误原因:因为python3.7.2需要手动<em>安装</em><em>pip</em>,正常情况下找到<em>pip</em>解压目录下执行上图命令即可,但是缺少 setuptools 包! 解决办法: 手动下载 setuotools<em>安装</em>包 下载路径: https://pypi.org/project/setuptools/#files 在解压目录下,执行 python setup.py build 重新进入<em>pip</em><em>安装</em>目录执行...
python pip 安装一些包找不到的问题 Could not find a version that satisfies....
有时我们使用下载python 自带的<em>pip</em> <em>安装</em>一些工具包时,会报如下错误找不到满意的版本,这时就是我们的<em>pip</em>可能需要升级了,所以使用python -m <em>pip</em> install --upgrade <em>pip</em>升级一下<em>pip</em> ,--upgrade 后面跟的是需要升级的库名然后继续尝试发现还是不行,会报相同的错误,这时考虑到是网络的问题,我的网有时候是不稳定的,这时我们用国内的镜像源来加速<em>pip</em> ins...
pip install 出现Exception
Exception: Traceback (most recent call last):   File "D:\software\python35_64\lib\site-packages\<em>pip</em>-9.0.1-py3.5.egg\<em>pip</em>\basecommand.py", line 215, in main     status = self.run(options, args)   Fi
python安装的时候报SSL连接错误的解决办法
Collecting xlwt   Could not fetch URL https://pypi.python.org/simple/xlwt/: There was a problem confirming the ssl certificate: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)
Python笔记】源码编译安装Python时,如何支持自定义安装的高版本openssl库
最近有个小需求想使用Scrapy库做抓取,但公司开发机操作系统版本老旧,导致系统默认的openssl库版本也很低(OpenSSL 0.9.7a Feb 19 2003),最终导致<em>安装</em>Scrapy非常麻烦。趁着元旦假期,决定用自己<em>安装</em>好的高版本openssl库作为依赖,重新编译<em>安装</em>开发机的<em>Python</em>环境。 <em>安装</em>及其后使用中遇到一些关于openssl的问题,或许对自己后续工作或别人有参考价值,作为
pip 安装库出错,一点解决方法
前言 目前发布的文章,大多是学习过程中,查找资料找到的。经过本人自己实践后,发现可行,于是记录下来,所以不属于原创,只是搬运,如果同样遇到此问题的伙伴因看到这里可以解决问题,那也挺好。 正文 在Ubuntu中,升级了<em>pip</em>,再次使用<em>pip</em> <em>安装</em>相关的python包的时候就出现以下错误 ImportError: cannot import name main 解决:<em>pip</em>文件在usr/bin目录...
No matching distribution found for opencv-python
No matching distribution found for opencv-python sudo <em>pip</em>3 install opencv-python strong@strong-System-Product-Name:~$ sudo <em>pip</em>3 install opencv-python The directory '/home/strong/.cache/<em>pip</em>/http' or it...
Could not find a version that satisfies the requirement PIL (from versions: ) No matching distributi
1、软件版本 首先我先<em>安装</em>了 python 2.7 <em>pip</em>是  8.1.2 2、当我要<em>安装</em>PIL时,我在cmd下面输入:<em>pip</em> install PIL 错误提示是: Could not find a version that satisfies the requirement PIL (from versions: ) No matching distribution found f...
解决pip install XX时出现Could not find a version that satisfies the requirement opencv (from versions: )
1.问题描述 在装<em>pip</em> install debacl时出现了如下错误: Could not find a version that satisfies the requirement debacl (from versions: ) No matching distribution found for debacl 试了很多次依然<em>报错</em>,有的是碰墙了,需要去官网下载软件包,手动<em>安装</em>。仔细找了下,...
Ubuntu中Pycharm配置anaconda报错:python packaging tools not found
conda命令将提示错误:“错误的解释器:没有这样的文件或目录”
python报错:No matching distribution found for yaml
问题:python<em>报错</em>:No module named ‘utils’ 执行<em>pip</em> install yaml时候<em>报错</em>Could not find a version that satisfies the requirement yaml No matching distribution found for yaml. 实际需要执行:<em>pip</em> install pyyaml 本博客仅仅记录我自己遇见过的...
Mac pycharm中无法安装unittest和HTMLTestRunner库求解决
ERROR: Could not find a version that satisfies the requirement unittest (from versions: none) Try to
安装pip模块python-pip报错
命令:yum install -y python-<em>pip</em> 错误一:提示No package python-<em>pip</em> available.Error: Nothing to do 解决: a、yum -y install epel-release b、rpm -ivh http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.n...
pip3 install ERROR: Exception: Traceback (most recent call last)
操作系统:macOS。 凡是在使用"<em>pip</em>3 install XXX"时,都会出现如下<em>报错</em>。 和网上别人提出的<em>报错</em>内容不太一致,网上看到的方法都试过了也没有用。所以来请求大佬们帮助。 ``` ERROR: Exception: Traceback (most recent call last): File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_vendor/urllib3/response.py", line 397, in _error_catcher yield File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_vendor/urllib3/response.py", line 479, in read data = self._fp.read(amt) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_vendor/cachecontrol/filewrapper.py", line 62, in read data = self.__fp.read(amt) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/http/client.py", line 457, in read n = self.readinto(b) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/http/client.py", line 501, in readinto n = self.fp.readinto(b) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/socket.py", line 589, in readinto return self._sock.recv_into(b) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/ssl.py", line 1071, in recv_into return self.read(nbytes, buffer) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/ssl.py", line 929, in read return self._sslobj.read(len, buffer) socket.timeout: The read operation timed out During handling of the above exception, another exception occurred: Traceback (most recent call last): File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/cli/base_command.py", line 188, in main status = self.run(options, args) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/commands/install.py", line 345, in run resolver.resolve(requirement_set) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/legacy_resolve.py", line 196, in resolve self._resolve_one(requirement_set, req) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/legacy_resolve.py", line 359, in _resolve_one abstract_dist = self._get_abstract_dist_for(req_to_install) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/legacy_resolve.py", line 307, in _get_abstract_dist_for self.require_hashes File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/operations/prepare.py", line 199, in prepare_linked_requirement progress_bar=self.progress_bar File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/download.py", line 1064, in unpack_url progress_bar=progress_bar File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/download.py", line 924, in unpack_http_url progress_bar) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/download.py", line 1152, in _download_http_url _download_url(resp, link, content_file, hashes, progress_bar) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/download.py", line 861, in _download_url hashes.check_against_chunks(downloaded_chunks) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/utils/hashes.py", line 75, in check_against_chunks for chunk in chunks: File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/download.py", line 829, in written_chunks for chunk in chunks: File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/utils/ui.py", line 156, in iter for x in it: File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_internal/download.py", line 818, in resp_read decode_content=False): File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_vendor/urllib3/response.py", line 531, in stream data = self.read(amt=amt, decode_content=decode_content) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_vendor/urllib3/response.py", line 496, in read raise IncompleteRead(self._fp_bytes_read, self.length_remaining) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/contextlib.py", line 130, in __exit__ self.gen.throw(type, value, traceback) File "/Library/Frameworks/<em>Python</em>.framework/Versions/3.7/lib/python3.7/site-packages/<em>pip</em>/_vendor/urllib3/response.py", line 402, in _error_catcher raise ReadTimeoutError(self._pool, None, 'Read timed out.') <em>pip</em>._vendor.urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host='files.pythonhosted.org', port=443): Read timed out. ```
pip安装python包出错:Could not find a version that satisfies the requirement skimage (from versions: )...
欢迎关注大数据和人工智能技术文章发布的微信公众号:清研学堂,在这里你可以学到夜白(作者笔名)精心整理的笔记,让我们每天进步一点点,让优秀成为一种习惯! 今天用<em>pip</em><em>安装</em>skimage时<em>报错</em>: 这是因为网络的问题,需要使用国内的镜像源来加速,比如豆瓣源 命令改为: <em>pip</em> install scikit-image-i http://pypi.douba...
安装pip实践报错及解决
wget &quot;https://pypi.python.org/packages/source/p/<em>pip</em>/<em>pip</em>-1.5.4.tar.gz#md5=834b2904f92d46aaa333267fb1c922bb&quot; --no-check-certificatetar -axf <em>pip</em>-1.5.4.tar.gz cd <em>pip</em>-1.5.4/python setup.py install########此...
Could not find a version that satisfies the requirement jupyter (from versions: )错误
用<em>pip</em>3 <em>安装</em> jupyter notebook 的时候 ,报 下面的错误 Collecting jupyter Could not find a version that satisfies the requirement jupyter (from versions: ) No matching distribution found for jupyter 是因为网络的问题,要使用...
Python更新pip错误解决方法
在使用python不久的朋友总会碰上报各种错误,像<em>pip</em>总是需要更新,根据更新提示: python -m <em>pip</em> install --upgrade <em>pip</em> 输入以上代码,有时候会报以下错误: 遇到这种错误,不要慌,我们有一个简单实用的方法 换条更新语句就好了 python -m <em>pip</em> install -U --force-reinstall <em>pip</em> 好的,完美解决...
pip install python-docx报错原因解答
执行<em>pip</em> install python-docx报如下错误 因为是setuptools老旧引起的,之前只是升级了<em>pip</em> <em>pip</em> install setuptools -U进行升级,发从2019年开始,python3.4不再维护了,郁闷,只好自己下载一个setuptools了 ...
Python中使用pip安装一些库时出现ERROR: Could not find a version that satisfies the requirement tensorflow (from
标题<em>Python</em>中使用<em>pip</em><em>安装</em>一些库时出现ERROR: Could not find a version that satisfies the requirement tensorflow (from versions: none) 有时我们使用<em>pip</em><em>安装</em>需要使用的某些包时会报如下错误: ERROR: No matching distribution found for tensorflow的...
当我在使用pip安装东西的时候提示这个?怎么解决?
求大佬指导!
错误解决:Could not find a version that satisfies the requirement h5py (from keras) (from versions: )
执行命令:<em>pip</em>3.7 install keras <em>报错</em>:Could not find a version that satisfies the requirement h5py (from keras) (from versions: ) No matching distribution found for h5py (from keras) 解决方法:更新<em>pip</em>后,再试一次 <em>pip</em>3.7 i...
pip 异常问题
使用<em>pip</em><em>安装</em>出现<em>报错</em> Exception: Traceback (most recent call last): File &quot;C:\Users\csprock\Anaconda3\lib\site-packages\<em>pip</em>\basecommand.py&quot;, line 215, in main status = self.run(options, args) File &quot;...
pip安装python包报错的一些解决办法【转】
用国内镜像通过<em>pip</em><em>安装</em>python的一些包 学习flask,<em>安装</em>virtualenv环境,这些带都ok,但是一<em>安装</em>包总是出错无法<em>安装</em>, 比如这样超时的问题: (env)user@orz:~/flask_study/venv-test/test$ easy_install Flask-SQLAlchemy Searching for Flask-SQLAlchemy Re
Could not find a version that satisfies the requirement tkinter
出现的问题是: 解决方法是: kinter其实是<em>Python</em>调用tcl程序的标准<em>Python</em>程序,可以通过这个interface调用tcl的程序,因为在大多数的unix系统中都内置了很多的tcl程序和命令。 Tcl 是“工具控制语言(Tool Command Language)”的缩写,其面向对象为otcl语言。Tk 是 Tcl“图形工具箱”的扩展,它提供各种标准的 GUI 接口项,以利...
Python使用pip安装MySQLdb提示无法找到符合要求的版本
我在使用一个关于数据挖掘平台Storm的框架pyleus,用pyleus将<em>Python</em>程序打成jar包,提交到Storm中运行。我在打包的过程中出现了如下的运行错误,我使用的系统是CentOS: Collecting PyYAML (from pyleus==0.3.0) Installing collected packages: msgpack-python, six, virtualenv, PyYAML, pyleus Successfully installed PyYAML-3.11 msgpack-python-0.4.7 pyleus-0.3.0 six-1.10.0 virtualenv-15.0.1 **Collecting MySQLdb (from -r /usr/rang/packege/miner/requirements.txt (line 1)) Could not find a version that satisfies the requirement MySQLdb (from -r /usr/rang/packege/miner/requirements.txt (line 1)) (from versions: ) No matching distribution found for MySQLdb (from -r /usr/rang/packege/miner/requirements.txt (line 1))** pyleus build: error: [VirtualenvError] Failed to install dependencies for this topology. Run with --verbose for detailed info.
PyCharm破解激活
原文地址:http://xidea.online/http://xclient.info/a/f0b9738a-36fd-8a97-a966-0d3db497092d.html1、打开激活窗口2、选择 Activate new license with License server (用license server 激活)3、在 License sever address 处填入 http://x...
终极解决方案:java.security.cert.CertificateException: Certificates does not conform to algorithm constrain...
<em>报错</em>信息 javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: Certificates does not conform to algorithm constraints 原因:   JDK7/8后添加了安全机制,导致这个问题出现 解决方案: 方案一:  把$JAVA_HOME/jr...
[ pip ] 安装一些包找不到的问题 (Could not find a version that satisfies.)
转载自:python <em>pip</em> <em>安装</em>一些包找不到的问题 Could not find a version that satisfies… 有时我们使用下载 python 自带的 <em>pip</em> <em>安装</em>一些工具包时,会报如下错误 找不到满意的版本,这时就是我们的 <em>pip</em> 可能需要升级了,所以使用 python -m <em>pip</em> install --upgrade <em>pip</em> 升级一下 <em>pip</em> ,–upgrade 后...
pip安装报错:Could not find a version that satisfies the requirement absl-py (from versions
解决方案是: <em>pip</em> install absl-py -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com 用国内的镜像源来加速
pip install安装包后报错ERROR?
![<em>报错</em>信息](https://img-ask.csdn.net/upload/201908/21/1566383154_853878.jpg) 使用<em>pip</em><em>安装</em>第三方包时<em>一直</em><em>报错</em> Could not install packages due to an EnvironmentError: [Errno 0] Error python的环境遍历正常配置
BUG之路1——Ubuntu安装pycharm报python package tools not found错误
心路历程: 真的想死啊,搞了我三天,就想在linux上架个django的服务器,然后<em>安装</em>个pycharm就出了一个占用我三天时间的BUG。最后终于在stackoverflow上看到国外的大神了。最后的解决方法真的是想死,简单的不能再简单,但是就是没注意到。 系统:ubuntu16 工具:pycharm <em>报错</em>描述:在<em>安装</em>完pycharm之后设置项目python版本时,<em>报错</em>:python pa...
pyinstaller3.3 在win10打包出现Python.Runtime not found
使用pyinstaller3.3 在win10上打包exe,但是出现<em>Python</em>.Runtime not found,不知道是什么错误,求大神帮助!!
python pip install 总是出错的解决方法
可以通过国内镜像进行下载  直接在<em>pip</em> install 加入镜像地址  例如:<em>pip</em>3 install -i https://pypi.tuna.tsinghua.edu.cn/simple django  用PyCharm <em>安装</em>包的方法  : 菜单: 文件-设置-项目-Project Interpreter-右上角的加号+     搜
pip安装时这样报错怎么解决
![图片说明](https://img-ask.csdn.net/upload/201810/26/1540535678_499060.png)
Could not find a version that satisfies the requirement 的解决方案
<em>pip</em> install XXX 追加 -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com 即可
全网最详细的用pip安装****模块报错:Could not find a version that satisfies the requirement ****(from version:) No ...
          不多说,直接上干货!       问题详情     这个问题,很普遍。如我这里想实现,Windows下Anaconda2 / Anaconda3里正确下载<em>安装</em>用来向微信好友发送消息的itchat库。       见,我撰写的   全网最全的Windows下Anaconda2 / Anaconda3里正确下载<em>安装</em>用来向微信好友发送消息的itchat库(图文...
Python 解决Pycharm或pip安装第三方包&库安装失败,报错问题“Could not find a version that satisfies the requirement ”
最近在使用Pycharm<em>安装</em>第三方库的时候,偶尔会遇到<em>安装</em>失败的情况,尝试使用<em>pip</em>在命令行<em>安装</em>,还是失败;在网上找了各种解决办法,但还是不起作用。 其中一种可能的原因:其实并不是我们的<em>Python</em>环境或网络环境出了问题。我<em>安装</em><em>报错</em>的原因,是因为当时开着抓包的代理软件(Fiddler)造成的。 关闭抓包软件后,在Pycharm<em>安装</em>第三方库和使用<em>pip</em><em>安装</em>第三方库恢复正常。 ...
python pip安装报错问题汇总
没有<em>pip</em>时通过以下<em>安装</em>: <em>pip</em>:apt install python-<em>pip</em> <em>pip</em>3:apt install python3-<em>pip</em> 1、当使用 sudo <em>pip</em> install **** <em>报错</em>时如下: Traceback (most recent call last): File "/usr/bin/<em>pip</em>", line 9, in &lt;module&gt; from ...
Pythonpip安装失败----Could not find a version that satisfies the requirement xxxx(from versions: )
今天在使用<em>pip</em><em>安装</em><em>模块</em>的时候,发现无法使用。<em>报错</em>信息: Could not find a version that satisfies the requirement xxxxxxx(from versions: ) No matching distribution found for xxxxx 如图: 网上查询了下,可能是网络的问题,所以,这里需要用国内的镜像源来下载 <em>pip</em> ...
安装pip报错解决
目录 1.<em>pip</em><em>安装</em>过程中发生如下错误: 2.解决办法: 1.获取具体版本的<em>pip</em>,我本机为2.6.6 2.运行刚才获取的<em>pip</em>文件 1.<em>pip</em><em>安装</em>过程中发生如下错误: _blocking_errnos = {errno.EAGAIN, errno.EWOULDBLOCK} 2.解决办法: 1.获取具体版本的<em>pip</em>,我本机为2.6.6 ...
python模块安装问题:no matching distribution found for XXX 或者 Read timed out.
在<em>安装</em>codecs,theano等<em>模块</em>时,经常出现这个问题。 看了很多解决问题的博客,亲测通过更换国内<em>安装</em>源和设置超时时间可以解决。 在<em>pip</em> install XXX命令的后面加上 --default-timeout=100 -i https://pypi.tuna.tsinghua.edu.cn/simple即可。 有时候只需更换国内<em>安装</em>源便可解决问题。 更换国内<em>安装</em>源参考这篇博客 设置超时...
PyCharm导入库时出现的一些问题
我要用PyCharm导入pandas库 我从setting->interpreter添加pandas库,但是出现下面这个错误。 ![图片说明](https://img-ask.csdn.net/upload/201902/12/1549943595_286509.png) 最下面说到:You should consider upgrading via the 'python -m <em>pip</em> install --upgrade <em>pip</em>' command. 然后我在命令行输入这行命令,出现另一个错误: ![图片说明](https://img-ask.csdn.net/upload/201902/12/1549943689_301386.png) 我输入<em>pip</em> install pandas也是上图这个错误。 ![图片说明](https://img-ask.csdn.net/upload/201902/12/1549943719_730710.png) 但是我从idle能够使用pandas。 ![图片说明](https://img-ask.csdn.net/upload/201902/12/1549943736_536992.png) 我从网上找了这个错误: ConnectionResetError(10054, '远程主机强迫关闭了一个现有的连接。', None, 10054, None))': /simple/pandas/ 但是提供的解决方法要么看不懂,要么解决不了。 新人实在没有办法了,第一次发帖求助。 希望有大佬帮帮忙。
使用pip安装Python包的抛出异常
-
Python报错:No matching distribution found for ipykernel (from XXX) —— win 10:pip 安装第三方库时报错解决
目录 一、<em>报错</em>情况 二、<em>报错</em>原因 三、解决方法 四、<em>pip</em> 国内的一些镜像 五、永久更换<em>pip</em> <em>安装</em>源为国内镜像 六、<em>报错</em>解决 一、<em>报错</em>情况 Collecting jupyter Downloading https://files.pythonhosted.org/packages/83/df/0f5dd132200728a86190397e1ea87cd76244...
python 遇到unittest里一个问题
最近在学单元测试,自然先从py自带的unittest框架入手,随便写了个实例,在测试时碰到这样一个错误,半天解决不了,求帮忙。 方法类代码 from sqlalchemy import * def q
Python_安装pip报错啦!
<em>pip</em>报的错误为:Fatal error in launcher:Unable to create process using 其中一种可能是,在win下<em>安装</em>了py3和py2,并且在环境变量中分别配置了<em>pip</em>,可是并没有区分<em>pip</em>3还是<em>pip</em>2。 所以你可以用区分Py3和Py2的<em>pip</em>: 比如<em>pip</em>3或者<em>pip</em>3.6来<em>安装</em>python3的<em>安装</em>包; 你可以用<em>pip</em>2或者<em>pip</em>2....
devstack安装pip安装的问题
问题描述:You are using <em>pip</em> version 9.0.3,howerver version 18.1 is available使用命令 sudo <em>pip</em> install –upgrade <em>pip</em> 到了18.1,但是执行stack.sh又回到了9.0.3原因:由于原因是<em>安装</em>中会检查版本,不在规定的范围内,就会重新<em>安装</em>,后面又需要最新版导致无限循环解决方法一:vi /home/dev...
执行pip安装python模块报错
执行<em>pip</em>命令<em>报错</em>
pip更新问题的解决:'python -m pip install --upgrade pip' 报错问题
在<em>安装</em>某个包的时候出现如下错误 然后按照提示运行python -m <em>pip</em> install --upgrade <em>pip</em>并更新<em>pip</em>后再次运行<em>pip</em> install DNN依旧<em>报错</em>如上,此时需要根据自己下载的python路径按照如下图所示找到后删除箭头所指: 接下来再次运行python -m <em>pip</em> install --upgrade <em>pip</em>后,大功告成,如下图所示 ...
python pip install XXX出现报错问题
重装Anacondas后,将<em>pip</em> 和python.exe路径加入到环境变量后直接在cmd窗口进行<em>pip</em> 操作,<em>报错</em>如下 <em>报错</em>内容为: <em>pip</em> is configured with locations that require TLS/SSL, however the ssl module in <em>Python</em> is not available. <em>pip</em>操作是直接联网的,需要SSL端...
ERROR: Could not find a version that satisfies the requirement tensorflow (from versions: none)
<em>安装</em>tensorflow报这个错,因为未指定tensorflow的版本。 解决方案: <em>pip</em> install tensorflow==1.9 为了下载的快一点可以加上国内镜像的链接,加在上面这句命令后面。 -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com 最后成功<em>安装</em> 解决下述代码的keras找不到...
IDEA开发工具12---pip升级带来安装插件错误
<em>pip</em>升级到10.0.1后,IDEA自动<em>安装</em>第三方包,会抛出异常:AttributeError: 'module' object has no attribute 'main'原因:新版<em>pip</em>修改了部分api,如将<em>pip</em>.main()改为了<em>pip</em>_main()将<em>报错</em>目录下的packaging_tools.py换为新版的:import sys import traceback import geto...
pycharm报python package tools not found错误
2019独角兽企业重金招聘<em>Python</em>工程师标准&gt;&gt;&gt; ...
Python使用pip下载库时报错
萌新刚接触python,在使用<em>pip</em>下载第三方库时<em>报错</em>,感觉应该是中文编码的问题,但不知道应该怎么解决,需要重新<em>安装</em>系统把用户名设置成英文才可以吗?使用的是win10系统,<em>Python</em>版本2.7.13
Mac安装pygame 遇到的所有问题
<em>安装</em>homebrew,通过homebrew来<em>安装</em>python和<em>pip</em> 通过<em>pip</em>3 install Pygame. 到这里会<em>报错</em>为: <em>pip</em>3 install pygame Collecting pygame Could not find a version that satisfies the requirement pygame (from versions: ) No matching ...
Ubuntu安装pycharm报python package tools not found错误
在settings的Project Interpreter界面,右侧的加号是灰色的,下面提示<em>Python</em> packaging tools not found. Install packaging tools ------&gt;网上说因为ubuntu<em>安装</em>的python默认是python2,而我电脑上的Pycharm是python3,用2的下载工具下载3的包会出现<em>模块</em>没办法导入等问题,...
Pythonpip - 安装第三方包的神器
使用<em>Python</em>,肯定希望使用大量成熟的第三方包,从而快速用到自己的项目。 还在一个个寻找,手动下载吗? <em>pip</em>就是这样一个神器,自动搜索、下载和<em>安装</em>第三方包: 1,首先请<em>安装</em><em>pip</em>自己,下载地址(也可以通过附件下载): http://www.<em>pip</em>-installer.org/en/latest/installing.html#python-os-support
Python里xlwt,xlrd模块安装出现:You are using pip version 9.0.1, however version 19.0.3 is available. You sho
今天在pycharm准备使用xlwt,xlrd<em>模块</em>,cmd<em>安装</em>python xlwt出现以下信息: You are using <em>pip</em> version 9.0.1, however version 19.0.3 is available. You should consider upgrading via the 'python -m <em>pip</em> install --upgrade <em>pip</em>' co...
pip:Could not find a version that satisfies the requirement Twisted==15.5.0 (from versions: none)
<em>pip</em><em>安装</em>某些包失败 因为网络原因,这种情况指定<em>安装</em>源就好: <em>pip</em> install SomeProject -i http://my.package.repo/simple/ 常用源: 阿里云 http://mirrors.aliyun.com/pypi/simple/ 中国科技大学 https://pypi.mirrors.ustc.edu.cn/simple/ 豆瓣(douban) ht...
python pip安装失败了,怎么
求教各位大神,黑屏终端<em>报错</em>!有哪些解决建议吗? C:\Users\pione><em>pip</em> -V <em>报错</em>代码: Traceback (most recent call last): File "c:\pyth
解决Python通过pip安装报错:(有图)Could not install packages due to an EnvironmentError: HTTPSConnectionPool
在install后面加上**–user**就可以啦! C:\Users\HWP&amp;gt;<em>pip</em> install --user report
python pip错误
【摘要】使用<em>pip</em>命令遇到的错误
python中使用pip功能报错大全
背景:如果你只使用官方的python软件,没有<em>安装</em>辅助软件如:pycharm这个软件; 使用<em>pip</em><em>安装</em><em>报错</em>怎么办? 注意:<em>pip</em>这个功能,是在cmd环境下来敲的。(windows) 首先: python 2 的版本使用的是<em>pip</em> python 3 的版本使用的是<em>pip</em>3 语法:<em>pip</em> install <em>模块</em>名 错误一: 比如:我<em>安装</em>chardet这个<em>模块</em>,<em>安装</em>失败,<em>报错</em>,代码如...
Could not find a version that satisfies the requirement flask
使用命令<em>安装</em>flask,出现<em>报错</em> 百度找到解决方法https://www.cnblogs.com/lijinze-tsinghua/p/8666558.html 参考修改成<em>pip</em> install flask -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com就<em>安装</em>成功了。 原文: <em>pip</em><em>安装</em>python包出错...
python pip安装PIL报错 Could not find a version that satisfies the requirement PIL (from versions: )
在学习做词云图时碰到这个问题。由于我是从pycharm转到用Anaconda的,有些第三方库得重新<em>安装</em>,以前也碰到过,因此想把自己碰到的问题记录下来,方便以后能进行知识回顾,也能给第一次碰到这种问题的小伙伴们一个解决方法。 <em>pip</em> install PIL<em>报错</em>: 查阅相关资料后发现,在python3.7中,PIL库已经更名为:pillow,所以直接:<em>pip</em>  install pillow  ...
Pytorch安装问题:pip3 install torchvision报错解决
在已有anaconda条件下再次<em>安装</em>新的anaconda遇到问题并解决。
pip install 报错问题解决
<em>pip</em> install <em>报错</em>问题解决有时在用<em>pip</em> install命令<em>安装</em>python库时出现红字<em>报错</em>1.<em>报错</em>:ReadTimeoutError: HTTPSConnectionPool(host=’pypi.python.org’, port=443): Read timed out.Downloading xgboost-0.6a2.tar.gz (1.2MB) 48% |███████
python 中pyplot模块导入的问题
![图片说明](https://img-ask.csdn.net/upload/201702/16/1487223343_801595.jpg) 见图,pyplot是available的,但是install的时候却提示没有版本符合 求助
linux安装TensorFlow提示No matching distribution found for tensorflow
我的<em>Python</em>版本是用anaconda装3.7版本的,3.7版本的<em>Python</em>用<em>pip</em> install tensorflow-gpu装不了TensorFlow,原因可能是因为不兼容? 解决方法: 卸载anaconda,装一个3.6版本或者更低版本的anaconda,然后再<em>pip</em> install tensorflow-gpu就好了。 更新于2018年12月17日 今天发现这个错误似乎并不是...
python安装pip之后 pip命令报错解决方法
使用源码包<em>安装</em>python2.7之后。 <em>安装</em><em>pip</em>工具,下载地址: https://pypi.python.org/packages/41/27/9a8d24e1b55bd8c85e4d022da2922cb206f183e2d18fee4e320c9547e751/<em>pip</em>-8.1.1.tar.gz#md5=6b86f11841e89c8241d689956ba99ed7 <em>安装</em> <em>pip</em> ...
python pip install 安装报错:is not a supported wheel on this platform 解决方案
** python <em>pip</em> install <em>安装</em><em>报错</em>:is not a supported wheel on this platform 解决方案 ** 看了无数帖子,自己对着帖子试还是不行,最后分析总结,再结合自己理解去试,,终于成为解决python <em>pip</em> install <em>安装</em><em>报错</em>:is not a supported wheel on this platform ** 1.我们先在百度搜索...
pip安装pymysql出错
使用<em>pip</em><em>安装</em>pymysql出错;Could not find a version that satisfies the requirement cryptography (from pymysql) (from versions: ) No matching distribution found for cryptography (from pymysql) 今天使用<em>pip</em><em>安装</em>pymysql时出...
Python 安装 第三方库的安装技巧
<em>Python</em> <em>安装</em> 第三方库的<em>安装</em>技巧 我的电脑:Windows 10 64位。 <em>Python</em> IDE 软件:PyCharm 2016.1.4 <em>Python</em> version : <em>Python</em> 3.5.0 <em>安装</em>一个两条建议: 1. 使用 <em>pip</em> 命令行工具在线下载你需要的第三方库 2. 手动下载 第三方库,再使用 <em>pip</em> 命令<em>安装</em> 1. 使用 <em>pip</em> 命令行...
pycharm中 setup报错怎么弄
-
爬虫福利二 之 妹子图网MM批量下载
爬虫福利一:27报网MM批量下载    点击 看了本文,相信大家对爬虫一定会产生强烈的兴趣,激励自己去学习爬虫,在这里提前祝:大家学有所成! 目标网站:妹子图网 环境:<em>Python</em>3.x 相关第三方<em>模块</em>:requests、beautifulsoup4 Re:各位在测试时只需要将代码里的变量 path 指定为你当前系统要保存的路径,使用 python xxx.py 或IDE运行即可。
西门子PLC S7-300可编程控制器产品目录下载
西门子PLC S7-300可编程控制器产品目录希望可以帮助大家跟好的了解西门子PLC 相关下载链接:[url=//download.csdn.net/download/q941703653/3470867?utm_source=bbsseo]//download.csdn.net/download/q941703653/3470867?utm_source=bbsseo[/url]
2011年度下半年项目经理继续教育在线考试题目答案下载
2011年度下半年项目经理继续教育在线考试题目答案 相关下载链接:[url=//download.csdn.net/download/xiaoailiu/3861912?utm_source=bbsseo]//download.csdn.net/download/xiaoailiu/3861912?utm_source=bbsseo[/url]
电脑蓝屏代码大全下载
电脑蓝屏代码大全。专门针对电脑蓝屏的解决方案,来源于网络收集,多数帮助较大。 相关下载链接:[url=//download.csdn.net/download/luyingyu2005/5049964?utm_source=bbsseo]//download.csdn.net/download/luyingyu2005/5049964?utm_source=bbsseo[/url]
相关热词 如何提升c#开发能力 矩阵乘法c# c#调用谷歌浏览器 c# 去空格去转义符 c#用户登录窗体代码 c# 流 c# linux 可视化 c# mvc 返回图片 c# 像素空间 c# 日期 最后一天
我们是很有底线的