Install error after downloading code from Openwrt 15.05

jeans521 2017-09-11 08:13:02
I try to use git clone git://git.openwrt.org/15.05/openwrt.git
./scripts/feeds update -a
./scripts/feeds install -a
to update openwrt 15.05 but found below issue

the Update feed is ok

Updating feed 'packages' from 'https://github.com/openwrt/packages.git;for-15.05' ...
Cloning into './feeds/packages'...
remote: Counting objects: 2702, done.
remote: Compressing objects: 100% (2276/2276), done.
remote: Total 2702 (delta 100), reused 2254 (delta 65), pack-reused 0
Receiving objects: 100% (2702/2702), 1.72 MiB | 1.91 MiB/s, done.
Resolving deltas: 100% (100/100), done.

when install :+1:
Build dependency: Please install Git (git-core) >= 1.6.5

Prerequisite check failed. Use FORCE=1 to override.
make[1]: *** [staging_dir/host/.prereq-build] Error 1
make: *** [prepare-tmpinfo] Error 2
Cannot open './tmp/.packageinfo': No such file or directory
Can't open file './tmp/.targetinfo': No such file or directory

I got this issue , try to update this with master branch git in mydir/feeds/package/net/git but not work.

Any help would be appreciated
Thanks
...全文
973 9 打赏 收藏 转发到动态 举报
写回复
用AI写文章
9 条回复
切换为时间正序
请发表友善的回复…
发表回复
逸云飞扬 2017-11-21
  • 打赏
  • 举报
回复
这是openwrt一个脚本的问题,用一个古老的命令来判断git的版本。 找到文件 openwrt/include/prereq-build.mk 的第148行,修改 git clone 2>&1 | grep -- --recursive 为 git verison 问题就可以解决了。 本方法适用于15.05版本
jeans521 2017-09-13
  • 打赏
  • 举报
回复
https://wiki.openwrt.org/doc/howto/buildroot.exigence 我是按这个来弄的,但是有问题,没人碰到过吗?
zhxianbin 2017-09-12
  • 打赏
  • 举报
回复
没看懂,哪些是 shell 输出错误?
jeans521 2017-09-12
  • 打赏
  • 举报
回复



这个是执行时的feed.conf文件和出错截图
引用
jeans521 2017-09-12
  • 打赏
  • 举报
回复
我使用git clone下载的15.05的代码,但是在使用
./scripts/feeds update -a // 这个正常
./scripts/feeds install -a //这个出现异常,这个里面去下载的版本是2.3.5-1
后提示Build dependency: Please install Git (git-core) >= 1.6.5
查看系统的git version 是2.14的
jeans521 2017-09-12
  • 打赏
  • 举报
回复
使用git version 查看是有git 2.14.1 的,那提示的错误看起来是下载的代码里面检测出现了问题? 有尝试把trunk版本的 2.14.1的代码拷贝到feed的package目录,但是一样的问题~~~
jeans521 2017-09-12
  • 打赏
  • 举报
回复
引用
没看懂,哪些是 shell 输出错误?
下面图的是输出的错误,提示需要安装git大于1.6.5~~
rayw0ng 2017-09-11
  • 打赏
  • 举报
回复
I'm not sure what exactly is your question.
jeans521 2017-09-11
  • 打赏
  • 举报
回复
I try to use the Master branch code on my environment but worked ok The PC with ubuntu 14.04 is 64bit with me also when i use 32bit pc this 15.05 branch worked also looks like related to working environment? Ask for help ----From a newer

679

社区成员

发帖
与我相关
我的任务
社区描述
智能路由器通常具有独立的操作系统,包括OpenWRT、eCos、VxWorks等,可以由用户自行安装各种应用,实现网络和设备的智能化管理。
linuxpython 技术论坛(原bbs)
社区管理员
  • 智能路由器社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧