qt5.2.1交叉编译时提示/usr/bin/ld: skipping incompatiple...when serarcning for -ldbus-1

MatthewMao 2017-11-06 09:35:50
呼叫使用qt的同志们,我现在遇到一个配置环境的问题:当前准备用的是qt5.2.1-opensource,来实现多点触控这个功能,我的编译器是arm-linux-gcc(g++)5.4.1 - 32位,Ubuntu是16.04-32位,但是我在环境搭建的编译时候,老是提示如标题所示,说我的库和当前环境需要的匹配,我的dbus库1.2.16版,也是交叉编译过得(在网上下载的),具体过程截图如下,望了解的人给予我相应的解答,如果有相关的有用的资源,更当感谢,资源分也会相应奉上,谢谢.......

这个是我的配置选项:

这个是我在在配置之后,编译提示的错误:

这个是我的dbus1.2.16库的目录:
...全文
563 3 点赞 打赏 收藏 举报
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
MatthewMao 2017-12-02
这个后面是通过厂家提供的文件系统里面的库来解决的!!!我现在想这里的问题大概是libdbus库版本不对吧
  • 打赏
  • 举报
回复
MatthewMao 2017-11-13
看过了,库是arm版的,编译器也是交叉编译过的;
  • 打赏
  • 举报
回复
jamon_tan 2017-11-07
file 看下你的库是不是你这个平台
  • 打赏
  • 举报
回复
相关推荐
发帖
Linux/Unix社区
加入

2.1w+

社区成员

Linux/Unix社区 应用程序开发区
申请成为版主
帖子事件
创建了帖子
2017-11-06 09:35
社区公告
暂无公告