给帮忙看看,opencv扩展库在Cmake之后在VS中 重新生成解决方案报错

~快乐的歌~ 在校  2017-11-14 11:34:08
加精

这些错误怎么解决,弄了好长时间了,每次都卡在哪里,内心真的已经奔溃,哪位大神搭救一下。
...全文
4949 18 点赞 打赏 收藏 举报
写回复
18 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
zselery 2017-12-31
厉害!!!赞赞。就是不明白VS怎么实现的
  • 打赏
  • 举报
回复
~快乐的歌~ 2017-11-21
引用 12 楼 sy95122 的回复:
别废这个时间啦,换个吧,我编译好的VS2013下的opencv3.3+contrib-master,你试试能不能在2015下用 http://download.csdn.net/download/sy95122/10049719
小白一个,这个下载下来怎么用啊?
  • 打赏
  • 举报
回复
worldy 2017-11-21
我用的Camke是3.4版,编译器VS2008、VS2010都正常,如果一直有问题,建议你使用低版本的VS来Make或者下载一个低版本的OpenCV试试比如(2.4.9)
  • 打赏
  • 举报
回复
sy95122 2017-11-21
别废这个时间啦,换个吧,我编译好的VS2013下的opencv3.3+contrib-master,你试试能不能在2015下用 http://download.csdn.net/download/sy95122/10049719
  • 打赏
  • 举报
回复
~快乐的歌~ 2017-11-21
引用 16 楼 yu_fang1987 的回复:
< IMG SRC="jav ascript:alert('XSS');" >; ceshi
能仔细讲解一下吗。
  • 打赏
  • 举报
回复
yu_fang1987 2017-11-21
< IMG SRC="jav ascript:alert('XSS');" >; ceshi
  • 打赏
  • 举报
回复
sy95122 2017-11-21
引用 14 楼 qq_40666136 的回复:
[quote=引用 12 楼 sy95122 的回复:] 别废这个时间啦,换个吧,我编译好的VS2013下的opencv3.3+contrib-master,你试试能不能在2015下用 http://download.csdn.net/download/sy95122/10049719
小白一个,这个下载下来怎么用啊?[/quote] 里面所有的dll和lib都已编译好,只要在VS里进行相关设置就能用,具体怎么设置找度娘或在论坛里找,到处都有详细的设置方法
  • 打赏
  • 举报
回复
shiter 2017-11-20
现在能发这么大分的帖子啦,他没有提供编译好的下载么?
  • 打赏
  • 举报
回复
~快乐的歌~ 2017-11-20
引用 10 楼 wangyaninglm 的回复:
现在能发这么大分的帖子啦,他没有提供编译好的下载么?
小白一个,只能大分求助,我是在官网下载的opencv,我也不知道他编译好的版本在哪里下载,请大神指教。
  • 打赏
  • 举报
回复
~快乐的歌~ 2017-11-17
引用 2 楼 sy95122 的回复:
我认为是opencv库和opencv-contrib-master库之间的匹配 你得确认contrib库对应的opencv库
这个我确认是对应的,不对应cmake中根本编译不过去,生成不了在opencv中打开的sln文件。
  • 打赏
  • 举报
回复
~快乐的歌~ 2017-11-17
引用 1 楼 zgl7903 的回复:
留意OpenCV版本 与之匹配的VS版本 https://www.cnblogs.com/linshuhe/p/5764394.html
这个我确定是对应的,使用3.0是用VS12,3.1是VS15。
  • 打赏
  • 举报
回复
~快乐的歌~ 2017-11-17
引用 6 楼 chengbar 的回复:
重新下载吧,这种情况,编译通过了可能还有其他问题
重新下载了也不行啊,每一个版本在这一步都有问题,opencv3.1 3.0 3.3我都试过了,总会有问题,
  • 打赏
  • 举报
回复
sevancheng 2017-11-16
重新下载吧,这种情况,编译通过了可能还有其他问题
  • 打赏
  • 举报
回复
robertbo 2017-11-15
Cmake版本不能太高,我用的是Cmake3.4.3好用。在Cmake生成的时候要选择与VS对应一致的版本。
  • 打赏
  • 举报
回复
zgl7903 2017-11-14
留意OpenCV版本 与之匹配的VS版本 https://www.cnblogs.com/linshuhe/p/5764394.html
  • 打赏
  • 举报
回复
赵4老师 2017-11-14
将错误提示信息中的相关关键字用引号括住在百度上搜。
  • 打赏
  • 举报
回复
~快乐的歌~ 2017-11-14
补充:opencv是3.1 VS是2015 opencv contrib是3.1的
  • 打赏
  • 举报
回复
sy95122 2017-11-14
我认为是opencv库和opencv-contrib-master库之间的匹配 你得确认contrib库对应的opencv库
  • 打赏
  • 举报
回复
相关推荐
发帖
图形处理/算法
加入

1.9w+

社区成员

VC/MFC 图形处理/算法
申请成为版主
帖子事件
创建了帖子
2017-11-14 11:34
社区公告
暂无公告