• 主页
  • ASP
  • .NET Framework
  • Web Services
  • VB
  • VC
  • 图表区
  • 分析与设计
  • 组件/控件开发
  • LINQ

video 播放视频的问题

807254150 2017-11-21 09:51:54
我设置了两种方式,第一种方式不能播放远程文件,第二种方式可以播放,但是 视频的帖没有播放出来,也就是播放滚动条播放成功,视频上黑漆漆的。两边的服务器MIME 类型都设置了 video/mp4 video/mepg

请问,是否是需要处理远程文件的播放流问题?有没有办法直接播放远程视频连接的?

我是js 给 src 添加路径,

第一种方式:

<video controls="controls" class="tl_video" webkit-playsinline="true">
<source id="v1" src="" controls="controls">
</video>



第二种播放方式

<video id="vv" controls="controls" src="" class="tl_video" webkit-playsinline="true" controls preload="none">

</video>
...全文
113 点赞 收藏 8
写回复
8 条回复
非专业开发Five 2017年11月21日
引用 6 楼 u011195704 的回复:
[quote=引用 5 楼 xomix 的回复:] [quote=引用 4 楼 u011195704 的回复:] [quote=引用 3 楼 xomix 的回复:] 远程直接video标签有返回码?打开网络追踪看情况了吗?
网络追踪看到有浮动,不知道是不是编码的问题,还是其它问题[/quote] 一般来说有图像没声音,八九成都是编码问题。 video标签支持最好的是h2.64[/quote] 现在是可以播放,没有声音也没图像。。。所以极其郁闷[/quote] 多找几个文件放到远程,还有就是在远程也做个video标签看看结果。
回复 点赞
807254150 2017年11月21日
引用 5 楼 xomix 的回复:
[quote=引用 4 楼 u011195704 的回复:] [quote=引用 3 楼 xomix 的回复:] 远程直接video标签有返回码?打开网络追踪看情况了吗?
网络追踪看到有浮动,不知道是不是编码的问题,还是其它问题[/quote] 一般来说有图像没声音,八九成都是编码问题。 video标签支持最好的是h2.64[/quote] 现在是可以播放,没有声音也没图像。。。所以极其郁闷
回复 点赞
非专业开发Five 2017年11月21日
引用 4 楼 u011195704 的回复:
[quote=引用 3 楼 xomix 的回复:] 远程直接video标签有返回码?打开网络追踪看情况了吗?
网络追踪看到有浮动,不知道是不是编码的问题,还是其它问题[/quote] 一般来说有图像没声音,八九成都是编码问题。 video标签支持最好的是h2.64
回复 点赞
807254150 2017年11月21日
引用 3 楼 xomix 的回复:
远程直接video标签有返回码?打开网络追踪看情况了吗?
网络追踪看到有浮动,不知道是不是编码的问题,还是其它问题
回复 点赞
非专业开发Five 2017年11月21日
引用 2 楼 u011195704 的回复:
[quote=引用 1 楼 xomix 的回复:] [quote=引用 楼主 u011195704 的回复:] 我设置了两种方式,第一种方式不能播放远程文件,第二种方式可以播放,但是 视频的帖没有播放出来,也就是播放滚动条播放成功,视频上黑漆漆的。两边的服务器MIME 类型都设置了 video/mp4 video/mepg 请问,是否是需要处理远程文件的播放流问题?有没有办法直接播放远程视频连接的? 我是js 给 src 添加路径, 第一种方式:

   <video controls="controls" class="tl_video" webkit-playsinline="true">
            <source id="v1" src="" controls="controls">
        </video>
  
第二种播放方式

<video id="vv" controls="controls" src="" class="tl_video" webkit-playsinline="true" controls preload="none">
            
        </video>
1、本地是否正常? 2、使用avi或mpg这些文件是否正常? [/quote] 本地播放没毛病,就是远程播放 有问题。我视频,就是.MP4格式。限定了。。设置avi mpg 都有设置。没起作用,关键点是一个服务器远程播放另一个服务器的视频文件[/quote] 远程直接video标签有返回码?打开网络追踪看情况了吗?
回复 点赞
807254150 2017年11月21日
引用 1 楼 xomix 的回复:
[quote=引用 楼主 u011195704 的回复:] 我设置了两种方式,第一种方式不能播放远程文件,第二种方式可以播放,但是 视频的帖没有播放出来,也就是播放滚动条播放成功,视频上黑漆漆的。两边的服务器MIME 类型都设置了 video/mp4 video/mepg 请问,是否是需要处理远程文件的播放流问题?有没有办法直接播放远程视频连接的? 我是js 给 src 添加路径, 第一种方式:

   <video controls="controls" class="tl_video" webkit-playsinline="true">
            <source id="v1" src="" controls="controls">
        </video>
  
第二种播放方式

<video id="vv" controls="controls" src="" class="tl_video" webkit-playsinline="true" controls preload="none">
            
        </video>
1、本地是否正常? 2、使用avi或mpg这些文件是否正常? [/quote] 本地播放没毛病,就是远程播放 有问题。我视频,就是.MP4格式。限定了。。设置avi mpg 都有设置。没起作用,关键点是一个服务器远程播放另一个服务器的视频文件
回复 点赞
非专业开发Five 2017年11月21日
引用 楼主 u011195704 的回复:
我设置了两种方式,第一种方式不能播放远程文件,第二种方式可以播放,但是 视频的帖没有播放出来,也就是播放滚动条播放成功,视频上黑漆漆的。两边的服务器MIME 类型都设置了 video/mp4 video/mepg 请问,是否是需要处理远程文件的播放流问题?有没有办法直接播放远程视频连接的? 我是js 给 src 添加路径, 第一种方式:

   <video controls="controls" class="tl_video" webkit-playsinline="true">
            <source id="v1" src="" controls="controls">
        </video>
  
第二种播放方式

<video id="vv" controls="controls" src="" class="tl_video" webkit-playsinline="true" controls preload="none">
            
        </video>
1、本地是否正常? 2、使用avi或mpg这些文件是否正常?
回复 点赞
807254150 2017年11月21日
引用 7 楼 xomix 的回复:
[quote=引用 6 楼 u011195704 的回复:] [quote=引用 5 楼 xomix 的回复:] [quote=引用 4 楼 u011195704 的回复:] [quote=引用 3 楼 xomix 的回复:] 远程直接video标签有返回码?打开网络追踪看情况了吗?
网络追踪看到有浮动,不知道是不是编码的问题,还是其它问题[/quote] 一般来说有图像没声音,八九成都是编码问题。 video标签支持最好的是h2.64[/quote] 现在是可以播放,没有声音也没图像。。。所以极其郁闷[/quote] 多找几个文件放到远程,还有就是在远程也做个video标签看看结果。[/quote] 解决了。 因为这个:controls preload="none" 导致的
回复 点赞
发动态
发帖子
.NET技术社区
创建于2007-09-28

4.9w+

社区成员

66.8w+

社区内容

.NET技术交流专区
社区公告
暂无公告