pat甲级1012前两个测试点一直通过不了。怎么破?

hedyfattoo 2017-12-12 09:01:40
题目描述
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


我的代码:
#include <iostream>
#include <string.h>
using namespace std;

struct stu
{
string num; //学号
int c; //c成绩
int m; //m成绩
int e; //e成绩
int a; //平均成绩
int best; //最好成绩
int bs; //最好科目
int bR = 1; //best rank
}list[2000];

int main ()
{
int n, m;
cin >> n >> m;
for (int i = 0; i < n; i++)
{
int tmax = 0; //暂存最大数
//int bs;
cin >> list[i].num;
cin >> list[i].c;
if (list[i].c > tmax)
{
tmax = list[i].c;
list[i].bs = 1;
}
cin >> list[i].m;
if (list[i].m > tmax)
{
tmax = list[i].m;
list[i].bs = 2;
}
cin >> list[i].e;
if (list[i].e > tmax)
{
tmax = list[i].e;
list[i].bs = 3;
}
list[i].a = int((list[i].c + list[i].m + list[i].e) / 3.0 + 0.5);
if (list[i].a >= tmax)
{
tmax = list[i].a;
list[i].bs = 4;
}
list[i].best = tmax;
}
for (int i = 0; i < m; i++)
{
int flag = 0;
string cn; //需要检测的学号
cin >> cn;
for (int j = 0; j < n; j++)
{
if (cn == list[j].num)
{
int b = list[j].best; //最好成绩
int s = list[j].bs; //最好的科目
char c;
if (s == 1)
{
for (int k = 0; k < n; k++)
{
if (j != k && list[k].c > b)
list[j].bR += 1;
}
c = 'C';
}
if (s == 2)
{
for (int k = 0; k < n; k++)
{
if (j != k && list[k].m > b)
list[j].bR += 1;
}
c = 'M';
}
if (s == 3)
{
for (int k = 0; k < n; k++)
{
if (j != k && list[k].e > b)
list[j].bR += 1;
}
c = 'E';
}
if (s == 4)
{
for (int k = 0; k < n; k++)
{
if (j != k && list[k].a > b)
list[j].bR += 1;
}
c = 'A';
}
cout << list[j].bR << ' ' << c << endl;
flag = 1;
break;
}
}
if (!flag)
cout << "N/A" << endl;
}

}

测试结果:

有大佬指导一下我吗
...全文
588 2 打赏 收藏 转发到动态 举报
写回复
用AI写文章
2 条回复
切换为时间正序
请发表友善的回复…
发表回复
79C0 2019-12-29
  • 打赏
  • 举报
回复
我是第二个未过,请问你当时是什么的问题
hedyfattoo 2018-02-01
  • 打赏
  • 举报
回复
解决了,自己的问题

33,311

社区成员

发帖
与我相关
我的任务
社区描述
C/C++ 新手乐园
社区管理员
  • 新手乐园社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧