用KEIL 5 遇到无法编译的问题

probie_noob 2018-02-22 03:20:18
keil 5 是我新装的,也破解了,内容是我根据讲义自己打进去的,但是一编译就出现
*** Target 'LD2' - Device Family 'Cortex-M4', default ARM-Compiler version 'Unspecified: use latest compiler version 5' is not available.
*** Please review the installed ARM Compiler Versions:
'Manage Project Items - Folders/Extensions' to manage ARM Compiler Versions.
'Options for Target - Target' to select an ARM Compiler Version for the target.
*** Build aborted.
这样就无法生成axf文件,我就没办法用ST-Link 下载到开发板上。

求各位大神帮助



...全文
3693 点赞 收藏 16
写回复
16 条回复
m0_54092329 03月01日
为什么我每次都需要重新调?
回复 点赞
m0_54092329 03月01日
每打开一个程序都需要重新再调一下这个东西吗?
回复 点赞
正是少年时 01月08日
怎么解决的呢?我也出现了这个问题
回复 点赞
R.ui.. 2020年08月08日
引用 8 楼 lookaroundd 的回复:
调一下这个试试
感谢老哥,搞好了
回复 点赞
probie_noob 2018年08月23日
8楼正解。 回复六楼:可以安装在一起 谢谢大家
回复 点赞
worldy 2018年04月11日
编译器版本不对,检查选项,看看是否有什么需要设置的项目
回复 点赞
wufeijian 2018年04月10日
贴个keil版本信息图,像这样的
回复 点赞
qq_38550287 2018年04月10日
版本的问题吧
回复 点赞
lookaroundd 2018年04月07日


调一下这个试试
回复 点赞
智者知已应修善业 2018年03月31日
昨晚用ARM打开C51工程的提示与LZ的差不多.
回复 点赞
智者知已应修善业 2018年03月31日
昨晚为了使用C51的弄了很久,因刚接触不太清楚,看楼上的才知道,昨晚下了ARM的安装所以无法打开C51工程,两个版本可以安装同一目录?
回复 点赞
南柯一梦zsy 2018年03月10日
应该是没有装arm编译器 好像keil5的安装包有c51的和arm的 怀疑楼主只装了c51的
回复 点赞
杨奎 2018年03月02日
kile5的哪个版本,建议安装最新版本的kile5我是5.23
回复 点赞
VF-TECH 2018年02月23日
沙发,一把错误翻译一下应该就可以了,
回复 点赞
zgl7903 2018年02月22日
打开Keil 自带的例子项目 编译看看 是否有问题
回复 点赞
zgl7903 2018年02月22日
按提示的意思 应该是说Keil的版本太低
回复 点赞
发动态
发帖子
单片机/工控
创建于2007-09-28

1.0w+

社区成员

2.8w+

社区内容

硬件/嵌入开发 单片机/工控
社区公告
暂无公告