安装包时出现有未满足的依赖关系,怎么解决 [问题点数:50分,无满意结帖,结帖人u011203541]

Bbs1
本版专家分:0
结帖率 66.67%
Bbs1
本版专家分:0
正在读取软件包列表... 有错误!
正在读取软件包列表... 有错误! E: Encountered a section with no Package: header E: Problem with MergeList/var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_precise-backports_main_i18n_Translation-zh E: 无法解
无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
安装terminator等一些软件等<em>时</em>候,遇到了这样等问题 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>: terminator : <em>依赖</em>: python-support (>= 0.90.0) 但是它将不会被安装 <em>依赖</em>: python-vte 但是它将不会被安装 推荐: python-gnome2 但是它将不会被安装 推荐: python-keybinder 但是它将不会被安装E: 无法修正错误,因为您
解决安装wine依赖问题
wine : Depends: wine1.6 but it is not going to be installed
Linux 软件包依赖关系满足
<em>解决</em>方案1: 使用以下指令来自动<em>满足</em><em>依赖</em><em>关系</em> sudo apt-get -f install 完成后重新安装需要的软件包即可<em>解决</em>方案2: 使用aptitude替换apt-get 安装aptitude sudo apt-get install aptitude 使用: 例:sudo aptitude ins
正在读取状态信息... 完成 E: 无法定位软件包 lesstif2
正在读取状态信息... 完成 E: 无法定位软件包 lesstif2 ![图片说明](https://img-ask.csdn.net/upload/201609/09/1473425034_349609.png)
在执行更新操作出现 “无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系” 错误
问题描述: 要用到vim,于是我用命令:sudo apt-get install vim-gtk进行下载,下载后提示: 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>: vim-gtk : <em>依赖</em>: vim-common (= 2:8.0.1453-1ubuntu1) 但是 2:8.0.1453-1ubuntu1.1 正要被安装 E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>。 ...
E: 有满足依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
转发自https://blog.csdn.net/longma666666/article/details/79374453 遇到此类问题,直接在终端输入sudo apt-get –fix-broken install即可<em>解决</em>问题。
linux安装软件报错:有满足依赖关系
一、问题描述   <em>解决</em>了上一个问题   另外一个进程已经为 dpkg 状态数据库 加锁   又一个问题接踵而来(真是深得命运宠爱呀)    二、问题分析   很明显,这不是重启能<em>解决</em>的问题了,继续向命运抗争吧。   1. “<em>依赖</em>于vlc(&amp;amp;amp;gt;= 2.1.0);然而:<em>未</em>安装软件包 vlc。”   <em>未</em>安装那就安装呗(你要什么我给什么),然而失败了(看来说出来的不一定是想要的),不过...
Linux学习--安装软件提示有满足依赖关系
这种现象<em>出现</em>的原因是: (1)软件需要<em>依赖</em>旧的版本的其他软件,但是目前这些都是新的。 (2)要装A,但是<em>依赖</em>新版本的B,同<em>时</em>C也<em>依赖</em>了B,但是C<em>依赖</em>的的版本更旧,如果更新B,那么C也不能正常使用了。 这里采用的<em>解决</em>办法: (1)首先需要更新源,我在里面安装了清华的源和阿里的源,然后执行更新本地源列表指令; (2)sudo apt-get install 软件名,这个<em>时</em>候会提示你“有<em>未</em><em>满足</em>...
无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
使用 sudo apt-get install 安装软件<em>时</em>, <em>出现</em>错误 “无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>”。 错误的主要原因是,系统中已经安装了被<em>依赖</em>的包的高版本。 例如在安装 gcc-4.8-multilib <em>时</em>,<em>依赖</em> libc6-dev-x32 ,但是系统中已经安装了***libc6-dev-x32*** ,并且版本高于所要求的版本,导致安装失败。...
ubuntu安装软件出现,无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
安装terminator等一些软件等<em>时</em>候,遇到了这样等问题 leo@leo:~$ sudo apt-get install terminator [sudo] password for leo: 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许
软件安装的依赖问题
在编译Android源码<em>时</em>,安装<em>依赖</em>的相关包<em>时</em>,如下: sudo apt-get install flex bison gperf libsdl-dev libesd0-dev libwxgtk2.6
Ubuntu有满足依赖关系解决
Ubuntu有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em><em>解决</em> 如下: wine : <em>依赖</em>: wine1.6 但是它将不会被安装 wine1.6-amd64 : <em>依赖</em>: wine1.6:any (= 1:1.6.2-0ubuntu14.2) wine1.6-i386:i386 : <em>依赖</em>: wine1.6:any (= 1:1.6.2-0ubuntu14.2) E: 有<em>未</em>能<em>满足</em>的<em>依赖</em><em>关系</em>。请尝试不指明软件包的名字来运行 ...
ubuntu 16.04 在使用apt-get install命令出现:下列软件包有满足依赖关系错误
1、<em>出现</em>错误的命令:sudo apt-get install dpkg2、<em>出现</em>的错误信息:您可能需要运行“apt-get -f install”来纠正下列错误: 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>: cups : <em>依赖</em>: cups-common (&amp;gt;= 2.1.3-4ubuntu0.4) 但是 2.1.3-4 正要被安装 cups-bsd : <em>依赖</em>: cups-common (&amp;gt;= 2....
ubuntu安装软件提示有满足依赖关系
  环境:ubuntu 14.04 STL、64位     在ubuntu中我们使用sudo apt-get install 或者dpkg -i *.deb安装软件<em>时</em>,常常提示“有<em>未</em>能<em>满足</em>的<em>依赖</em><em>关系</em>“,这是因为当前软件源中<em>依赖</em>库的版本不<em>满足</em>软件的要求。 <em>解决</em>办法: 步骤1:更新软件源。ubuntu自带的软件源比较旧,很多的软件版本较低,国内比较好用的源有阿里源; sudo cp /etc/ap...
Deepin微信开发者工具依赖关系解决
Deepin微信开发者工具<em>依赖</em><em>关系</em><em>解决</em>安装微信开发者工具<em>时</em>报错:<em>依赖</em><em>关系</em>不<em>满足</em>:wine<em>解决</em> 安装微信开发者工具<em>时</em>报错:<em>依赖</em><em>关系</em>不<em>满足</em>:wine 安装<em>时</em>报错:<em>依赖</em><em>关系</em>不<em>满足</em>:wine,安装版本如下: <em>解决</em> 安装<em>时</em>,提示<em>依赖</em><em>关系</em><em>未</em>被配置,暂<em>时</em>先不看,继续执行下面的命令: sudo dpkg --add-architecture i386 sudo apt-get update sudo a...
依赖: XXX 但是它将不会被安装
1. install aptitudesudo apt-get instal aptitude下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>: aptitude : <em>依赖</em>: libcwidget3 但是它将不会被安装 <em>依赖</em>: libsigc++-2.0-0c2a (&amp;gt;= 2.0.2) 但是它将不会被安装 <em>依赖</em>: libxapian22 但是它将不会被安装 ...
解决办法:下列软件包有满足依赖关系依赖。。。但是。。。正要被安装
  很多朋友安装软件,<em>出现</em>这个错误<em>时</em>找不到<em>解决</em>办法。为什么呢?因为搜索的关键字不对。应该搜索“无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>”。   参考文章:   《<em>解决</em>办法:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>》  ...
ubuntu问题g++ : 依赖: g++-4.8 (>= 4.8.2-5~) 但是它将不会被安装
截图中选取了一个等同的例子。 python-dev : <em>依赖</em>:libpython-dev(=2.7.5-5ubuntu3)但是它将不会被安装 凡是遇到类似问题,括号里面会是一些版本号。这通常代表的意思是Ubuntu自生安装的软件包版本高,而所安装软件的<em>依赖</em>包版本低的原因 <em>解决</em>发案 1. $sudo apt-get install aptitude $sudo aptitude
ubuntu安装软件:有满足依赖关系
通常的原因是:1、软件<em>依赖</em>于某一软件旧的版本,可是你却已经安装了新的。 2、要装A, <em>依赖</em>B, 但是已经安装的软件C也<em>依赖</em>B, 但是A<em>依赖</em>的B的版本和C<em>依赖</em>的B的版本不一致, 导致了如果要安装B,那么C便不能正常运行了,所以系统报错。<em>解决</em>办法:方法(一):步骤1:更新软件源。ubuntu自带的软件源比较旧,很多的软件版本较低,国内比较好用的源有阿里源;                sudo cp...
Ubuntu 14.04 “无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关” 解决办法
  ubuntu下apt-get install 安装软件, 报“无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>”。 这个错误<em>出现</em>的主要原因是,系统中已经安装了被<em>依赖</em>的包的高版本。例如在我安装 openssh-server <em>时</em>,有一个对于 openssh-client 的<em>依赖</em>,但是我系统中已经提前安装了openssh-client 这个包,并且版本高于所要求的...
ubuntu问题解决:下列软件包有满足依赖关系,xxx依赖xxx
sudo apt-get -f install(是修复损坏的软件包,尝试卸载出错的包,重新安装正确版本的) 然后再安装就可以了。
Ubuntu16.04无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
Ubuntu下sudo apt-get install python-opencv显示: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>。 网上提到的<em>解决</em>方法很多,但是好像最后对我都没有用,最后看到网上一张截图的配置跟我不太一样,我索性给改了,发现下载东西居然就没问题了。这里我给分享一下,希望能给别人带来帮助吧。 方法: 点击右上角 -&gt; 打开系统设置 -&gt...
Ubuntu14.04搭建环境 g++ : 依赖: g++-4.8 (>= 4.8.2-5~) 但是它将不会被安装
Ubuntu14.04搭建环境遇到下列问题: root@ubuntu-VirtualBox:/home/ubuntu# apt-get install -y build-essential 正在读取软件包列表… 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息… 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求的状态造成的。该版本中可能会有一...
npm 安装依赖出现错误
笔者在进行学习webpack学习实践的<em>时</em>候,使用npm命令进行<em>依赖</em>安装<em>时</em>,总是遇到以下错误,笔者一<em>时</em>找不到<em>解决</em>方案,很是无奈。后偶然间在看mpvue文档的<em>时</em>候瞬间受到启发<em>解决</em>了此错误。 <em>解决</em>方法及<em>解决</em>示例图如下: 执行以下命令后再执行安装<em>依赖</em>就不报错误啦 $ npm set registry https://registry.npm.taobao.org/ OR $ yarn con...
下列软件包有满足依赖关系: cuda : 依赖: cuda-9-0 (>= 9.0.176) 但是它将不会被安装
楼主是Ubuntu 16.04装CUDA9的<em>时</em>候遇到了这个问题,最后发现是因为自己关闭了更新的原因,如果你也遇到问题的话,请按如下步骤:系统设置-软件和更新-更新设置为如下即可:如果还不行的话,你可以看一下你是否更换过软件的源,将源重置一下看看!...
解决办法』:build-essential: 依赖: XXX 但是它将不会被安装
当你安装一些东西的<em>时</em>候提示: build-essential:<em>依赖</em>:XXX但是它不会被安装 例如:build-essential:<em>依赖</em>:g++但是它不会被安转。 <em>解决</em>办法: sudo -i aptitude install g++
E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
安装terminator等一些软件等<em>时</em>候,遇到了这样等问题 leo@leo:~$ sudo apt-get install terminator [sudo] password for leo: 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
LINUX安装依赖库冲突的最终版本:下列软件包有满足依赖关系/但是它将不会被安装/无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
出错 apt install libx11-dev 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件 包尚<em>未</em>被创建或是它们已被从新到(Incoming)目录移出。 下列信息可能会对<em>解决</em>问...
ubuntu 安装 nvidia-docker2报错“下列软件包有满足依赖关系:”
先看错误: 执行 sudo apt-get install -y nvidia-docker2 的<em>时</em>候<em>出现</em>下面错误信息: 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>: nvidia-docker2 : <em>依赖</em>: docker-ce (= 5:18.09.0~3-0~ubuntu-xenial) 但是 5:18.09.1~3-0~ubuntu-xenial 正要被安装 或docker-ee (= 5:18.09....
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
最近小白安装虚拟机,在其上安装caffe<em>时</em>,在该步骤出错 sudo apt-get install --no-install-recommends libboost-all-dev 网上搜了多种方法,太杂,反正没<em>解决</em>。自己直接瞎改,<em>解决</em>。 将下载自中国服务器,改为主服务器即可。再无需任何更改。
解决 ubuntu 16.04安装软件遇到的一个罕见巨坑
这个坑是这样的:  gcc-multilib : Depends: gcc-5-multilib (&amp;gt;= 5.3.1-3~) but it is not going to be installed  lib32stdc++6 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.9 is to be insta...
【protobuf】protobuf 的安装与使用
protobuf的安装与使用
pat-get 与aptitude的区别 处理:下列软件包有满足依赖关系
有<em>时</em>候我们在ubuntu系统中用apt-get install 安装软件包<em>时</em>或<em>出现</em>以下错误:下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>:... ....这是我们可以考虑用sudo aptitude install  ... ... 的安装工具安装,举个例子:原来使用sudo apt-get install python-pip会提示以上错误。改成以下命令:sudo aptitude install python...
ubuntu 17.10 安装后软件包有满足依赖关系
求助一下各位老师,我刚接触ubuntu,最近下载安装了ubuntu kylin 17.10版本后,联网更新软件,发生了一个错误,错误信息:“错误:已损坏个数>0”, 这通常意味着您安装的软件包有<em>未</em><em>满足</em>
E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
安装terminator等一些软件等<em>时</em>候,遇到了这样等问题leo@leo:~$ sudo apt-get install terminator [sudo] password for leo: 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法...
树莓派kali 装完整包出现满足依赖关系
如题树莓派已经安装了kali但是主要工具都没有所以想安装全部但是不<em>满足</em><em>依赖</em><em>关系</em>![图片](https://img-ask.csdn.net/upload/201612/08/1481155510_158293.jpg)![图片](https://img-ask.csdn.net/upload/201612/08/1481155352_360756.jpg)![图片](https://img-ask.csdn.net/upload/201612/08/1481155541_845543.jpg)![图片](https://img-ask.csdn.net/upload/201612/08/1481155681_732564.jpg)
Python-pip 安装失败问题解决
一、问题描述root@ubuntu:/home/chao# apt-get install python-pip 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件 包尚<em>未</em>被创建或是它们已被从
依赖关系满足:teamviewer
<em>解决</em>办法是 sudo apt-get remove teamviewer
deepin深度商店安装应用说依赖关系被破坏
在深度终端执行以下命令即可<em>解决</em> sudo apt-get clean 清除已经下载的<em>安装包</em> sudo apt-get update 重新更新软件列表 sudo apt-get dist-upgrade
无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。(亲身体验)
下载aptitude sudo apt-get install aptitude 执行 sudo aptitude install shutter /*******************************************************************************************/---&amp;gt;很重要的操作来了 (败在这...
无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系 解决办法
ubuntu下apt-get install安装软件, 报“无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>”,今天终于找到<em>解决</em>方法了。 一般<em>出现</em>这种情况的原因<em>时</em> 要装A, <em>依赖</em>B, 但是已经安装的软件C也<em>依赖</em>B, 但是A<em>依赖</em>的B的版本和C<em>依赖</em>的B的版本不一致, 导致了如果要安装B,那么C便不能正常运行了,所以系统报错,组织安装B。 那么<em>解决</em>方法就是: 重新安装C,
ubuntu安装VLC出现依赖包版本过高解决方法
cyl@cyl-Latitude-D630:~$ sudo apt-get install vlc正在读取软件包列表... 完成正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件包尚<em>未</em>被创建或是它们已被从新到(Incoming)...
Ubuntu18.04安装gcc提示错误
错误信息: 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件 包尚<em>未</em>被创建或是它们已被从新到(Incoming)目录移出。 下列信息可能会对<em>解决</em>问题有所帮助: 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em>...
Ubuntu安装软件事出现依赖关系有问题解决方案
在ubuntu中安装软件中,有<em>时</em>会<em>出现</em>以下错误提示: 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件包尚<em>未</em>被创建或是它们已被从新到(Incoming)目录移出。... <em>出现</em>上述等问题,一般是系统中相关软件没有更新。当然,有<em>时</em>可以在终端键入:sudo aptitude... 来降低相关软件版本,达到<em>依赖</em>...
build-essential: 依赖: g++ (>= 4:4.3.1) 但是它将不会被安装
问题:   [yangzb@yangzb-desktop:~]$ which g++ bash: type: g++: <em>未</em>找到 [yangzb@yangzb-desktop:~]$ sudo apt-get install build-essential 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树       正在读取状态信息... 完成       有一些软件...
debian 安装软件出现 下列软件包有满足依赖关系
apt-get install vim <em>出现</em> 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>: vim : <em>依赖</em>: vim-common (= 2:7.2.445+hg~cb94c42c0e1a-1) 但是 2:7.3
Ubuntu14.4 源列表问题导致下列软件包有满足依赖关系: MySQL社区服务器:取决于:MySQL客户端(= 5.642等等
首先第一步了解系统的一些基本信息如:系统版本号(方便根据不同版本选择不同的源列表) [root@database mysql]# cat /etc/issue Ubuntu 14.04.3 LTS \n \l 备份原装源列表: [root@database mysql]# cp /etc/apt/sources.list /etc/apt/sources.list.bak [root@d...
解决办法:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
安装出错 quantum6@gh63:~/research/caffe-master$ sudo apt-get install --no-install-recommends libboost-all-dev 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,...
安装GTK开发环境,满足依赖关系,如何解决
ubuntu 10.04 2.6.32-22-generic $ sudo apt-get install gnome-devel gnome-devel-docs 正在读取软件包列表... 完成 正
Linux下BUG系列:ubuntu16.04安装wine有满足依赖关系
Linux下BUG系列:ubuntu16.04安装wine有<em>未</em><em>满足</em><em>依赖</em><em>关系</em> 想在ubuntu16.04下装一个MS的office,按照 https://www.sohu.com/a/162185166_295478 安装winetricks<em>时</em>: sudo apt-get install wine1.8 winetricks 首先报错 ... Rebuilding /usr/share/app...
ubuntu 请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>:  wine-qqintl:i386 : <em>依赖</em>: libasound2:i386                     <em>依赖</em>: libgtk2.0-0:i386 但是它将不会被安装                     <em>依赖</em>: liblcms2-2:i386 但是它将不会被安装                     <em>依赖</em>: libpng12-0:i386
ubuntu 没有可用的软件包 gcc
正在读取软件包列表… 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息… 完成 没有可用的软件包 gcc,但是它被其它的软件包引用了。 这可能意味着这个缺失的软件包可能已被废弃, 或者只能在其他发布源中找到 E: 软件包 gcc 没有可安装候选 1 sudo apt-get update 2sudo apt install gcc ...
python-dev无法安装,求助
安装pyrex后,使用<em>时</em>需要Python.h头文件,在网上查询到需要安装python-dev, 于是sudo apt-get install python-dev,(Ubunto12.04系统),提
解决办法:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
关键:提示<em>依赖</em>什么,就安装<em>依赖</em>库及其版本号(低的那个)! 编译提示错误: fatal error: gtk/gtk.h: 没有那个文件或目录 #include &lt;gtk/gtk.h&gt; 下载<em>依赖</em>库: apt install libgtk2.0-dev 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一...
ubuntu gcc低版本过低引起错误
错误内容: 正在读取软件包列表... 完成正在分析软件包的<em>依赖</em><em>关系</em>树正在读取状态信息... 完成您可能需要运行“apt-get -f install”来纠正下列错误:下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>:gcc-4.9 : <em>依赖</em>: cpp-4.9 (= 4.9.3-8ubuntu2~14.04) 但是它将不会被安装<em>依赖</em>: gcc-4.9-base (= 4.9.3-8ubuntu2~14.04) 但...
Linux下BUG系列:解决deepin-wine依赖问题
简单来说,就是常见的“为<em>满足</em><em>依赖</em>错误”,一般是由于软件安装卸载冲突所造成的。 报错: root@lowfree03:/home/lowfree# apt-get install libc6-dev:i386 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 您可能需要运行“apt-get -f install”来纠正下列错误: 下...
Ubuntu卸载protobuf并安装3.6.0版本的protobuf
1.卸载Ubuntu自带的protobuf; # sudo apt-get remove libprotobuf-dev # which protoc // 运行完“which protoc”会显示一个protoc的路径,如果没有显示则下面这条命令不必执行 # rm /usr/local/bin/protoc // 具体路径以“which protoc”显示的为准 到此,低版本的protob...
ProtoBuf 2.6.1安装、配置、卸载
由于公司现在用的是2.6.1,所以现在我安装的版本是2.6.1,据说protoc2和protoc3的数据格式不通用 顺便说一下不要在github上面直接下源码,因为源码中没有configure文件,需要先在源码文件夹内运行./autogen.sh命令下载configure文件,但是下载网址被墙了,所以有可能下载失败 https://github.com/google/protobuf/relea...
Protobuf安装步骤
今天看Brpc开源代码的<em>时</em>候,看到了里面提到了google开源的protobuf的数据序列化和反序列工具,所以特地下了源码,试着看下一个简单的使用过程。 1、protobuf的介绍 google protobuf是一个灵活的、高效的用于序列化数据的协议。相比较XML和JSON格式,protobuf更小、更快、更便捷。google protobuf是跨语言的,并且自带了一个编译器(protoc),只...
protobuf的介绍、安装与使用
1.protobuf是什么? protobuf是google旗下的一款平台无关,语言无关,可扩展的序列化结构数据格式。所以很适合用做数据存储和作为不同应用,不同语言之间相互通信的数据交换格式,只要实现相同的协议格式即同一 proto文件被编译成不同的语言版本,加入到各自的工程中去。这样不同语言就可以解析其他语言通过 protobuf序列化的数据。 2.数据交互xml、json、proto...
Ubuntu16.04安装protobuf(最靠谱的)
emmmmmmm..... Ubuntu16.04自带protobuf protoc --version 查看版本 whereis protoc 查看安装位置 which protoc 如果有多个protobuf,查看默认使用的protobuf 方法一: 1、下载google protocol buffers,下载地址:http://code.google.com/p/protob...
ganglia-monitor : 依赖: libconfuse0 (>= 2.5) 但是它将不会被安装 ........
由于先前主节点更换的原因,ganglia<em>出现</em>问题,先将原主节点的ganglia相关软件卸载, 1、打开一个终端,输入dpkg --list显示的是你电脑上安装的所有软件。 2、在终端中找到你需要卸载的软件的名称,列表是按照首字母排序的。 3.在终端上输入命令sudo apt-get --purge remove 包名(--purge是可选项,写上这个属性是将软件及其配置文件一并删除...
Linux工具大全_gcc-multilib
参考资料 无法安装 gcc-libs-multilibhttp://cdc.zhaopin.com/infomation/Industryinfo/contentinfo?articleid=1583881185&Category=160400 gcc-multilib 4.8.2-3https://www.archlinux.org/packages/multilib/x86_64/gc
解决npm 安装部分依赖失败问题总结
有<em>时</em>候,我们通过npm install进行项目初始化,会由于“天朝墙”的原因,可能会导致下载速度慢,无法下载等等问题<em>出现</em>。 好在现在有很多国内镜像,也有一个帮助我们随意切换 npm 镜像的工具:nrm。 npm install -g nrm nrm ls * npm ---- https://registry.npmjs.org/ cnpm --- http://r.cnpmjs.org...
Linux解决(无法获得锁 /var/lib/dpkg/lock - open (11: 资源暂不可用))
root@kali:~# apt update &amp;amp;&amp;amp; apt -y full-upgrade 命中:1 http://mirrors.neusoft.edu.cn/kali kali-rolling InRelease 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有 1998 个软件包可以升级。请执行...
apt-get安装问题:请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树... 完成 您可能需要运行“apt-get -f install”来纠正下列错误: 下列的软件包有不能<em>满足</em>的<em>依赖</em><em>关系</em>: cdparanoia: <em>依赖</em>: libcdparanoia0 (= 3a9.8-11) 但是,它将不会被安装 gpdf: <em>依赖</em>: libgnomeprint2.2-0 (>= 2.4.2) 但是,它将不会被安装
protobuf 安装笔记
本人从github上直接下载,然后按照步骤走,发现没有。/config命令。从网上搜集了原因,特此记录卸载掉老版本的Protocol:sudo apt-get remove libprotobuf-dev 2.下载最新的Protocol Buffers。下载网址:https://developers.google.com/protocol-buffers/docs/downloads。说明:最好不...
sudo apt-get install package出现E:无法定位软件包
OS:Ubuntu 16.04 问题描述: ``` sudo apt-get install xxxx ``` <em>出现</em> ``` 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 E: 无法定位软件包 xxxx ``` 网上的<em>解决</em>方案例如 ``` sudo apt-get update && apt-get upgrade ``` 我都试过了,没有用,问题依然存在。 ``` sudo gedit /etc/apt/sources.list ``` 换源我也试过了,不行。请问还有什么办法吗??
下列软件包满足依赖关系: flashplugin-installer(ubuntu下adobe flash player的安装)
下列软件包<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>: flashplugin-installer(ubuntu下adobe flash player安装<em>时</em>碰到的怪事<em>解决</em>方案)
Ubuntu :zlib1g-dev依赖: zlib1g (= 1:1.2.8.dfsg-2ubuntu4) 但是 1:1.2.8.dfsg-2ubuntu4.1 正要被安装
执行sudo apt-get indtall zlib1g-dev后<em>出现</em>-&amp;gt;“Ubuntu :zlib1g-dev<em>依赖</em>: zlib1g (= 1:1.2.8.dfsg-2ubuntu4) 但是 1:1.2.8.dfsg-2ubuntu4.1 正要被安装” 的问题,<em>解决</em>办法:                                      .                   ...
现在没有可用的软件包 vnc4-common
ubuntu14,用sudo apt-get update更新了后,再安装也不行
【Deepin】安装smartmontool报错:libc6-dev : 破坏:
错误信息如下: 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件 包尚<em>未</em>被创建或是它们已被从新到(Incoming)目录移出。 下列信息可能会对<em>解决</em>问题有所帮助: 下列软件包有<em>未</em>满...
虚拟机 正在读取软件包列表... 有错误!
正在读取软件包列表… 有错误! E: Encountered a section with no Package: header E: Problem with MergeList/var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_precise-backports_main_i18n_Translation-zh E: 无法解析或打开软件包...
软件包 lib32readline5-dev 没有可供安装的候选者
mystation@mystation:~$ sudo apt-get install lib32readline5-dev 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信
Ubuntu环境安装包 E: 发现软件包 zliblg-dev
问题如下: root@ubuntu-VirtualBox:/home/ubuntu# apt-get install -y zliblg-dev 正在读取软件包列表… 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息… 完成 E: <em>未</em>发现软件包 zliblg-dev 改正:把l改成1,不是字母“l”而是数字1,zlib1g-dev root@ubuntu-VirtualBox:/home/ubu...
ubuntu16.04--需要运行"apt-get -f install"来纠正下列错误
安装graphviz的<em>时</em>候报如下的错误: E: 有<em>未</em>能<em>满足</em>的<em>依赖</em><em>关系</em>。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个<em>解决</em>办法)。 <em>解决</em>办法: 在终端输入:sudo apt-get -f install 然后在输入: sudo apt-get install graphviz <em>解决</em>了
linux下满足依赖关系错误(1)
刚刚装了新的ubuntu 16.04 安装 curl<em>时</em><em>出现</em>错误 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>:  curl : <em>依赖</em>: libcurl3 (= 7.35.0-1ubuntu2.5) 但是 7.47.0-1ubuntu2 正要被安装 E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>。 原因:libcurl3与系统原来的版本冲突 <em>解决</em>:直
ubuntu16.04下软件依赖冲突的解决方案
在使用apt安装各种软件<em>时</em>,经常会提示包<em>依赖</em><em>关系</em>冲突,很典型的就是你安装的软件的<em>依赖</em>包版本比较低,但你电脑上已经有了对应的<em>依赖</em>包,但是版本更高,这<em>时</em>候为了保证你原来电脑上软件的正常运行,apt就会<em>出现</em>安装失败。<em>解决</em>方法是使用aptitude来安装,它给更加智能地给出冲突的<em>解决</em>方案,比如对现有的<em>依赖</em>包降版本处理。首先安装aptitude:      sudo apt-get install apti...
求助:Ubuntu安装依赖包的问题
想要安装一些32位的库,出来了一个<em>依赖</em><em>关系</em>,然后一个个往上找<em>依赖</em>,最后是找到了tzdata:i386 tarena@ubuntu:~$ sudo apt-get install tzdata:i386 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 注意,选取 tzdata 而非 tzdata:i386 tzdata 已经是最新的版本了。 升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 23 个软件包<em>未</em>被升级。 tarena@ubuntu:~$ 并没有成功安装上tzdata:i386,也<em>未</em>能找到相应的资料,这个应该怎么<em>解决</em>
ubuntu“apt-get -f install”问题解决
正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树        正在读取状态信息... 完成        您可能需要运行“apt-get -f install”来纠正下列错误: 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>:  openjdk-8-jdk : <em>依赖</em>: openjdk-8-jre (= 8u111-b14-3~14.04.1)                  <em>依赖</em>: ope
关于linux依赖关系出错的解决
我在装caffe<em>时</em>遇到的错误如下: apt-get: 代码: sudo apt-get install libgl1-mesa-dev 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要
Ubuntu 16.04 apt-get无法自动解决依赖解决方法
当使用apt-get安装一些很常见的应用都不能自动<em>解决</em><em>依赖</em>,比如安装git,docker这些软件包都报错找不到<em>依赖</em>包的话,那么就需要查看一下是不是软件源配置的有问题,我发现从官网下载的Ubuntu 16.04apt源配置的都是官方的,而且非常不全,导致无法自动<em>解决</em><em>依赖</em>,而且下载的异常缓慢。所以一般情况下,只需要把默认源改为正确的就可以了。这里推荐使用阿里的apt源。如果你买过阿里云的服务器,那么u
未能满足依赖关系" 解决">ubuntu下"E: 有满足依赖关系" 解决
到达
Ubuntu上安装vim不能安装的问题,“下列的软件包有不能满足依赖关系
前阵子,刚安装Ubuntu<em>时</em>,安装vim的问题,现在些出来分享一下。 apt-get install vim 正在读取软件包列表... 完成 正在分析软件包的<em>依赖</em><em>关系</em>树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,
Ubuntu解决依赖关系
问题: apt-get install libprotobuf-dev 下列软件包有<em>未</em><em>满足</em>的<em>依赖</em><em>关系</em>:  libprotobuf-dev : <em>依赖</em>: zlib1g-dev 但是它将不会被安装 E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的<em>依赖</em><em>关系</em>。 原因: Linux下经常需要安装不同类型的库,在Ubuntu中,这些类库都是以“lib_n
树莓派(raspberry pi) 3的入门过程遇到的一些问题
raspberry pi3买回来也有几天了,这几天上班回家过年也没有太多<em>时</em>间玩,现在就记录一下入门遇到的一些问题吧。首先是烧写镜像,和安装电脑系统是一样的道理。先要有一个制作一个U启动盘。先将SD卡格式化,再用Win32DiskImager将raspberry官方下载的镜像烧写进去(这种文档很多的,随便找一个都可以完成操作)。将SD卡插到板子上就会自动加载镜像了,最后出来界面如下:如果完成上面这些...
动态规划入门到熟悉,看不懂来打我啊
持续更新。。。。。。 2.1斐波那契系列问题 2.2矩阵系列问题 2.3跳跃系列问题 3.1 01背包 3.2 完全背包 3.3多重背包 3.4 一些变形选讲 2.1斐波那契系列问题 在数学上,斐波纳契数列以如下被以递归的方法定义:F(0)=0,F(1)=1, F(n)=F(n-1)+F(n-2)(n&gt;=2,n∈N*)根据定义,前十项为1, 1, 2, 3...
Hibernate注解详解下载
Hibernate注解详解(超全面不解释),好不好,自己下了看看就知道 相关下载链接:[url=//download.csdn.net/download/d765747369/4784091?utm_source=bbsseo]//download.csdn.net/download/d765747369/4784091?utm_source=bbsseo[/url]
惠普1280打印机驱动下载
惠普1280打印机vista、win7 64位驱动 相关下载链接:[url=//download.csdn.net/download/b1v115/5078683?utm_source=bbsseo]//download.csdn.net/download/b1v115/5078683?utm_source=bbsseo[/url]
PCMAN Telnet軟體下载
國產免費自由軟體,中文支援度 100%,不含廣告,且原始碼全部以 GNU GPL 授權開放 相关下载链接:[url=//download.csdn.net/download/u012571522/6454565?utm_source=bbsseo]//download.csdn.net/download/u012571522/6454565?utm_source=bbsseo[/url]
相关热词 c# 数组类型 泛型约束 c#的赛狗日程序 c# 传递数组 可变参数 c# 生成存储过程 c# list 补集 c#获得所有窗体 c# 当前秒数转成年月日 c#中的枚举 c# 计算校验和 连续随机数不重复c#
我们是很有底线的