springboot中文乱码问题

TeemoSmithLee 学生  2018-03-19 12:29:27
IDEA2.7 创建的springboot项目,在application.properties中给的中属性,在controller中获得,无论在控制台输出还是在页面上输出都是乱码,百度上搜到的该改的地方都改了,求教一下!下面上图:

-1-application.properties


-2-controller


-3-setting


-4-console控制台输出


-5-page网页输出
...全文
450 点赞 收藏 10
写回复
10 条回复
dong_19890208 2018年03月20日
你用 appilication.yml格式的配置文件吧,appilication.properties 在Integllij IDE应该由bug
回复 点赞
dong_19890208 2018年03月20日
是不是你浏览器的编码
引用 7 楼 TeemoSmithLee 的回复:
[quote=引用 6 楼 dong_19890208 的回复:] [quote=引用 5 楼 TeemoSmithLee 的回复:] [quote=引用 3 楼 dong_19890208 的回复:] 我测试了下,我的中文配置没有中文乱码的现象,我怀疑是你的application.properties 文件的编码格式不对,修改成UTF-8应该就好了
请教一下如何修改application.properties的文件编码格式。file->setting里面的我已经全部改成了utf-8[/quote]打开文件,右下角就能看到该文件的编码格式,点击会出现编码选项,选中就能修改了[/quote] 我测试了一下 这个左下角我显示的是UTF-8而且是灰色的不能修改的 [/quote]你还是用.yml格式的配置文件吧
引用 7 楼 TeemoSmithLee 的回复:
[quote=引用 6 楼 dong_19890208 的回复:] [quote=引用 5 楼 TeemoSmithLee 的回复:] [quote=引用 3 楼 dong_19890208 的回复:] 我测试了下,我的中文配置没有中文乱码的现象,我怀疑是你的application.properties 文件的编码格式不对,修改成UTF-8应该就好了
请教一下如何修改application.properties的文件编码格式。file->setting里面的我已经全部改成了utf-8[/quote]打开文件,右下角就能看到该文件的编码格式,点击会出现编码选项,选中就能修改了[/quote] 我测试了一下 这个左下角我显示的是UTF-8而且是灰色的不能修改的 [/quote]
回复 点赞
TeemoSmithLee 2018年03月20日
引用 9 楼 dong_19890208 的回复:
你用 appilication.yml格式的配置文件吧,appilication.properties 在Integllij IDE应该由bug

感谢大佬 问题解决,使用yml格式文件后乱码问题解决。
下面贴图



回复 点赞
TeemoSmithLee 2018年03月20日
引用 6 楼 dong_19890208 的回复:
[quote=引用 5 楼 TeemoSmithLee 的回复:]
[quote=引用 3 楼 dong_19890208 的回复:]
我测试了下,我的中文配置没有中文乱码的现象,我怀疑是你的application.properties 文件的编码格式不对,修改成UTF-8应该就好了

请教一下如何修改application.properties的文件编码格式。file->setting里面的我已经全部改成了utf-8[/quote]打开文件,右下角就能看到该文件的编码格式,点击会出现编码选项,选中就能修改了[/quote]
我测试了一下 这个左下角我显示的是UTF-8而且是灰色的不能修改的
回复 点赞
dong_19890208 2018年03月20日
引用 5 楼 TeemoSmithLee 的回复:
[quote=引用 3 楼 dong_19890208 的回复:] 我测试了下,我的中文配置没有中文乱码的现象,我怀疑是你的application.properties 文件的编码格式不对,修改成UTF-8应该就好了
请教一下如何修改application.properties的文件编码格式。file->setting里面的我已经全部改成了utf-8[/quote]打开文件,右下角就能看到该文件的编码格式,点击会出现编码选项,选中就能修改了
回复 点赞
TeemoSmithLee 2018年03月19日
引用 3 楼 dong_19890208 的回复:
我测试了下,我的中文配置没有中文乱码的现象,我怀疑是你的application.properties 文件的编码格式不对,修改成UTF-8应该就好了
请教一下如何修改application.properties的文件编码格式。file->setting里面的我已经全部改成了utf-8
回复 点赞
TeemoSmithLee 2018年03月19日
引用 1 楼 Master_wsa 的回复:
在properties配置文件中加上 server.tomcat.uri-encoding=UTF-8 spring.http.encoding.charset=UTF-8 spring.http.encoding.enabled=true spring.http.encoding.force=true spring.messages.encoding=UTF-8
请看第一个图我已经加上了
回复 点赞
dong_19890208 2018年03月19日
我测试了下,我的中文配置没有中文乱码的现象,我怀疑是你的application.properties 文件的编码格式不对,修改成UTF-8应该就好了
回复 点赞
沐洋 2018年03月19日
在properties配置文件中加上 server.tomcat.uri-encoding=UTF-8
spring.http.encoding.charset=UTF-8
spring.http.encoding.enabled=true
spring.http.encoding.force=true
spring.messages.encoding=UTF-8
回复 点赞
发动态
发帖子
Web 开发
创建于2007-09-28

5.2w+

社区成员

34.1w+

社区内容

Java Web 开发
社区公告
暂无公告