请ubuntu的大佬帮忙看一下 [问题点数:50分]

Bbs1
本版专家分:0
结帖率 0%
Bbs1
本版专家分:25
Bbs2
本版专家分:266
Bbs1
本版专家分:0
Bbs1
本版专家分:0
Bbs1
本版专家分:0
Bbs1
本版专家分:0
Bbs1
本版专家分:0
ros-indigo-moveit-full : 依赖: ros-indigo-moveit 但是它将不会被安装
ros-indigo-moveit-full : 依赖: ros-indigo-moveit 但是它将不会被安装 执行sudo apt-get install ros-indigo-moveit-full 出现以下错误: 正在读取软件包列表… 完成 正在分析软件包的依赖关系树 正在读取状态信息… 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求...
ubuntu 16.04安装ROS Kinetic ,“软件包有未满足的依赖关系”错误
在<em>ubuntu</em> 16.04安装ROS Kinetic时,爆出如下错误,<em>请</em>各位老师指导: 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求的状态造成的。该
记录ROS下python-catkin-pkg-modules、python-catkin-pkg包无法安装【已解决】
--------------------- Keyword 1 python-catkin-pkg-modules、python-catkin-pkg包无法安装 2 Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': 没有那个文件或目录 ...
在ROS中使用Python3
原链接: https://community.bwbot.org/topic/499 当前ROS是只支持Python2.7的。Python3的支持在ROS的计划中,详细的可以看这里。简单说来就是要到2019年ROS的N版本才能完全支持Python3。 首先要了解为什么ROS不能支持Python3.对于纯的Python代码同时支持Python3和Python2.7是比较容易的,基本上ROS的代码...
安装成功了的ros系统,突然提示未安装ros
之前一直用的好好的ros-kinetic,今天输入roscore..提示未安装,试了其他指令,也是未安装 百度了一下没找到同样的问题,记录一下 ada@ada-HP-Spectre-x360-Convertible-13-ae0xx:~$ roscore 程序“roscore”尚未安装。 您可以使用以下命令安装: sudo apt install python-roslaunch 首先想...
安装机器人ros驱动遇到的问题(catkin_make)
1.  关于"hardware_interface" CMake Warning at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:76 (find_package): Could not find a package configuration file provided by "hardware_interface
ros安装出现依赖问题
http://www.liuxiao.org/2015/10/ros-%E5%9C%A8-<em>ubuntu</em>-14-04-%E7%B3%BB%E7%BB%9F%E4%B8%8A%E5%AE%89%E8%A3%85-ros-indigo/ 0、安装环境: Ubuntu 14.04.3 LTS 1、配置源: 使用 ROS 官方源: 1sudo sh -c 'echo
ipython-notebook : 依赖: ipython (= 2.4.1-1) 但是它将不会被安装
在deepin 15.4.1下安装ipython-notebook报错$ sudo apt install ipython-notebook 正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
依赖: XXX 但是它将不会被安装
1. install aptitudesudo apt-get instal aptitude下列软件包有未满足的依赖关系: aptitude : 依赖: libcwidget3 但是它将不会被安装 依赖: libsigc++-2.0-0c2a (&amp;gt;= 2.0.2) 但是它将不会被安装 依赖: libxapian22 但是它将不会被安装 ...
我的ROS学习之路—创建catkin的工作空间
创建ros工作空间 在<em>ubuntu</em>终端执行以下命令 1.  source /opt/ros/kinetic/setup.bash 2.  mkdir -p ~/catakin_ws/src   连续创建两个目录 3.  cd  ~/catakin_ws/src   进入目录 4.  catkin_init_workspace   初始化工作空间创建CMakelists.txt ps:以上
编译ROS出现catkin_pkg错误
错误显示:Make sure that you have installed &quot;catkin_pkg&quot;, it is up to date and on the PYTHONPATH 方法:输入sudo gedit ~/.bashrc,打开.bashrc文件,在文件末尾加上 export PYTHONPATH=$PYTHONPATH:/usr/lib/python2.7/dist-packa...
“依赖: ros-kinetic-perception 但是它将不会被安装” 等报错
前言 水平不足,没有证实下面这个方法是一定可行的,仅作参考。 问题 最近在<em>ubuntu</em>16.04上安装ROS,版本kinetic,按官网教程操作,执行到: sudo apt-get install ros-kinetic-desktop-full 遇到了报错: 下列软件包有未满足的依赖关系: ros-kinetic-desktop-full : 依赖: ros-kinetic-des
ROS编译:catkin简析
catkin_make 与cmake的关系 程序在cmake编译是这样的流程, cmake指令依据你的CMakeLists.txt 文件,生成makefiles文件,make再依据此makefiles文件编译链接生成可执行文件. catkin_make是将cmake与make的编译方式做了一个封装的指令工具, 规范了工作路径与生成文件路径.
Kobuki学习之一:Linux驱动安装(不使用ROS)
ROS对Kobuki及以其为基础的Turtlebot有完整全面的支持。但ROS实在是一个庞大的系统。而Kobuki作为一个具有很多传感器,可以计算自身里程、位姿,可以用来做循迹、避障、SLAM的机器人底盘,应该有更广泛的使用,不能只被ROS独享。因此决定尝试脱离ROS使用Kobuki,看看情况如何。 首先,便是驱动安装的问题。本人使用的是Ubuntu 14.04LTS,4.4内核。 安装主要参
ubuntu执行 apt-get install出错:正在读取软件包列表... 有错误!
搜索出来的..   <em>ubuntu</em>执行 apt-get install出错:   正在读取软件包列表... 有错误! E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/apt/lists/cn.archive.<em>ubuntu</em>.com_<em>ubuntu</em>_dists_natty_m
ubuntu安装libzstd-dev
使用apt-get 安装 某个项目需要使用libzstd-dev库,安装步骤如下: 获取sudo权限 apt-get update apt-get libzstd-dev 报错,错误如下(E: Unable to locate package libzstd-dev): Reading package lists... Done Building dependency tree ...
ubuntu问题解决:下列软件包有未满足的依赖关系,xxx依赖xxx
sudo apt-get -f install(是修复损坏的软件包,尝试卸载出错的包,重新安装正确版本的) 然后再安装就可以了。
ubuntu 16.04 在使用apt-get install命令时出现:下列软件包有未满足的依赖关系错误
1、出现错误的命令:sudo apt-get install dpkg2、出现的错误信息:您可能需要运行“apt-get -f install”来纠正下列错误: 下列软件包有未满足的依赖关系: cups : 依赖: cups-common (&amp;gt;= 2.1.3-4<em>ubuntu</em>0.4) 但是 2.1.3-4 正要被安装 cups-bsd : 依赖: cups-common (&amp;gt;= 2....
ubuntu安装软件时:有未能满足的依赖关系
通常的原因是:1、软件依赖于某一软件旧的版本,可是你却已经安装了新的。 2、要装A, 依赖B, 但是已经安装的软件C也依赖B, 但是A依赖的B的版本和C依赖的B的版本不一致, 导致了如果要安装B,那么C便不能正常运行了,所以系统报错。解决办法:方法(一):步骤1:更新软件源。<em>ubuntu</em>自带的软件源比较旧,很多的软件版本较低,国内比较好用的源有阿里源;                sudo cp...
pat-get 与aptitude的区别 处理:下列软件包有未满足的依赖关系:
有时候我们在<em>ubuntu</em>系统中用apt-get install 安装软件包时或出现以下错误:下列软件包有未满足的依赖关系:... ....这是我们可以考虑用sudo aptitude install  ... ... 的安装工具安装,举个例子:原来使用sudo apt-get install python-pip会提示以上错误。改成以下命令:sudo aptitude install python...
ubuntu tar、dpkg子进程错误
命令行失败信息如下: tar:无法识别的选项“--warning=no-timestamp” <em>请</em>用“tar --help”或“tar --usage”获得更多信息。 dpkg-deb: error: 子进程 tar 返回了错误号 64 dpkg:处理 /var/cache/apt/archives/vim-common_2%3a7.3.429-2<em>ubuntu</em>2_i386.deb (--un
E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系...
安装terminator等一些软件等时候,遇到了这样等问题 leo@leo:~$ sudo apt-get install terminator [sudo] password for leo: 正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也...
Linux Mint软件安装问题--无法修正错误,因为您要求某些软件包保持现状
之前在Windows下一直使用的是网易云音乐听歌,现在安装了Linux Mint之后一直没安装音乐播放器,今天去网易云音乐官网中发现其有提供Linux版本的网易云音乐,赶紧下来感受一下,官网上提供了以下几个版本 这里下载的是<em>ubuntu</em>16.04(64位)版本,安装时发现终端上提示了各种错误,缺少很多依赖关系,经过一番苦战之后发现还是有一个顽固的依赖关系,如下 一直提示未安装gstre
无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
安装terminator等一些软件等时候,遇到了这样等问题 下列软件包有未满足的依赖关系: terminator : 依赖: python-support (>= 0.90.0) 但是它将不会被安装 依赖: python-vte 但是它将不会被安装 推荐: python-gnome2 但是它将不会被安装 推荐: python-keybinder 但是它将不会被安装E: 无法修正错误,因为您
解决dpkg: error processing /var/cache/apt/archives/python-apport_2.0.1-0ubuntu9_all.deb
在<em>ubuntu</em>上通过apt-get install 安装包的时候会出现 unmet dependency的问题,根据提示使用 sudo apt-get -f install 也没有用 在https://ask<em>ubuntu</em>.com/questions/148383/how-to-resolve-dpkg-error-processing-var-cache-apt-archives-python-a...
各位大佬帮忙看一下
各位<em>大佬</em><em>帮忙</em>看一下做的坦克大战的游戏,不知道为什么生成敌人的坦克的时候总是在凤凰老家的位置生成,明明代码里面没写这个位置的
python安装第三方模块出现错误 failed with exit status 2
error: Command "C:\Users\pmhgms\AppData\Local\Programs\Common\Microsoft\Visual C++ for Python\9.0\VC
dpkg: 处理归档 /var/cache/apt/archives/libexpat1-dev_2.2.5-3_amd64.deb (--unpack)时出错:
使用sudo apt-get install 安装软件的时候报错: dpkg: 处理归档 /var/cache/apt/archives/libexpat1-dev_2.2.5-3_amd64.deb (--unpack)时出错:  正试图覆盖 /usr/include/expat.h,它同时被包含于软件包 expat-devel 2.2.6-2 dpkg-deb: 错误: 子进程 粘贴 被信号...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-i386_2.19-0ubuntu6.6_amd64.deb
类似此类错误都可以这么解决 sudo dpkg -i --force-overwrite /var/cache/apt/archives/*.deb *为上图中(--unpack)前面的那个deb文件,看图最后一条
dpkg: error processing /var/cache/apt/archives/python-apport_2.0.1-0ubuntu9_all.deb 解决方法
如果在使用apt-get时出现类似下面错误: dpkg: error processing /var/cache/apt/archives/python-apport_2.0.1-0<em>ubuntu</em>9_all.deb 解决方法: sudo dpkg -i --force-overwrite /var/cache/apt/archives/python-problem-report_2
ubuntu主线版本下的/var/cache/apt/archives文件夹说明-系统清理
/var/cache/apt/archives文件夹中的文件是使用sudo apt-get install appname时下载的安装文件,这些文件是可以清理的,若你系统空间不足的时候,可以想到从此处进行清理而获得空间。在我的PC下的文件有,如下:  /var/cache/apt/archives $ ls acct_6.5.5-1<em>ubuntu</em>4_amd64.deb
无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系
在树莓派安装ros(参考网页http://wiki.ros.org/ROSberryPi/Installing%20ROS%20Kinetic%20on%20the%20Raspberry%20Pi,的过程中,
ubuntu 16.04下安装flann
之前直接从官网下了源码进行编译,可是pip setup.py install 后一直显示package dir不存在,渣渣如我,不知道原因,果断换方法.还是pip大法好啊,pip install pyflann就哦了!...
Ubuntu16.04使用FLANN出现的错误记录
错误记录:/usr/bin/ld: xx.o: undefined reference to symbol '_ZN3MPI8Datatype4FreeEv' //usr/lib/libmpi_cxx.so.1: error adding symbols: DSO missing from command line解决方法: 在CMakeLists.txt中,加上:ADD_TARGET(xxx x
linux(ubuntu16.04) /windows10+Flann编译及使用
真是一把辛酸泪。 首先注意修改文件: nearest_neighbors.cpp: /*#include */ #include "flann/flann.cpp" 1. windows 下载flann压缩包并解压,这里我下载官网的不知道为什么一直编译失败(摊手),这里下载的成功了https://github.com/mariusmuja/flann
PCL1.8+Ubuntu16.04安装详解
方式一:官网prebuild版本 sudo add-apt-repository ppa:v-launchpad-jochen-sprickerhof-de/pcl sudo apt-get update sudo apt-get install libpcl-all可能是因为国内的关系,并没有更新 apt-get 成功 方式二:安装 prebuilt DEB file for PCL 1.8
ORB_SLAM2系列之一:Ubuntu 编译安装ORB_SLAM2
环境 Ubuntu 14.04 +ROS indigo 解决依赖 首先需要编译安装GLEW和Pangolin 安装GLEW: sudo apt-get install libx11-dev sudo apt-get install libgl1-mesa-dev sudo apt-get install libglu1-mesa-dev sudo apt-get insta...
PCL1.8+Ubuntu16.04安装详解以及运行时遇到的一些错误
方式一:官网prebuild版本 sudo add-apt-repository ppa:v-launchpad-jochen-sprickerhof-de/pcl sudo apt-get update sudo apt-get install libpcl-all 可能是因为国内的关系,并没有更新 apt-get 成功方式二:安装 prebuilt DEB file for PCL 1...
k近邻法(k-NN)笔记3-第三方库FLANN介绍-下载/编译/测试代码解析
k近邻法(k-NN)笔记3- 第三方实现(PCL点云库kdtree模块)笔者我查阅了较多kdtree的第三方实现,下载调试了github上及其他途径的代码,结合个人喜好和对比结果,推荐PCL点云库kdtree模块。PCL库是大型跨平台开源C++编程库,实现了大量点云相关的通用算法和高效数据结构,其中划分了许多模块,其中有一个核心问题就是建立离散点间的拓扑关系,实现基于邻域关系的快速查找。 具体详情...
ROS安装出现错误无法继续进行
-
Ubuntu上安装vim不能安装的问题,“下列的软件包有不能满足的依赖关系”
前阵子,刚安装Ubuntu时,安装vim的问题,现在些出来分享一下。 apt-get install vim 正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,
ubuntu 17.10 安装后软件包有未满足的依赖关系
求助一下各位老师,我刚接触<em>ubuntu</em>,最近下载安装了<em>ubuntu</em> kylin 17.10版本后,联网更新软件,发生了一个错误,错误信息:“错误:已损坏个数>0”, 这通常意味着您安装的软件包有未满足
Ubuntu16.04下PX4 开发环境配置
PX4 Ubuntu1604 开发环境配置 问题1 依赖错误及安装时404错误 问题2 安装基于NuttX的硬件出错 问题3 编译报错 问题3 QT配置问题PX4 Ubuntu16.04 开发环境配置看到官网有详细介绍(官网安装说明链接)时,喜出望外,列下了一串学习任务,以为会很快就搞定开发环境,结果搞了半天发现自己还是too young too naive,一步一个坑,暂时记录下来,留给有需要的人
ubuntu下列软件包有未满足的依赖关系
临时解决案: $ apt-get remove conflict-pa
创建ROS 工作空间时出现:程序“catkin_init_workspace”尚未安装,程序“catkin_make”尚未安装。...
问题:创建ROS 工作空间时出现:程序“catkin_init_workspace”尚未安装,程序“catkin_make”尚未安装。 解决方法: source /opt/ros/kinetic/setup.bash 转载于:https://www.cnblogs.com/fuhang/p/9781739.html...
markdown编辑器
功能快捷键 撤销:Ctrl/Command + Z 重做:Ctrl/Command + Y 加粗:Ctrl/Command + Shift + B 斜体:Ctrl/Command + Shift + I 标题:Ctrl/Command + Shift + H 无序列表:Ctrl/Command + Shift + U 有序列表:Ctrl/Command + Shift + O 检查列表:Ctrl/...
Ubuntu中ROS中安装catkin问题
之前看代码写代码一直没用IDE,后来看的代码多了,需要安装个IDE,然后就装了QT,感觉很不好用,openproject后无法编译,索性就卸载删除,卸载删除后,ros工程catkin_make的时候出现需要安装 catkin!!!!! 之前都正常编译的,这是什么鬼!没有遇到过,然后百度google各种查。 执行sudo apt install catkin 同时出现python-catkin...
程序“roscore”尚未安装
已经安装过ROS,但在运行roscore时,提示程序“roscore”尚未安装。 您可以使用以下命令安装:sudo apt install python-roslaunch, 解决办法: 终端gedit .bashrc 查看是否还有“source /opt/ros/kinetic/setup.bash”这一行,如果有,那就在终端在source ./bashrc 问题解决。 ...
程序“mm”尚未安装。 您可以使用以下命令安装: apt-get install multimail
执行mm编译程序时,报错:程序“mm”尚未安装。 您可以使用以下命令安装: apt-get install multimail 不要安装multimail这个软件,直接source build/envsetup.sh即可
Ros-Indigo 在catkin_make出现报错 (无法找到程序包的配置文件)
我在跟随教程从源代码下载和构建Ros-Industrial/robotiq驱动程序的时候,返回工作空间根目录(catkin_ws)使用catkin_make编译工作空间的时候遇到了困难。 CMake Warning at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:76 (find_package):     Could not f...
Ubuntu 16.04下源码安装Catkin
一、下载源代码 Catkin ~$ sudo apt-get install git ~$ git clone https://github.com/ros/catkin 二、安装依赖项 1、Catkin具有以下依赖性: ·[CMake](https://cmake.org/) - 一个跨平台的开源构建系统。 ·[Python](https://www.python.or...
dpkg-deb:错误:control目录的的权限位是 777 (必须 >=0755 且 <=0755)
最近装了一个Ubuntu虚拟机,想在上面装一个qq。下了一个deb的安装包“Linuxqq_v1.0.2-beta1_i386.deb”。执行时提示版本号开头必须是数字,于是用dpkg-deb -x和
子进程 post-installation script 返回了错误号
在<em>ubuntu</em>上使用apt-get安装软件的时候出现如下错误:正在设置 nfs-common (1:1.2.2-4<em>ubuntu</em>5) ...dpkg:处理 nfs-common (--configure)时出错: 子进程 已安装 post-installation 脚本 返回了错误号 10正在设置 samba-common (2:3.5.8~dfsg-1<em>ubuntu</em>2.3) ...dpkg:处理 s...
sudo apt-get install 报错
Ubuntu 16.0.4中,有时候运用sudo  apt-get install 安装软件时,会出现一下的情况E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)E: Unable to lock the administration directory (/var/lib/d...
E: 子进程 已安装的 post-removal 脚本 返回了错误号 2
http://forum.<em>ubuntu</em>.org.cn/viewtopic.php?f=77&t=213816 error  信息如下 正在设置 sl (3.03-16) ... 在处理时有错误发生:  man-db E: Sub-process /usr/bin/dpkg returned an error code (1) root@liu-laptop:/wor
sudo apt-get install vim
tar:无法识别的选项“--warning=no-timestamp” <em>请</em>尝试执行 “tar --help” 或 “tar --usage” 来获取更多信息。 dpkg-deb: error: 子进程
Ubuntu更新错误--子进程已安装,返回错误号1
Ubuntu中常用的两条更新系统的指令如下:
子进程 post-installation script 返回了错误号 解决方法
这几天用<em>ubuntu</em>14.04,在用apt-get安装软件时出现了类似于  :  install-info: No dir file specified; try --help for more information.dpkg:处理 gettext (--configure)时出错: 子进程 post-installation script 返回了错误号 1 在处理时有错误发生:  fin
Real Time Face Tracking and Recognition下载
实现了人脸的检测、跟踪与识别,包括几种算法,详细内容及安装请看readme.txt 相关下载链接:[url=//download.csdn.net/download/hp_lan/2237300?utm_source=bbsseo]//download.csdn.net/download/hp_lan/2237300?utm_source=bbsseo[/url]
过NP e c 可过大部分网游下载
汉化的 很好用 不要在进行设置 这个你能做到的 相关下载链接:[url=//download.csdn.net/download/mzjf000/3161159?utm_source=bbsseo]//download.csdn.net/download/mzjf000/3161159?utm_source=bbsseo[/url]
3D游戏编程大师技巧下载
3D游戏编程大师技巧,感兴趣的人可看看。 可以阅读 相关下载链接:[url=//download.csdn.net/download/frank_20080215/8852083?utm_source=bbsseo]//download.csdn.net/download/frank_20080215/8852083?utm_source=bbsseo[/url]
相关热词 c# login 居中 c# 考试软件 c# 自然语言分析 c# 分段读取文件 c# 泛型反射 c#打断点 c# 时间转多少秒 c# 线程函数加参数 c# modbus 读取 c#查询集合表
我们是很有底线的