关于vs2017 打包程序无法选择.net framework4.0版本 [问题点数:100分,结帖人likelinsiyuan]

Bbs5
本版专家分:2523
Blank
Github 绑定github第三方账户获取
结帖率 100%
Bbs7
本版专家分:22704
Blank
金牌 2019年5月 总版技术专家分月排行榜第一
2019年4月 总版技术专家分月排行榜第一
Blank
银牌 2019年3月 总版技术专家分月排行榜第二
Blank
红花 2019年5月 .NET技术大版内专家分月排行榜第一
2019年4月 C/C++大版内专家分月排行榜第一
2019年4月 .NET技术大版内专家分月排行榜第一
2019年3月 .NET技术大版内专家分月排行榜第一
Bbs5
本版专家分:2523
Blank
Github 绑定github第三方账户获取
【C#】VS2017 winform 打包以及打包遇到的问题
最近<em>打包</em>一个客户端软件,遇到一些问题呢, 所以写下来供大家参考一下,主要担心我再忘记了~~哈哈 首先要在想要<em>打包</em>的项目下创建一个新的项目,创建好setup项目,之后点击属性,去修改<em>打包</em>软件的名字,ProductName。。。。可以选填到此已经创建好了setup工程了,那么下面开始将要<em>打包</em>的debug文件下的内容都copy到Application Folder中。点击Application Fo...
VS 2010只有.net Framework 4.0可以选择的解决方案。
在网上找到的。这个方法对我的个案有效。 其实很简单。1. 安装.<em>net</em> framework 3.5 sp1就行2. 重启动。
ClickOnce部署DotNETFrameWork流程及注意事项
ClickOnce部署DotNETFrameWork流程及注意事项            用户在使用WinForm应用<em>程序</em>,通常需要首先安装对应的.NET Framework 框架。所以,当开发人员在发布应用<em>程序</em>时,将该项目对应的.NET Framework<em>版本</em>同时发布也是非常必要的工作。下面介绍在Visual Studio 2015环境下对.NET Framwork 4.5.2<em>版本</em>的发布操作
VS2010等版本出现针对“NETframework vision=4.0”,但计算机没有安装它
在创建一个工程之后,关闭vs2010,想再次打开上一次的解决方案和工程的时候,出现了   针对“NETframework,vision=4.0”,但计算机没有安装,请<em>选择</em>下面两个选项中一个,这是你的电脑上的vs2010缺少了这个东西,只要在自己电脑的<em>程序</em>(卸载<em>程序</em>)里面对VS2010进行一个修复就可以了,修复结束的时候可以下载文档中的“NETframework,vison=4.0”就可以,点击完成
InstallShield12集成.net framework4.0环境安装包制作
该文档是本人使用InstallShield12进行<em>打包</em>时整理出来的,当时碰到并花了不少时间才解决了以下几个问题: 1、检测并自动安装.NET4环境; 2、重新安装后桌面快捷方式“打开文件位置”<em>无法</em>使用; 3、解决打出的安装包安装时出现长时间无反应的现象;
C# 如何用ILMerge为应用程序打包
ILMerge是合并.<em>net</em>的assembly的工具,最新版的支持.<em>net</em> 4.0的ILmerge下载: http://www.microsoft.com/downloads/details.aspx?FamilyID=22914587-b4ad-4eae-87cf-b14ae6a939b0&displaylang=en ILMerge使用方法详解: ILMerge是将 C#制作
win7下IIS的安装和配置、以及framework4.0版本网站的发布
以为是件容易的事,可也怕出错,也到网上找了教程,就这样中间还出了两次错。可能使用了VS2012吧,framework<em>版本</em>比较高,出的错以前都没见过。这里把详细过程写出来方便大众,也给自己留个备份,所以才定了是怀旧篇。毕竟大家都说我很笨。 第一步、安装IIS 1,打开控制面板-<em>程序</em>-打开或关闭windos功能 2,找到“Inter<em>net</em> 信息服务”,按照下图打勾即可(打√的表示子项已经全选...
解决调试.net framework源代码时遇到的问题
项目中遇到棘手问题,需要彻底搞清.<em>net</em> Framework中<em>关于</em>SOAP webservice proxy的一些实现的细节。 从Visual Studio 2008开始,开发者可以通过设置Visual Studio,跟踪.<em>net</em> Framework内部代码。 具体方法如下: http://referencesource.microsoft.com/serversetup.asp...
【问题】应用程序池中无Framework v4.0
应用<em>程序</em>池中无Framework v4.0
VS2017 打包 从与我的应用程序相同的位置下载系统必备组件
VS2017第一次<em>打包</em><em>程序</em>,想把NET4.5.2<em>打包</em>进项目,遇到: ERROR: 要在“系统必备”对话框中启用“从与我的应用<em>程序</em>相同的位置下载系统必备组件”,必须将“Microsoft .NET Framework 4.5.2 (x86 和 x64)”项的文件“Dot.. 网上找办法都是让把NDP452-KB2901907-x86-x64-AllOS-ENU.EXE 放到 C:\Pr
解决C# framework2.0程序升级到framework4.0的问题
加App.config文件加下列内容
使用VS2017+QT5.12.1打包发布应用程序教程
1.在Release模式下生成运行,生成..exe 2.把生成的.exe文件放在一个文件夹下(要<em>打包</em>的文件夹) 3.我自己在生成的时候用QT的命令行工具,用管理员身份打开。 4.跳转到要<em>打包</em>的文件夹目录下,执行:windeployqt  xxx    其中XXX为前面Release生成的.exe文件名 5.成功执行后,再目录下会<em>打包</em>进一堆库文件,然后把文件夹直接压缩给别的电脑就可以用了...
Visual Studio 2017&C#打包应用程序详细教程,重写安装类获取安装路径,附加各种奇葩问题描述
前言 C#写好一个应用<em>程序</em>,总想分享给自己的朋友或者上架,然而被困在<em>打包</em>之外,这次为大家带来近期我的经验,经过几天的摸索,发现网上的教程并不全面,会给初学者带来很多疑问,这里将做些问题描述与解答。 /** 开发工具:Visual Studio 2017 系统<em>版本</em>:win10 x64 要求:已经有一个已完成的项目 */
关于使用MATLAB2016b 或Matlab2017a转换exe程序无法加载vs2017的问题
使用matlab2017a的请<em>选择</em> attachment_1487958_17a_win64_2017-05-10 使用matlab2016b的请<em>选择</em> attachment_1487958_16b_win64_2017-05-10 具体操作方式见操作说明
IIS应用程序池添加ASP.NET v4.0
IIS应用<em>程序</em>池添加ASP.NET v4.0 可能在安装.NET Framewrok 4.0之前,IIS就已经装好了,结果在IIS的应用<em>程序</em>池中只有.NET 2.0的Classic .NET AppPool和DefaultAppPool
关于无法选择实体框架EF版本问题
  安装新<em>版本</em>的EF或安装对应<em>版本</em>EF即可。 闪退问题详见:https://blog.csdn.<em>net</em>/qq_40521205/article/details/86603709 问题整合: (1)<em>关于</em>VS<em>无法</em><em>选择</em>mysql数据源问题 地址:https://blog.csdn.<em>net</em>/qq_40521205/article/details/86603679 (2)<em>关于</em>使用ADO.NET实...
vs2017 更换现有c#客户端项目的.framework版本
<em>版本</em><em>选择</em>注意: winxp系统,建议<em>选择</em>3.5 方案一 第一步:选中当前项目名称,右键-&amp;gt;属性  第二步:应用<em>程序</em>-&amp;gt;目标框架 可以<em>选择</em>合适的<em>版本</em>。  方案二 第一步:选中已生成的项目,双击 Microsoft .NET Framework 第二步:.NET Framework 右键点击,<em>选择</em> 属性窗口   第三步:点击version,<em>选择</em>合适<em>版本</em> ...
C#WinForm中CefSharp.Winform示例代码(VS2010、.net4.0)
C#WinForm中使用CefSharp.Winform的示例代码,开发环境为VS2010、.NET4.0。CefSharp.Winform<em>版本</em>为49.0.1
[C#] VS2017中在某些目录下使用不了 .NET Core 2.0 问题的处理办法
作者: zyl910 一、缘由 最近遇到了一个奇怪的问题——明明已经在VS2017里装好了 .NET Core 2.0 SDK,且测试过新建一个 .NET Core 2.0控制台项目能成功使用。但是在项目目录中实际使用新建.NET Core 2.0控制台项目时,会遇到不支持 .NET Core 2.0 的错误提示。 Severity Code Description Projec...
【C#】vs2017 发布工具 Visual Studio Installer 发布包遇到的问题处理经验
一、遇到的问题 在安装了<em>vs2017</em> 社区版(Community)之后  想<em>打包</em>安装<em>程序</em>(winform) 还是想用之前的 installshield来<em>打包</em>  发现居然打不了,在官网查了    installshield不支持社区版(Community),后来尝试用vs自带的ClickOnce<em>打包</em>遇到以下问题:       1.严重性 代码 说明 项目  文件 行 禁止显示状态 错误 要在“
.net framework4.0环境
.<em>net</em> framework 4.0安装环境,环境请从低<em>版本</em>安装起才能实现高低<em>版本</em>共存
Dotfuscator Pro 4.10.2 .NET混淆器 完美破解版 4.9.9升级版
Dotfuscator是VS.NET混淆器和压缩器,它可以帮助您防止您的应用<em>程序</em>被反编译。同时,它还可以使得您的应用<em>程序</em>更加小巧以及高效。 本<em>程序</em>为破解牌,直接安装便可使用。
zxing.net二维码.net版本
https://zxing<em>net</em>.codeplex.com/
[VS2017][C#]打包发布安装版程序(修改默认安装地址/卸载等)
Microsoft Visual Studio 2017 Installer Projects的使用及快捷方式/卸载<em>程序</em>/x86平台报错问题的解决
.NetFrameWork4.0版本的Dapper
可以作为.NetFrameWork4.0环境下的Dapper简单学习,可以完成相应的例子<em>程序</em>开发
vs2017程序打包
https://www.cnblogs.com/1175429393wljblog/p/8398345.html
安装了.net framework 4.0后,还需要安装.net framework 3.5,因为.net组件是独立的,不是先下兼容的
.<em>net</em> framework X的几个<em>版本</em>,不是向下兼容的,是独立的,
一、VS2017桌面程序打包成.msi或.exe全过程
安装<em>打包</em>插件:Microsoft Visual Studio 2017 Installer Projects
Kafka .Net Framework4.0 版本
Kafka .Net Framework4.0 <em>版本</em> 有完整的依赖包 Visual C++ Redistributable Packages for Visual Studio 2013
VS2010制作安装包时没有.net framework2.0选项的解决办法
将“C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\DotNetFX ”复制到“C:\Program Files\Microsoft SDKs\Windows\v7.0A”下即可。 没有其他.<em>net</em>framework<em>版本</em>时可参照复制。
搞懂.NET Framework 历史版本(2017年)
最近被.NET平台各种名词、以及各种<em>版本</em>弄得有些疑惑,开发和部署,对于开发平台<em>版本</em><em>选择</em>是个基本问题,因此,花了些时间,学习汇总了有关.NET<em>版本</em>演进的历史。 .NET简介 这个平台相信我们都知道,不过随着技术发展,现在的.NET平台也今非昔比。 .NET平台类似Java平台,是微软于2000年推出的Windows操作系统的应用软件开发框架,发展至今形成巨大的技术栈,涉及多语言
qt5+vs2017程序打包发布,在其他电脑上运行
最近刚刚接触qt5编写界面<em>程序</em>,新手上路可谓是困难重重啊,你永远不知道下一个困难会在什么时候出现,这里分享一个qt5+<em>vs2017</em>的<em>打包</em>发布方法,希望能对新手有所帮助,废话不多说,请继续看下去。 一、dll(动态库链接) 发布qt<em>程序</em>,就要找到dll文件,使用qt自带的 windeployqt 可以自动寻找dll文件 1、我使用的是 Qt 5.11.1 64-bit for Desk...
编译时提示程序集引用找不到与.Net Framework 4 Client Profile
在Ioc容器的性能测试中,在Munq代码完编译时出现Error:“The type or namespace name 'Munq' could not be found (are you missing a using directive or an assembly refe
VS2017 netcore 发布遇到错误,框架依赖型应用程序主机需要一个至少netcoreapp2.1的目标框架
一、引言 .<em>net</em>core目前处于高速发展时期,<em>版本</em>更新比较快,<em>vs2017</em>最新<em>版本</em>对.<em>net</em>core支持也跟进的比较快,使用最新<em>版本</em>的<em>vs2017</em>开发历史<em>版本</em>的.<em>net</em>core项目时多多少少会碰到一些兼容性问题,虽然微软声称是兼容历史<em>版本</em>的,但是采坑依然是少不了的。 二、问题 开发环境:VS2017(<em>版本</em>号15.8.1) 团队项目使用的是.<em>net</em>core 2.0开发的,项目在本机编译运行...
RestSharp 支持4.0、3.5、net4-client、net35-client(找了很久)
dll支持4.0、3.5、<em>net</em>4-client、<em>net</em>35-client,找了很久,才发现一个真正可用的,大家注意看我发的<em>版本</em>。
Wix工具集,良好的支持vs 2017制作安装程序的工具
WiX工具集允许开发人员为Windows安装引擎Windows Installer创建安装<em>程序</em>。 WiX的核心是一组构建工具,它们使用与产品其余部分相同的构建概念构建Windows Installer<em>程序</em>包:编译源代码然后链接以创建可执行文件; 在这种情况下,.exe安装包,.msi安装包,.msm合并模块和.msp补丁。WiX命令行构建工具适用于任何自动构建系统。此外,命令行,Visual Studio和Team Build支持MSBuild。 WiX包含几个扩展,提供超出Windows Installer的功能。例如,WiX可以安装IIS网站,创建SQL Server数据库,以及在Windows防火墙中注册例外等。 使用Burn(WiX引导<em>程序</em>),您可以创建安装<em>程序</em>包,以便安装.NET Framework和其他运行时等先决条件以及您自己的产品。Burn允许您下载包或将它们组合成一个可下载的.exe文件。 WiX SDK包括托管和本机库,可以更轻松地编写适用于Windows Installer的代码,包括C#和C ++中的自定义操作。
vs.net打包自动检测环境并安装.net framework
vs.<em>net</em><em>打包</em>或者制作安装<em>程序</em>时进行自动检测环境并安装.<em>net</em> framework的设置方法:             1. 新建一个“安装和部署”的项目;             2. 然后点击“视图”菜单,<em>选择</em>“编辑器”--“文件系统”,然后将要<em>打包</em>的<em>程序</em>以及相关文件添加进来,之后<em>程序</em>将自动检测依赖项;             3. 再次<em>选择</em>“视图”菜单,<em>选择</em>“编辑器”--“启动条件...
net framework 4.0 sp1 补丁 cn
<em>net</em> framework 4.0 sp1 补丁
Smobiler 4.4已正式发布!(Smobiler能让你在Visual Studio上开发APP)
Smobiler 4.4已经正式发布,还不快来看看?原文地址:https://www.smobiler.com/portal.php?mod=view&amp;amp;aid=53这次更新要感谢我们的用户,在使用smobiler的过程中不吝反馈,同时我们的<em>程序</em>员也及时响应用户提出的新增、优化、修复等内容。 在这次更新中,与旧<em>版本</em>的主要差异如下(重要考点,敲黑板):1, 修改Smobiler.Core.Co...
Newtonsoft.Json.dll对各.Net版本
Newtonsoft.Json.dll对各.Net<em>版本</em>,包括.<em>net</em> 2.0 3.5 4.0 4.5 以及 <em>net</em>standard1.0 1.3 2.0 等。
若要针对 .NET Framework 4.0 或更高版本进行编译,则提供程序选项中“compile
安装了vs2013,新建一个空网站,发现出现错误:若要针对 .NET Framework 4.0 或更高<em>版本</em>进行编译,则提供<em>程序</em>选项中“compilerVersion”特性的值必须为“v4.0”或更高<em>版本</em>。若要针对 .NET Framework 3.5 或更低<em>版本</em>编译此 Web 应用<em>程序</em>,则请从 Web.config 文件的 元素中移除 targetFramework 特性 后来找了资料,微软
vs2010打包系统必备选择.net framework 3.5sp1编译错误的解决方法
利用visual studio 2010进行<em>打包</em><em>程序</em>,默认安装的是Framework 4.0,如果需要将3.5sp1<em>打包</em>到系统中一起安装(<em>选择</em>了"从与我的应用<em>程序</em>相同的位置下载系统必备组件"时),会提示很多诸如此类错误“系统必备组件的安装位置未设置为“组件供应商的网站”,<em>无法</em>在磁盘上找到项“.NET Framework 3.5 SP1”中的文件“DotNetFX35SP1/DotNetFX35/x
已安装Framework4.0,仍提示没有安装Framework4.0问题
部分电脑安装Framework4.0成功,但运行4.0<em>程序</em>时仍提示未安装Framework4.0(Win7上再安装4.5后仍不管用)。碰到有该问题的电脑占极少数 原因: 文件 %windir%\system32\mscoree.dll 或(和)%windir%\SysWOW64\mscoree.dll在安装过程中未能应用对应高<em>版本</em>的文件,仍就是V2.0.*版或其他低<em>版本</em>,出现这种情况的原因是安
Windows程序打包,使用VS2017
作者:KwokKwok链接:https://www.jianshu.com/p/be0ea8c04643來源:简书安装依赖组件首先打开扩展和更新:扩展和更新联机查找下面的组件,然后安装,重启VS。安装依赖组件创建项目文件作为应用的主<em>程序</em>。比如这里我就创建一个简单的项目,只有一个窗口:创建一个简单的项目创建一个<em>打包</em>项目先右键解决方案,<em>选择</em> 添加-新建项目创建<em>打包</em>项目我这里就起名为PackageDem...
Python 调用.net framework写的类库的方法
 版权声明请尊重原创作品。转载请保持文章完整性,并以超链接形式注明原始作者“tingsking18”和主站点地址,方便其他朋友提问和指正。 Python 调用.<em>net</em> framework写的类库的方法1. 安装python2.5和对应的pywin32安装方法:略。 2. 下载ironPython源代码 是C#的。我用的是IronPython1.1的<em>版本</em>,
Quartz.net使用入门(三)
Windows服务,自定义安装,卸载服务+Quartz.<em>net</em>app.config配置文件 System.Configuration.NameValueSectionHandler, System, Version=1.0.
VS2017安装打包工具;以及无法加载此项目,setup(不兼容),该应用程序未安装、MFC的使用
感谢分享 VS2017安装<em>打包</em>工具,相比Installshield好用吧   下载 1、打开VS2017,工具---&amp;gt;扩展和更新--&amp;gt;联机--&amp;gt;搜索---&amp;gt;Microsoft Visual Studio2017 Installer Projects --&amp;gt;下载   修改 开始安装         安装中 这里加入VS还在运行,则会提示...
MVCnet4.0引用 Newtonsoft.Json.dll版本,升级冲突问题
因MVC使用<em>版本</em>为<em>net</em>4.0,升级问题太多问题,放弃升级<em>版本</em>5.0。在要引用Newtonsoft.Json 9.0.0.0<em>版本</em>时运行报错,说是没有找到“Newtonsoft.Json 4.0.0.0”<em>版本</em>,需要我引用4.0.0.0<em>版本</em>,但是我需要引入高级<em>版本</em>来执行我的class。          <em>net</em>4.0<em>版本</em>默认使用Newtonsoft.Json.dll 4.0.0.0,需要引用高级<em>版本</em>
Setup Factory 打包程序 --程序安装前判断本机是否安装.NET Framework和SQL Server
.NET Framework 4.0 result = Registry.DoesKeyExist(HKEY_LOCAL_MACHINE, "SOFTWARE\\Microsoft\\.NETFramework\\policy\\v4.0"); if (result == false) then Dialog.Message("提示", "请先安装.<em>net</em>4.0\r\n.<em>net</em>4.
Sqlite类库,基于framework 4.0框架
// // Copyright (c) 2009-2010 Krueger Systems, Inc. // using System; using System.Runtime.InteropServices; using System.Collections.Generic; using System.Reflection; using System.Linq; using System.
如何使用VS2017将客户端库添加到ASP.NET CORE 2.2(简单方法)
目录 介绍 先决条件 步骤 外部参考 在VS 2017 ASP NET Core 2.2项目上使用UI安装客户端库的简便方法 介绍 Libman是一个轻量级的客户端库获取工具。适用于简单的Web应用<em>程序</em>或不需要高级工具的项目(例如:npm / web pack),这对小型应用<em>程序</em>来说太过分了。早期的bower在VS 2017上使用,但不幸的是bower出现问题,所以VS团队<em>选择</em>使用L...
vs2017安装打包功能
不知道什么原因,vs2107搜索更新找不到安装<em>打包</em>功能,就在找到插件(InstallerProjects.vsix),下载并安装,插件下载地址如下:https://visualstudioproductteam.gallerycdn.vsassets.io/extensions/visualstudioproductteam/microsoftvisualstudio2017installerpr...
mysql.data.dll(.net 4.0或以前版本
mysql.data.dll for .<em>net</em> 2.0, 3.0, 3.5, 4.0.用于unity中使用.<em>net</em>3.5框架链接数据库。
Microsoft .NET Framework4.0 安装程序
Microsoft .NET Framework4.0 安装<em>程序</em>,为安装.NET Framework4.0 <em>程序</em>的电脑点击直接引导安装
VS2017程序打包
参考文章:http://www.cnblogs.com/overstep/p/6942423.html
VS2017 启动调试出现 无法启动程序 当前状态中是非法
VS2017 启动调试出现 <em>无法</em>启动<em>程序</em>“http://localhost:15613” 操作在当前状态中是非法的。 同时附加进程也是错误的解决方法遇到这个问题网上百度都说是 防火墙的问题但是我修改了防火请依旧没有用在论坛看见有人的回复解决了问题工具--选项--调试--常规--启用asp.<em>net</em>的JavaScript调试(chrome和ie)去掉勾选...
Mysql的.Netframe4.0版本
包含Mysql.Data的5个dll文件,.<em>net</em>frame4.0<em>版本</em>。亲自测试引用成功。
Win7卸载了FrameWork4.0后,再重装Framework4.0,vs2010显示“此计算机上没有安装.NETFramework,Version=v4.0”
昨天因为个别原因,把系统中的Framework7.0给卸载了,然后今天用VS2010打开以前的项目时,弹出如下的弹出框 然后就郁闷了,在网上找了好多办法,最后无奈,只有卸载了vs2010,然后又从新安装了一下,问题解决了。 其实我主要是想记录下我在网上找到的一些解决方法,虽然没有解决我的问题,但感觉还是很有用的 1.将Framework4.0在IIS中注册下   打开<em>程序</em>-
zxing.net framwork4.0 中文字符集重新编译版本,pdf417二维码生成识别经测试可用
zxing.<em>net</em> 中文二维码乱码问题解决,附件为修改后重新编译的dll。.<em>net</em>framwork4.0编译,测试使用pdf417二维码,中文生成和识别二维码可用。
2017iOS开发最新的打包测试步骤(亲测)
最近也是忙着修改项目,今天把最近遇到的问题和知识给大家分享一下。有时候我们需要将我们的项目发给测试组进行bug测试,这时候我们就需要把自己的项目<em>打包</em>,生成一个二维码或者链接的形式,给测试组,接下来就是操作步骤还是要注意两个问题:1、有付过钱的开发者账号;2、Xcode软件是正规下载的软件1、进入开发者中心,登录付过费的开发者账号https://developer.apple.com/cn/2、进入
win7环境下无法安装framework 4.0的问题
本人win7系统,在安装某些软件的时候提示需要framework,如果多次尝试均未成功,推荐你安装framework 4.5及以上
VS2017关于生成exe文件图形不输出的解决以及两种简单的打包方法
当辛辛苦苦写好一段带有图形界面的代码而exe<em>无法</em>进行图形输出,显然是一件十分苦恼的事情,下面就提供一种此类问题的解决方案,并且简单介绍一种最简单的<em>打包</em>方法以及vs的一种<em>打包</em>方法 问题描述 当代码在vs上运行时可以得到正常的图形输出 然而而通过exe文件打开却是一片漆黑 问题分析 既然vs上可以正常运行,说明代码是没有问题的,想要解决问题显然下一步需要从exe文件入手 我们对未进...
.NET Framework4.0微软官方
.NET Framework4.0微软官方 自己保存
opencv 3.4.1 32位 64位打包 vs2017编译 下载即用
使用<em>vs2017</em> / vc15编译好的opencv3.4.1,包含32位和64位<em>版本</em>,下载即用。
.NET各版本处理JSON用的Newtonsoft.dll
Newtonsoft.DLL For ALL DotNet Version……该资源包含.NET2.0、.NET3.5、.NET4.0、.NET4.5等<em>版本</em>以及移动设备Portable上均可调用Newtonsoft.DLL。
VS2017打包C#桌面应用
在要<em>打包</em>项目的解决方案 右键→添加→ 新建项目   后出现如下<em>选择</em>  如果没有Visual Studio Installer 说明没有安装<em>打包</em>插件 安装<em>打包</em>插件:Microsoft Visual Studio 2017 Installer Projects 工具 扩展和更新 联机,搜索Microsoft Visual Studio 2017 Instal
vs2017企业版,支持.netCore2.0
<em>vs2017</em>企业版,支持.<em>net</em>Core2.0,运行exe文件,<em>选择</em>需要的组件安装即可
Microsoft .NET Framework 各个版本之间的关系?如何安装2.0,3.0,4.0?向下兼容?
2014-06-15 10:21 12827人阅读 评论(2) 收藏 举报 版权声明:本文为博主原创文章,未经博主允许不得转载。 .Net<em>版本</em>之间是有一定联系的,目前(2010-04月)为止微软推出了3个<em>版本</em>的CLR,分别是 1.1, 2.0 , 4.0, 并且你要注意的是 .Net 4是基于CLR4的,而.Net 2.0 3.0 3.5都是基于 CLR2.0, 3
VS2017 怎样将桌面应用程序打包成.msi或.exe嘞?
两点:1、将桌面应用<em>程序</em><em>打包</em>成.msi或.exe 分享博客:http://xm2013.com/#/d/12 2、Extras  最近刚换装 VS 2017。哝,长这样:   加入插件之后,就长这样了,这颜值 。。。   Recommended Plug-ins :1>CludiaIDE; 2>Viasfora或Indent Guides;  Downloads:http://ms
.net FrameWork4.0安装包
.<em>net</em> FrameWork4.0安装包.<em>net</em> FrameWork4.0安装包
.NET Framework 4.0 离线安装包
.NET Framework 4.0 离线安装包
Framework4.0+中文汉化包
.Net Framework4.0+中文汉化包 支持64/32位的Win7/win10等操作系统
.NET Reflector 版本问题和破解方法
    .NET Reflector 主要是两个<em>版本</em>:Standard(标准版)和VSPRO(VSPRO版)。他们的区别是: Standard版只能在.NET Reflector软件中查看反编译出来的代码,而VSPRO可以在VS中进行在线调试时,查看反编译里面的代码。     通过下面的截图可以看到,VSPRO<em>版本</em>是兼具了STANDARD的功能,如果希望在Debug的时候使用,那么在破解的时候...
VS2017 Winform调用dll程序打包
<em>打包</em>solution的时候需要调用dll文件,当<em>打包</em>成exe后提示<em>无法</em>找到dll文件导致exe运行失败--》 一种简单的解决方法:在配置好setup project文件夹内容后,在解决方案资源管理器中右键setup project->添加文件-><em>选择</em>dll文件->生成 新生成的软件安装以后会在安装目录下包含dll文件,这时就可以顺利调用dll文件运行exe啦 (碰到一个问题:在setup P
VS2017项目打包为exe和setup
首先你要点击新建,然后点击项目,看看自己有没有下图中的东西。   如果没有,请在工具--拓展和更新--联机中搜索  visual studio installer 并安装,如下图。   安装好以后点击,新建下图中箭头指向的东西。 新建后,你会看到下图,然后按照红色框中路径<em>选择</em>。 然后弹出下图,在按照红色框中设置。 然后看到下图,右击主输出,点击红色框,这事创建快捷方式...
windows server 2008中安裝部署.net framework 4.0及iis7.0
windows server2008中安裝.<em>net</em> <em>framework4.0</em>,及安裝部署iis7.0
vs2017 C#程序打包安装部署之创建Windows安装项目
目前文档主要内容有: 一:创建创建Windows安装项目 二:添加内容文件 三:添加项目输出 四:添加注册表信息 五:创建快捷方式 六:生成Windows安装<em>程序</em> 获取<em>打包</em>工具,使用微软自带工具,获取步骤如下,若已安装请忽略此步。 点击:工具—&amp;gt;拓展和更新(U),然后在弹出的页面联机搜索installer,点击安装Microsoft Visual Studio In...
由于未安装.net framework 4.0的miscrosoft office支持,无法加载以下解决方案 ***.vsto
安装vsto应用时,提示这个错误,已经安装了.<em>net</em> <em>framework4.0</em>  这是少装了什么东西,还是有什么错误?   经过分析,如果系统中存在以下<em>程序</em>,可以直接使用,不用报错。     但如果新安装的系统中,没有以上<em>程序</em>时,需要在安装包时加入以下<em>程序</em>   在安装时,会提示如下图所示:     ...
microsoft dotnetframework4.0中文补丁包
Microsoft .NET Framework 4 语言包中包含针对非英语语言的翻译文本(如错误消息)。如果不安装语言包,这些消息将默认以英文显示。在一台计算机上可以安装多个语言包,每个语言包显示一种不同的语言。   支持的操作系统: Windows 7; Windows Server 2003 Service Pack 2; Windows Server 2008; Windows Server 2008 R2; Windows Vista Service Pack 1; Windows XP Service Pack 3   Windows XP SP3   Windows Server 2003 SP2   Windows Vista SP1 或更高<em>版本</em>   Windows Server 2008(在服务器核心角色上不受支持)   Windows 7   Windows Server 2008 R2(在服务器核心角色上不受支持)   支持的体系结构:   x86   x64   ia64(有些功能在诸如 WPF 之类的 ia64 上不受支持)   硬件要求:   建议的最低要求:Pentium 1 GHz 或更快,512 MB RAM 或更大   最小磁盘空间:   x86 – 850 MB   x64 – 2 GB   发布日期:   2010/6/1   语言:   中文(简体)
分别适用于.NET Framework 2.0和4.0的Excel.dll
压缩文件里包含了分别适用于.NET Framework 2.0和4.0的两个Excel.dll。 大家在编写操作excel表格的代码时,添加引用是个麻烦事,直接引用Excel.dll会更加方便。
让VS编译的Release版本程序在其他机器上顺利运行
让VS编译的Release<em>版本</em><em>程序</em>在其他机器上顺利运行
c#开发winform用VS打包安装包判断是否安装net-framework对应版本
操作环境:win10 + visual Studio 2017 一、创建工程并选定<em>net</em><em>版本</em> 正常创建工程,更具下表<em>选择</em>合适的<em>net</em> framework<em>版本</em>: 为了支持xp,但又不至于<em>net</em><em>版本</em>过低,导致使用不了新框架的功能, 因此最后选定使用<em>net</em> 4.0<em>版本</em>。支持:xp-sp3,win7,win8,win10 二、软件<em>打包</em>并添加<em>net</em>检测 软件<em>打包</em>采用Visual Studi...
AdvancedInstaller基础使用详解
最新AdvancedInstaller<em>打包</em>安装软件使用详解。
vs .net项目自动更新版本
使用SVN的一个<em>程序</em>, 一般都会装,无需再次下载和安装了. 只需要在项目属性-&amp;gt; 生成事件-&amp;gt; 后期生成事件命令 中加入 subwcrev.exe $(ProjectDir)Properties\ $(ProjectDir)Properties\AssemblyInfo.cs.tpl $(ProjectDir)Properties\AssemblyInfo.cs 复制Assembly...
framework4.0
framework .<em>net</em>4.0框架安装版,支持32位和64位操作系统!
SharpZipLib for .NET4.0
sharpziplib的.<em>net</em>4.0 的dll,因为看到开源页面上没有这个<em>版本</em>的.然后自己下了源码编译了一份,备忘..内含debug跟release的dll
vs2017 15.5.x dll调试不成功问题
配置:Unity5.5.5f1 + <em>vs2017</em> 问题:更新到<em>vs2017</em> 15.5.0之后,项目中用到的dll调试断点进不去了。之后更新到15.5.1,依然进不去。 现象:Unity工程下生成的dll文件只有dll.pdb没有dll.mdb文件了。 原因:vs生成调试的dll后,同时会生成dll.pdb文件。Unity3d会将.pdb转换为.mdb格式(mono的调试文件)。 Unity自带的转
Hololens 打包问题解决汇总
Hololens<em>打包</em>失败解决方案: 1.检查基础设置-VS中相应插件安装 2.更新Win10SDK 从这里安装:https://developer.microsoft.com/en-us/windows/downloads/windows-10-sdk 3.检查相应的Unity 与 MRTK(HoloToolKit)的对应<em>版本</em>匹配一致 4.Unity的工程中,一定要少用有dll的...
使用Wix打包C#桌面应用程序(1)简单打包例子
这里写自定义目录标题欢迎使用Markdown编辑器新的改变功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码片生成一个适合你的列表创建一个表格设定内容居中、居左、居右SmartyPants创建一个自定义列表如何创建一个注脚注释也是必不可少的KaTeX数学公式新的甘特图功能,丰富你的文章UML 图表FLowchart流程图导出与导入导出导入 欢迎使用Ma...
用 .Net Framework 4.0 制作的安装程序来安装 .Net Framework 4.0 编写的程序
本文为使用C++和C#编写的一个安装<em>程序</em>的关键代码,目的是使用框架制作的安装<em>程序</em>来安装框架开发的<em>程序</em>,使用C++编写一个引导<em>程序</em>来独立检测和安装.Net Framework 4.0,框架安装成功后,调用应用安装<em>程序</em>,将<em>程序</em>功能安装到目标客户机上,应用安装<em>程序</em>使用框架语言C#编写,实现了一般安装<em>程序</em>的功能,如复制文件、创建桌面快捷方式、创建<em>程序</em>组、注册字体、注册系统服务、写入反安装信息,并提供反安装功能。有兴趣的读者可以在此基础上进一步深化提高。
Net framework4.0 安装失败的解决方法
windows很多的软件需要有Net framework框架支持,在windows 7上面默认是没有的,win8,10就不用考虑了。 image.png 日志:Final Result: Installation failed with error code: (0x80070643), &quot;安装时发生严重错误 &quot; (Elapsed time:...
VS2017下用release进行程序调试及无法打断点问题
有时候<em>程序</em>过大时,用Debug在VS下调试速度过慢,变换成release<em>版本</em>。 需要确保每一个工程都有如下配置,例如你想调试Recog工程下的某个CPP文件。那么只对cup工程release的配置是不够的,也需要对Recog工程有这个配置。 具体操作如下: C++&gt;General-&gt;Debug Information Format-&gt;Program Dat...
.Net Core 2.0正式版上线
一、2017/8/15 .Net Core2.0正式版提前上线 正式版的发布在2017/9/19的.<em>net</em>虚拟社区大会中公布。 官方下载地址:https://www.microsoft.com/<em>net</em>/core#windowscmd 二、基于VS2017的安装使用过程 1.下载安装并安装 .Net Core 2.0 SDK 2.更新VS2017 到V15.3版 官方文档
关于XP\win7系统中安装.net4.0 程序运行版本出错的原因之一
解决“This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms” 还是装那台服务器,装好了IIS和ASP.NET,但在运行aspx页面时出现了异常: 异常信息: This implementation is not part of the Windows P
VS打包,如何设置在安装新版本时,无需先卸载旧版本,自动覆盖安装?
项目 → 属性(右键) 修改<em>程序</em>集<em>版本</em>号(一般是增加) Setup Project → 属性(快捷键F4的属性) RemovePreviousVersion = true 修改 Version ...
VS2017打包一个控制台程序为安装软件(已解决)
Youtube网址https://www.youtube.com/watch?v=z0v6hmumCFU 如下写了一个<em>程序</em> 点击解决方案-&gt;添加-&gt;新建项目(注意要在需要<em>打包</em>的<em>程序</em>的解决方案里面新建该项目) <em>选择</em>其他项目类型-&gt; Visual Studio installer 里面 Setup Project 如果没有这一项请点此网址https://w...
若要运行应用程序,您必须首先安装 .NET Framework 4.0 解决办法
在安装很多<em>程序</em>,或者游戏的时候会弹出这个提示窗口,这是因为电脑上缺少 .NET Framework 4.0 ,下面贴上 .NET Framework 4.0的下载地址 .<em>net</em> framework 4.0安装 安装之后即可解。 若是在安装失败请看另一篇文章 .<em>net</em> framework 4.0安装失败解决办法
强连通分量及缩点tarjan算法解析
强连通分量: 简言之 就是找环(每条边只走一次,两两可达) 孤立的一个点也是一个连通分量   使用tarjan算法 在嵌套的多个环中优先得到最大环( 最小环就是每个孤立点)   定义: int Time, DFN[N], Low[N]; DFN[i]表示 遍历到 i 点时是第几次dfs Low[u] 表示 以u点为父节点的 子树 能连接到 [栈中] 最上端的点   int
ami bios设置图解.doc下载
我找了两种Bios的计算机分别是:华硕的AMI BIOS和升技的AWARD BIOS,这也是目前两种主流的Bios,及算是不同品牌的主板,他们的Bios也是与这两种Bios的功能和设置大同小异。 相关下载链接:[url=//download.csdn.net/download/zy8611736/1979590?utm_source=bbsseo]//download.csdn.net/download/zy8611736/1979590?utm_source=bbsseo[/url]
Excel会计应学35招秘技下载
Excel会计应学35招秘技也许你已经在Excel中完成过上百张财务报表,也许你已利用Excel函数实现过上千次的复杂运算,也许你认为Excel 也不过如此,甚至了无新意。但我们平日里无数次重复的得心应手的使用方法只不过是Excel全部技巧的百分之一。本专题从Excel中的一些鲜为人知的技巧入手,领略一下关于Excel的别样风情 相关下载链接:[url=//download.csdn.net/download/sjqfhcx/2130802?utm_source=bbsseo]//download.csdn.net/download/sjqfhcx/2130802?utm_source=bbsseo[/url]
深入浅出 SQL(中文版).part5.rar下载
本书带你进入SQL语言的心脏地带,从使用INSERT和SELECT这些基本的查询语法到使用子查询(subquery)、连接(join)和事务(transaction)这样的核心技术来操作数据库。 相关下载链接:[url=//download.csdn.net/download/OkMyHoney/2299768?utm_source=bbsseo]//download.csdn.net/download/OkMyHoney/2299768?utm_source=bbsseo[/url]
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 关于大数据培训 关于云计算
我们是很有底线的