Could not resolve com.android.tools.build:gradle:2.3.0

移动开发 > Android [问题点数:20分]
等级
本版专家分:0
结帖率 0%
等级
本版专家分:9701
勋章
Blank
签到新秀 累计签到获取,不积跬步,无以至千里,继续坚持!
Blank
名人 2019年 荣获名人称号
2013年 荣获名人称号
Blank
状元 2012年 总版技术专家分年内排行榜第一
Blank
进士 2013年 总版技术专家分年内排行榜第七
2011年 总版技术专家分年内排行榜第五
2009年 总版技术专家分年内排行榜第九
qq_41091661

等级:

Could not resolve com.android.tools.build:gradle:2.3.+

在由3.2.0升级Android studio 到3.2.1之后,之前正常编译的项目,报错。发现很多之前的第三方库没有指定明确版本的都找不到依赖了。解决办法是全部指定 明确的版本号。 - compile '...

Could not resolve com.android.tools.build:gradle:2.3.2.

一个Android 项目,刚倒到本地一直不能build成功就执行了一下gradlew compileDebugJavaWithJavac --stacktrace 命令,报Could not resolve com.android.tools.build:gradle:2.3.2. 这个错误。 找到build.gradle文件...

> Could not find com.android.tools.build:gradle:3.2.0. Searched in the follo

ERROR: Could not find com.android.tools.build:gradle:3.2.0. Searched in the following locations: - file:/C:/Users/user/.m2/repository/com/android/tools/build/gradle/3.2.0/gradle-3.2.0.p...

更新Android Studio版本出现Could not find com.android.tools.build:gradle:2.2.3

如题,因为前阵子google更新了studio版本,像... 我更新studio重启配置完向导,项目在加载的时候(那一段时间应该是在加载gradle之类的吧,我不太懂=。=)应该是有提示我要不要更新gradle,我也没仔细看就点了更新,所以

com.android.tools.build:gradle:3.2.0

.gradle\caches\modules-2\files-2.1\com.android.tools.build\gradle缓存文件,包含pom,jar,source

ionic cordova 打包 失败 无法下载 com.android.tools.build:gradle:2.3.0 PKIX path building failed: ...

> Could not resolve com.android.tools.build:gradle:2.3.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/gradle/2.3.0/gradle-2.3.0.pom'. > Could not GET '...

Could not find com.android.tools.build:aapt2:3.3.2-5309881.解决方法

Could not find com.android.tools.build:aapt2:3.3.2-5309881.解决方法(有一些差别) 今天想着把4412开发板提供的串口例程和自己修改的高德导航的app结合到一起,由于没有学过Android jni的相关知识,就对着开发板...

Could not resolve com.android.support.constraint:constraint-layout:1.1.3问题的解决

ERROR: Unable to resolve dependency for ':app@debug/compileClasspath': Could not resolve com.android.support.constraint:constraint-layout:1.1.3. Show Details Affected Modules: app ERROR: Una...

No cached version of com.android.tools.build:gradle:2.0.0 available for offline mode.

异常场景从AS2.0升级到2.1,重新编译工程后,抛出了如下异常Error:A problem occurred configuring root project '...> Could not resolve all dependencies for configuration ':classpath'. > Could not resolve co

解决Could not find com.android.tools.build:aapt2:3.2.0问题

前言:在导入一个demo出现该问题,问题点是Android studio3.2版本以后,AAPT2 (Android Asset Packaging Tool 2)的源代码就是谷歌的Maven存储库。 要使用AAPT2,请确保构建中有一个谷歌()依赖项 gradle文件如下: ...

SpringBoot项目无法Gradle,报 Could not resolve:XXXX

无法Gradle,错误日志是: CONFIGURE SUCCESSFUL in 0s Could not resolve: org.springframework:spring-jdbc:5.0.6.RELEASE Could not resolve: org.apache.httpcomponents:...Could not resolve: com.alibab...

关于Android Studio集成其他插件,遇到 Could not find com.google.firebase:firebase-core 等问题

一个项目,导成gradle 安卓项目后,用Android Studio 打开项目,然后集成一个登录计费SDK。 结果编译时,出现一些依赖库找不到 比如: Could not find com.google.firebase:firebase-core Could not find ...

技巧篇 之 这可能是解决 Could not resolve X 最有效的办法之一咯。

夜深人静,远离了城市的喧嚣,开启了个人的狂欢。 前言 本文扯皮话较多,主要记录下心路历程,勿喷。...行云流水般导入,编译,准备 build 成功后开始一通霍霍。事实告诉我,小伙子还是忒年轻。...

安卓编译的时候依赖包解析不了,老是下载...Faled to resolve: com.squareup.retrofit2:converter-gson:2.3.0

安卓编译的时候依赖包解析不了,老是下载不下来。E\ldeaProjectsNdrcApp\app\build.gradle ...Faled to resolve: com.squareup.retrofit2:converter-gson:2.3.0 Error: QpenFile ShowinProiectStruct

Android photoview使用遇到Failed to resolve: com.github.chrisbanes:PhotoView:1.2.6

推荐一个安卓不错的案例UI:... 在app的build.gradle添加photoview依赖,photoview图片缩放库 implementation 'com.github.chrisbanes:PhotoView:1.2.6' 但是会出现Error:(70, 13) Faile...

Could not find org.jetbrains.kotlin:kotlin-stdlib:1.1.3-2.

具体报错内容大概有这句话:Could not download kotlin-stdlib.jar 试过的方法但是没效果的记录下: 方法1 1. Tools--->Kotlin--->Configure Kotlin Plugin Updates  方法2: 下了个蓝灯,然后...

内网下解决dependencies的classpath依赖问题

参考:Could not resolve com.android.tools.build:gradle:0.5.+ 原文: 使用Android studio Gradle 打包Android项目遇到  couldnot resolve com.android.tools.build:gradle:1.3.0 错误,与...

React Native Build Tools版本错误解决方案

React Native Build Tools版本错误解决方案在React Native开发时,添加第三方工程时,遇到以下错误时,该如何解决呢? The SDK Build Tools revision (23.0.1) is too low for project ‘:react-native-picker’. ...

Android Realm Gradle3.0以上出错解决方法

想在Android Studio3.2中使用Realm,结果发现gradle3.0以上不支持APT了。需要转换下才可以使用,特意将解决的方法记录下来。 问题描述 按照正常,我们会这样子配置: buildscript { repositories { …… } ...

Android - Gradle 项目构建

Gradle https://en.wikipedia.org/wiki/Gradle Gradle是一个开源构建自动化系统,它基于Apache Ant和Apache Maven的概念,并引入了一种基于Groovy的领域特定语言(DSL),而不是Apache Maven用于声明项目配置的XML...

Getting Build Error while ionic cordova build android

com.android.tools.build:gradle:4.0.0-alpha01 > com.android.tools.build:builder:4.0.0-alpha01 [cordova] unspecified:unspecified:unspecified > com.android.tools.build:gradle:4.0.0-alpha01 > ...

升级到AndroidStudio3.0 之后的遇到问题的处理(新建、方法数限制等)

转载:升级到AndroidStudio3.0 之后的遇到问题的处理(新建、方法数限制等) - 个人文章 - SegmentFault 思否 https://segmentfault.com/a/1190000012063649遇到的新问题:1,新建项目报错:Unable to resolve ...

DBFlow总是导入失败? 不知道哪里错了

classpath 'com.neenbedankt.gradle.plugins:android-apt:1.8' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { ...

[Android开发] Android Studio问题以及解决记录

1、真机运行报错Multi dex requires Build Tools 21.0.0 / Current: 19.1解决: 在项目 build.gradle 里面把classpath ‘com.android.tools.build:gradle:1.5.0’ 改为1.5.0 或者1.3.02、导入第三方包运行报错:前言...

Could not resolve all dependencies for configuration ':app:retrolambdaConfi

Error:Execution failed for task ‘:app:compileRetrolambdaDebug... Could not resolve all dependencies for configuration ‘:app:retrolambdaConfig’. Could not resolve net.orfjackal.retrolambda:retrolamb

Android studio 安装已经下载好的gradle.zip文件【ubuntu 14.04 LTS环境】

一 下载 gradle-3.3-all.zip 包 http://download.csdn.net/detail/t6546545/9732412 http://www.fxxz.com/soft/234043.html 二 将 gradle-3.3-all.zip 放置在 gradle/wrapper目录下,如图 三 打开 gradle-...

Could not download spring-boot-autoconfigure.jar (org.springframework.boot: spring-boot-autoconfigur

我在家创建了一个grails工程运行grails run-app,出现如下错误: D:\Projects\Grails\project\HelloWorld>grails run-app Java HotSpot(TM) Client VM warning: TieredCompilation is disabled in this releas ...

【Unity / Gradle】 Unity 5.6.x Gradle build APK 报错 Connection refused 解决方法

问题描述 公司有一个海外项目需要接入 Admob 并聚合多家广告联盟,同时需要接入 Facekbook 相关服务。由于 Google Play Service 的基础库比较多,加入...为了解决 64K问题,必须改用 Gradle 方式打包。经过测试,选...

看AspectJ在Android中的强势插入

什么是AOPAOP是Aspect Oriented Programming的缩写,即『面向切面编程』。它和我们平时接触到的OOP都是编程的不同思想,OOP,即『面向对象编程』,它提倡的是将功能模块化,对象化,而AOP的思想,则不太一样,它提倡...

Gradle插件相关的问题记录一下

Gradle插件遇到的问题 切换到As工程后或多或少的遇到了一些问题,以前的时候总是解决后不记录,写这个是为了做个...参见链接: https://developer.android.com/studio/releases/gradle-plugin.html#updating-gradle...

相关热词 c# 方法 问号 c#生成失败没有错误 c# 淘宝数据 c# 全局钩子 c# 用户自定义控件关闭 c# 冒号 c# console颜色 c#以13 发送邮箱c# c#拖动条