openssl版本选择的问题

大板牙花生 2020-05-04 10:51:01
有如下问题
1.openssl版本1.1.1和3.0.0有什么区别,是支持的协议不同吗?SSL2.0,SSL3.0?
2.如果两个开源库,一个依赖1.1.1的版本,一个依赖3.0.0的版本,怎么解决编译冲突和头文件问题?
3.BOOST的AISO库依赖openssl,这个版本是如何查看的,看了下官网上并没有,一定需要依赖OPENSSL库吗?
...全文
52 点赞 收藏 1
写回复
1 条回复
smwhotjay 2020年05月04日
1.版本高的支持新加密协议。抛弃了旧协议。估计那旧的api就用不了了。
2.好问题,我还真没遇到过。我一般只设置一个库,
回复 点赞
发动态
发帖子
工具平台和程序库
创建于2007-09-28

8235

社区成员

2.7w+

社区内容

C/C++ 工具平台和程序库
社区公告
暂无公告