【求助】树莓派4B下python3.73安装好pywin32和pypiwin32后 import win32api提示win32api module找不到

qy501 2020-12-07 04:18:36
我的树莓派4B版本:Raspbian GNU/Linux 10 (buster);我的python3.73,安装了pywin32(试过224,226,227,300版本)和pypiwin32(223版本),从网上下载 pywin32-227-cp37-cp37m-win32.whl
存在/home/pi/Downloads下,因为python支持格式CP37-none-any,修改成pywin32-227-cp37-none-any.whl
用pip3 install pywin32-227-cp37-none-any.whl安装
安装完毕后再用pip3 install pypiwin32 安装pypiwin32 223版本;完毕后 import win32com,win32api等均提示win32api module找不到;
我尝试用python3 pywin32_postinstall.py -install修复,提示“ModuleNotFoundError: No module named 'winreg',”,试过网上描述的各种方法,都不奏效;
我的python环境配置如下:
/usr/lib/python37.zip
/usr/lib/python3.7
/usr/lib/python3.7/lib-dynload
/home/pi/.local/lib/python3.7/site-packages
/home/pi/.local/lib/python3.7/site-packages/win32
/usr/local/lib/python3.7/dist-packages
/usr/lib/python3/dist-packages
...全文
76 点赞 收藏 2
写回复
2 条回复
qy501 2020年12月14日
我没有安装python呀,原来本意是想在树莓派上用pywin32实现一些东东,感觉下来linux版本无法使用。里面的库没有.so的,都是window系统使用的。
回复 点赞
rrrr336 2020年12月08日
1. Raspberry Pi 缺省好像自带有 Python, 不用安装,你在菜单下找一下。 2. 如果没有,你安装也要选择Linux版本去安装。 所有带 win32字样是都是 Windows操作系统下用的,而 Raspiberry Pi 是Linux操作系统。
回复 点赞
发动态
发帖子
脚本语言(Perl/Python)
创建于2007-08-27

1.5w+

社区成员

3.3w+

社区内容

其他开发语言 脚本语言(Perl ,Python)
社区公告
暂无公告