idea提示不支持jdk1.7的问题

指尖过客 2021-04-16 02:30:58
问题描述:

项目是用jdk1.6开发的,运行时用插件是jetty,在eclipse上运行无问题,同样的代码跑在idea上报错:

报错提示很简单,不支持1.7的class文件。但是项目运行设置的是jdk1.6.
要求项目只能使用1.6编译。

idea相关配置如下:




已尝试解决办法:项目是maven项目,maven-clean,idea本身的invalidate cache,仍就报错。

最神奇的是:别人idea版本一样,代码一样,运行并不报错。

已困扰好多天,请遇到过相同问题或有思路的大佬,帮忙看看,谢谢!



...全文
43 点赞 收藏 2
写回复
2 条回复
指尖过客 04月16日
没有配置,目前怀疑是idea哪的配置的问题,但是还没有找到。
回复 点赞
lin351550660 04月16日
检查一下pom.xml 是不是配了java版本
回复 点赞
发动态
发帖子
Java SE
创建于2007-09-28

3.4w+

社区成员

30.7w+

社区内容

Java 2 Standard Edition
社区公告
暂无公告