新版本spring cloud 项目,bootstrap.yml无法加载

sbgphl 2021-04-25 09:32:12
最新版本cloud,注册中心noace
<spring.boot-version>2.4.4</spring.boot-version>
<spring.cloud-version>2020.0.2</spring.cloud-version>
<spring-alibaba.cloud-version>2021.1</spring-alibaba.cloud-version>

maven工程中把bootstrap.yml作为单独项目管理,其他项目依赖这个项目;
bootstrap.yml 没有加载,有人说最新的版本默认把这个关闭了,不知道在哪里打开。




求助,感谢!
...全文
74 点赞 收藏 1
写回复
1 条回复
sbgphl 04月25日
问题解决 配置文件。必须是 bootstrap.properties ,yml格式失败。
回复 点赞
发动态
发帖子
Java EE
创建于2007-09-28

3.7w+

社区成员

22.5w+

社区内容

J2EE只是Java企业应用。我们需要一个跨J2SE/WEB/EJB的微容器,保护我们的业务核心组件(中间件),以延续它的生命力,而不是依赖J2SE/J2EE版本。
社区公告
暂无公告