CSDN论坛 > Java > Web 开发

Tomcat不能正常使用的问题?? [问题点数:100分,结帖人blackhost]

Bbs5
本版专家分:3286
结帖率 94.74%
CSDN今日推荐
Bbs4
本版专家分:1071
Bbs6
本版专家分:7595
Bbs5
本版专家分:3286
Bbs5
本版专家分:3286
Bbs5
本版专家分:3286
Bbs5
本版专家分:2151
Bbs5
本版专家分:3286
Bbs5
本版专家分:2345
Bbs5
本版专家分:2151
Bbs5
本版专家分:3286
匿名用户不能发表回复!
其他相关推荐
Eclipse正常启动tomcat但无法访问主页
症状: tomcat在eclipse里面能正常启动,而在浏览器中访问http://localhost:8080/不能访问,且报404错误。同时其他项目页面也不能访问。 关闭eclipse里面的tomcat,在tomcat安装目录下双击startup.bat手动启动tomcat服务器。访问htt://localhost:8080/能正常访问tomcat管理页面。 症状原因:
tomcat正常启动,但是localhost:8080或127.0.0.1:8080无法打开tomcat欢迎
最近刚搭建了一个web测试环境,但是遇到了tomcat启动后无法访问的情况,最终解决问题,在这里记录备忘; 配置如下: 1、操作系统:windows server 2008 R2 2、web容器:Tomcat.8.0.18; 3、jdk:jdk1.7.0_25 64位; 4、环境变量:JAVA_HOME:C:\deploy\jdk1.7.0_25; 环境搭建完成之后启动tomcat,能
tomcat,jboss使用中遇到的一些问题的解决
开发J2EE的项目已经有一段不短的时间了,可仍然有时候总会遇到一些 让人非常烦的问题,其中以编写程序时与服务器连接中的问题尤为让人闹心,自己对服务器的底层实现又不了解,所以碰到这样的问题时除了google也就没有办法了,于是我们一般称其为“灵异现象”说到服务器,平时使用的基本就是tomcat与jboss两种(前段时间也下了个application server9,跑了跑petstore 2.0
Tomcat正常启动,但是网页无法访问,而且不报404等任何异常
首先按标题所示:       1,正常启动       2,无法访问       3,无任何异常 根据3排除:路径不存在、路径错误、静态资源配置、代码RuntimeException等可见性异常。      于是查看Tomcat日志文件logs/catalina.out(Windows下可以查看catalina.2017-07-24.log), 如果日志仅仅停留在Server star
Tomcat非正常退出导致无法再次启动
Tomcat非正常退出导致无法再次启动使用eclipse启动调试jsp时,意外出现了错误,再次启动的时候一直提示无法启动tomcat,8080端口被占用,我想一定是tomcat退出时出现了异常。 用的时Ubuntu系统,首先netstat -naop | grep 8080列出占用8080端口程序的PID,然后#port 是端口号 ps -e | grep 'port'查看该进程最后#PID
Tomcat添加Apr后,http正常访问,https不能访问
Tomcat添加Apr后,http正常访问,https不能访问
当Tomcat服务器无法正常启动时
当Tomcat服务器无法正常启动时,首先检查是否配置了JAVA_HOME环境变量,然后再检查Tomcat服务器启动时的端口是否被别的应用程序占用了。
项目在eclipse运行正常,但单独部署到tomcat上不正常
林正英捉鬼
Maven项目Tomcat无法正常启动
小编在学习maven项目开发的时候,启动Tomcat时,乍一看,Tomcat咋没起来,还给我报了一堆错误,仔细一看8080端口被占用了。严重: Error initializing endpoint java.net.BindException: Address already in use: JVM_Bind <null>:8080 at org.apache.tomcat.uti...
jhipster生成的工程war包部署到tomcat中,tomcat正常启动,但一直不加载项目的问题原因。
jhipster生成工程打成war包,可以直接采用java -jar war包命令执行。 如果要将其放到tomcat下webapps中运行,如果tomcat启动成功,也将war包解压开,但就是不加载工程。此问题困扰很长时间,最终发现是jdk版本问题导致。 出现此问题,需要检查下jdk的版本,必须是1.8以上版本。因为jhipster要求jdk是1.8以上。
关闭