CSDN论坛 > Java > Java SE

使用ant编译java程序出错,请大虾指点 [问题点数:0分]

Bbs1
本版专家分:0
结帖率 100%
CSDN今日推荐
Bbs7
本版专家分:11015
Bbs4
本版专家分:1028
Bbs8
本版专家分:37303
Blank
蓝花 2007年1月 Java大版内专家分月排行榜第三
匿名用户不能发表回复!
其他相关推荐
java+mysql聊天室(CS模式)
小弟用java写的 连接mysql数据库 服务器客户端模式 小弟做的第一个项目 请各位大虾多多指点
处理Ant编译时中文乱码问题
在使用ant编译项目的时候经常会遇到“警告:编码 GBK 的不可映射字符”这样的信息,这个主要是因为我们在写代码的时候加入了一些中文注释,而导致编译时候出现的问题。要处理这个问题,仅仅只需要在 build.xml文件中的调用javac的地方加入encoding的参数。<br /> 如下所示:<br /> <javac<br />                 encoding="utf-8"<br />                 destdir
Ant—使用Ant构建简单Java项目(一)
Apache Ant主要用于Java项目的构建。为什么要使用Apache Ant来构建项目呢:        1)项目构建不是简单的编译,各种资源需要合理构建,例如有的类需要压缩成jar文件,有的文件需要放在指定位置,有时候需要使用配置文件。这些工作是繁杂琐碎的,手工处理难免出错。        2)诸如Myeclipse之类的IDE工具可以方便地部署web项目,但是脱离了这些集成工具,例如在需要
java ant进行编译打包,build.xml文件编写
java build.xml 打包
更改Ant的JDK编译版本
今天将写好的附件服务器的API发给同事 她引入我的jar后, 编译就会报错: 类文件具有错误的版本 50.0,应为 49.0 50.0 对应的是JDK的1.6版本, 而49.0 对应的是JDK的1.5版本 也就是说我的jar的版本高于她所用的版本 由于我们实际部署在1.5之上, 所以我就来修改我的编译环境 首先我先修改了Eclipse的编译环境到1.5, 但
用Ant实现Java项目的自动构建和部署/Eclipse下使用Ant
转载处:http://www.blogjava.net/amigoxie/archive/2007/11/09/159413.html
Ant中设置特定的jdk版本
最近遇到这样一个问题,我在电脑A上开发的java程序,用Ant打包成jar文件后,放到电脑B上无法运行,提示:UnsupportedClassVersionError错误。 原来电脑A的jdk是1.8版本的,电脑B是jdk1.6的,所以无法兼容。其实解决这个问题也不难,添加相应的配置参数就可以了。 例如,原先的build.xml文件是这样写的: 只需要添加两个参数,改成这样:
Ant classpath 指定类路径 编译程序引用第三方jar包
Ant 在运行一些任务的时候需要用指定类路径.尤其是编译程序引用第三方jar包时, 需要在里配置 可以内嵌 pathelement,path,fileset,dirset,filelist. 1.pathelement:                     对于pathelement的两个属性——path和location: 1-1.location的值可以是一个文件
遇过的坑-用ant编译java项目,如果static变量有修改,使用了该static变量的java文件, 不会重编译
java项目,修改了static变量后,你必须知道的潜规则
Ant自动编译Java project时无法找到rt.jar的处理方法
最近在使用Ant自动化编译打包一个Java项目,执行时总是报有class找不到:     [javac] Compiling 46 source files to /A/B/C/D/build/staging/bin     [javac] .../ChangePassWordTool.java:5: package com.sun.org.apache.xml.internal.securi
关闭