CSDN论坛 > Java > Web 开发

客户端可以不下载jdk1.4吗? [问题点数:0分]

Bbs1
本版专家分:0
结帖率 100%
CSDN今日推荐
Bbs6
本版专家分:6797
Bbs1
本版专家分:0
Bbs3
本版专家分:636
Bbs4
本版专家分:1998
匿名用户不能发表回复!
其他相关推荐
JDK 1.4.1本地下载
最新版本的JDK。
jdk1.4.2.17
jdk1.4.2.17
tomcat5.5与jdk1.4不兼容
今天帮人看个问题才发现 tomcat5.5与jdk1.4不兼容,主是出现的问题是服务器启动不起来,所以http://localhost:8080无法访问。不过apache提供了一个补丁包,下载地址:http://tomcat.apache.org/download-55.cgi找到JDK 1.4 Compatability Package适合自己操作系统的压缩包,下载下来,把解压后的文
linux安装jdk1.4.2
下载jdk文件包:j2sdk-1_4_2_10-linux-i586.bin         1,解压缩文件包      #chmod a+x ./j2sdk-1_4_2_10-linux-i586.bin      #./j2sdk-1_4_2_10-linux-i586.bin     2,建立安装路径      #cd /usr      #mkdir java     3
修改版json-lib-2.4-jdk14与json-lib-2.4-jdk13 支持JDK1.4与1.3与1.5
官网发布的json-lib-2.4-jdk13.jar,在JDK1.4中无法使用,经过不懈努力,知道问题出在哪里了,分享下: debug那个json-lib源码,最后错误定位在这个方法 protected static void removeInstance( Object instance ) { Set set = getCycleSet(); set.remove( instance ); if(set.size() == 0) { cycleSet.remove(); }} 注意这行cycleSet.remove(); remove是java.lang.ThreadLocal类的方法,但是jdk1.4中,却没有这个方法的实现,jdk1.5中有这个方法,因此是没问题的; 本jar包经过改造,适用于JDK1.4,需要第三方JAR包的支持(commons-beanutils-1.8.2.jar,commons-collections-3.2.jar,commons-lang-2.5.jar,commons-logging-1.1.jar,ezmorph-1.0.6.jar)
兼容 jdk 1.4 的json jar包
兼容 jdk 1.4 的json jar包,经过测试支持JDK1.4,记得导入依赖JAR包
JDK 1.4.2 for 64 bit
JDK For 64 bit,用于64位操作系统,很好用
安装SAP需要的JDK版本 1.4.2.32 Windows 64位版
安装SAP环境必须的JDK版本,现在JAVA的官方网站上已经找不到了,真搞不懂为什么对SAP这么重要的东西都下架了。
JDK1.4创建多线程的几种方法
import java.util.concurrent.TimeUnit; class InnerThread1 { private int countDown = 5; private Inner inner; private class Inner extends Thread { Inner(String name) {
tomcat5 兼容jdk1.4插件
tomcat5.X 要是没有jdk5以上的版本是没办法运行的,现在把这个插件包放进去就好了 具体的操作看我的csdn博客有详细的说明
关闭