CSDN论坛 > Delphi > 数据库相关

delphi编程时,数据库为oracle,当在客户端为8.16版本上编译通过但到客户端是8.17却不行,为什么啊? [问题点数:0分]

Bbs1
本版专家分:0
结帖率 100%
CSDN今日推荐
Bbs7
本版专家分:13858
Bbs4
本版专家分:1765
Bbs1
本版专家分:0
匿名用户不能发表回复!
其他相关推荐
连接oracle数据库异常System.Data.OracleClient 需要 Oracle 客户端软件 8.1.7 或更高版本
1、连接oracle数据库异常System.Data.OracleClient 需要 Oracle 客户端软件 8.1.7 或更高版本 本人在用公司用C#写的服务连接数据库oracle 时,报出上面的错误:连接oracle数据库异常System.Data.OracleClient 需要 Oracle 客户端软件 8.1.7 或更高版本。在网上查了好多,试了都没有用,但是通过网上查询,说是
如何查看oracle客户端版本号是32位还是64位(转)
unix下的话,找到sqlplus, file /path/to/sqlplus,windows就更简单了,32位系统肯定是32位的,64位系统看任务管理器就好了,sqlplus后面没有*32就是64位了,如下图: 转自:http://hi.baidu.com/goodlisf/item/34ae5318647619446826bb72
Oracle数据库与客户端版本协调
Oracle数据库有很多版本,同样客户端也有很多版本,一般用于教学使用的最多的是11g 11g版本分为R1与R2,并且分为64位版与32位版 如果需要客户端正常连接数据库使用,需要版本匹配,并设置正常 但有些情况下需要使用版本不用的数据库与客户端,已达到匹配其他应用工具的使用 举例: 下载安装了64位的oracle数据库与64位的客户端并连接测试正常,此处拿sql plus举例
delphi程序利用odac控件代替oracle客户端
本程序使用odac控件代替oracle客户端 一、测试用表为odac_test,数据内容贴到数据库中就可以使用 二、程序组成部分 1.DbModuleUnit部分,用来提供数据库连接的公共服务。 2.CommonUnit部分,提供相关函数等。 3.MainUnit部分,测试界面。 使用以上几个模块可以架构常用delphi程序
解决System.Data.OracleClient 需要 Oracle 客户端软件 8.1.7 或更高版本
百分百解决“System.Data.OracleClient 需要 Oracle 客户端软件 8.1.7 或更高版本”这个问题 详细操作请看压缩包TXT文档说明……
解决 c#连接Oracle 提示system.data.oracleclient 需要 oracle 客户端软件 8.1.7 或更高版本
最近在做winform,需要远程连接Oracle,本来测试的都顺利。但是到客户那里了 抛出了 system.data.oracleclient 需要 oracle 客户端软件 8.1.7 或更高版本 这个错误! 这个意思就是需要安装Oracle客户端,但是给客户打包好的客户端还需要客户安装一个Oracle客户端有点不太现实啊!没办法,忍者过来了,中午客户去吃饭,偷偷的给客户的电脑安装了Orac
PL/SQL连接Oracle数据库--没有连接为选项
在Win 7 上装的64位的Oracle数据库,然后装上了32位的Oracle客户端,用PLSQL连接Oracle时出现如图情况,只有用户名,密码,数据库的填写或者选择框,没有“登录为”(角色)的选择框。       解决方案:       1)安装Oracle 11g 64位             2)安装32位的Oracle客户
oracle客户端可以连接但cmd连不上
oracle客户端可以连接但cmd连不上       之前为了做测试需要,在本地安装了Oracle服务端,后来因导数据需要,又安装了一个客户端作为监听;导致了现在cmd无法连接(服务已启动),但客户端可以连接上。 D:\app\Administrator\product\11.2.0\dbhome_3\bin;d:\app\Administrator\product\11.1.0\cli
在一台服务器上安装oracle服务端和客户端,不能访问的解决办法 .
由于客户端是在服务端之后安装的,所以在环境变量中path变量,客户端的配置在服务端的前面。只需要将客户端的配置放在服务端之后即可。
解决“System.Data.OracleClient 需要 Oracle 客户端软件 8.1.7 或更高版本”
在用VS.NET2005+Oracle9.2进行开发的时候,在本地测试可以通过,但是在服务器上不能实现(复制网站,发布网站都不行),报错的具体内容,没记下来,大概就是: "System.Data.OracleClient 需要 Oracle 客户端软件 8.1.7 或更高版本" 在网上查询了很长时间也没有见效,后来综合网上的很多方法,终于测试成功,现分享一下。 出错的原因: 1.虽然报的是
关闭