CSDN论坛 > VC/MFC > 基础类

VC.NET编译一个VC6的项目报错? [问题点数:50分,结帖人hydralisk]

Bbs1
本版专家分:5
结帖率 99.46%
CSDN今日推荐
Bbs1
本版专家分:5
Bbs2
本版专家分:129
Bbs4
本版专家分:1336
Bbs1
本版专家分:5
匿名用户不能发表回复!
其他相关推荐
使用VC6将32位程序编译成为64位程序(这个才是可行的)
山上明月 使用VC6将32位程序编译成为64位程序 看了好多好多资料,自己也太过依赖现有的资料,按部就班不是真理不是真理!!! 主要内容是参照http://www.vckbase.com/document/viewdoc/?id=1857的,下面把自己做的过程简要描述如下: 创建64位环境             网上资料很多都以SDK2001少数以200
彻底解决VC6在编译,链接时的假死问题
VC6在编译,或者链接的时候会出现假死的现象,IDE没有响应了,直接关关不掉IDE,只有从进程管理器里面关掉,一开始我以为是Visual Assist X的问题,卸载它之后问题依旧,最终找到了解决方案,原来这是一个BUG,在vs6 sp6里面microsoft已经解决了,具体链接如下:http://support.microsoft.com/kb/839136/en-us?fr=1vs6 sp6的下载地址:英文版地址: http://download.microsoft.com/download/1/9/f
vc6编译连接选项全解
一 编译参数的设置编译参数的设置。主要通过VC的菜单项Project->Settings->C/C++页来完成。我们可以看到这一页的最下面Project Options中的内容,一般如下:/nologo /MDd /W3 /Gm /GX /ZI /Od /D "WIN32" /D "_DEBUG" /D "_WINDOWS" /D "_AFXDLL" /D "_MBCS" /Fp"Debug/
xp+vc6+openssl 1.0.1f 编译
1. xpsp3  vc6.0sp6  openssl1.0.1f 2. 安装activeperl 5.8 或更高版本 3. vc6需要添加环境变量(手动方式加入用户环境变量,如下) 名 include 值 C:\Program Files\Microsoft Visual Studio\VC98\atl\include;C:\Program Files\Microsoft Visual
打造最强的VC6编译器!
类似的话题也讨论过很多,实际用到, 真是麻烦;首先,Windows 平台下的C/C++编译器,大家肯定会想到VC,个人觉得VC中最好的就是 VC6了,不过缺点很多,我们稍后改造它!     Borland C++ 我没用过, 不知道如何。    Borland C++ Builder 感觉作程序界面比较方便, 如果你用来学习C++,或者写一些控制台小程序,或者作                  
VC中动态创建二维数组的方法
<br />先给了例子吧:如要想创建一个[m][n]的二维数组。<br />下面为通过动态创建一个指针数组的方法来动态创建二维数组的方法。<br /> <br />double **data;<br />data = new double*[m];//设置行 或直接double **data=new double*[m]; 一个指针指向一个指针数组。 <br />for(int j=0;j<m;j++)<br />{<br />data[j] = new double[n];        //这个指针数组
VC6命令行编译DLL
前言要做个小工具,在程序中调用命令行来编译DLL. VC6IDE提供导出编译脚本的功能, 先将编译脚本导出来. .mak文件还是有点大 , 将活动的参数用参数宏替换, 然后做个.bat, 指定参数宏调用. 这样,换不同的DLL工程编译时, .mak就不用改了. 除了.mak文件,其它文件都是比较短,或有规律可循的,可以用程序来做. 在安装了开发环境的计算机上,就能实现调用脚本来编译
JSONCpp在windows下的VC6编译和调用
其实很简单,但是不知道的时候根本无从下手,后来看到别人分享的
vc6 在win10上编译x64程序的问题总结
VC6本身是不支持编译x64程序的,如果想在VC6的环境下开发x64程序就需要下载新的微软sdk,支持VC6的最新SDK应该是Microsoft Platform SDK Windows Server 2003 R2. 正常安装后打开 “Set Windows XP 32-bit Build Environment (Retail)” 会提示:“Attempting to detect a
VS2010下编译的库在VC6下使用问题
之前因为工作需要,深入研究了 rabbitmq 的 C 代码,并以 libevent 为基础将其改造成事件驱动的单线程模型。由于一直都是自己写库封装和 demo 代码来测试,所以上述库都以 VS2010 的静态库(.lib)形式提供。前天,终于有业务人员要基于这个 demo 写东西了,但却发现编译链接都不行,究其原因是由于所用的编译器 VC6 太老旧的缘故。 库的跨编译器使用问题属于老生
关闭