CSDN论坛 > .NET技术 > ASP.NET

在插入操作时 出现“操作必须使用一个可更新的查询。”是什么意思 [问题点数:40分,结帖人xiaohunhun2001]

Bbs1
本版专家分:41
结帖率 98.21%
CSDN今日推荐
Bbs6
本版专家分:8137
Bbs7
本版专家分:17319
Bbs6
本版专家分:8137
Bbs6
本版专家分:8137
Bbs4
本版专家分:1037
Bbs5
本版专家分:3301
Bbs9
本版专家分:97725
Blank
微软MVP 2014年1月 荣获微软MVP称号
2012年1月 荣获微软MVP称号
2011年1月 荣获微软MVP称号
2009年1月 荣获微软MVP称号
2006年1月 荣获微软MVP称号
2008年1月 荣获微软MVP称号
2007年1月 荣获微软MVP称号
2005年1月 荣获微软MVP称号
2004年1月 荣获微软MVP称号
匿名用户不能发表回复!
其他相关推荐
解决"操作必须使用一个可更新的查询"
错误信息:Microsoft OLE DB Provider for ODBC Drivers error 80004005 [Microsoft][ODBC Microsoft Access 97 Driver] Operation must use anupdateable query. 原因:有几个主要的错误原因:这个错误发生在当你的程序试图执行更新数据库或其它类似操作时。这是因为ADO
Microsoft JET Database Engine 错误 '80004005' 操作必须使用一个可更新的查询。问题解决办法
问题如下:无法显示网页试图访问的网页出现问题,无法显示。请尝试执行下列操作:单击刷新按钮,或稍后重试。 打开 localhost 主页,然后查找与所需信息相关的链接。 HTTP 错误 500.100 - 内部服务器错误 - ASP 错误Internet 信息服务   然后首先你要确定错误
“/”应用程序中的服务器错误(System.Data.OleDb.OleDbException: 操作必须使用一个可更新的查询)
问题描述:         在云服务器上部署项目遇到的问题,系统是windows2008r2,部署完成后,打开页面,在修改数据提交时报错如下: 运行时错误 说明: 服务器上出现应用程序错误。此应用程序的当前自定义错误设置禁止远程查看应用程序错误的详细信息(出于安全原因)。但可以通过在本地服务器计算机上运行的浏览器查看。 详细信息: 若要使他人能够在远程计算机上查看此特定错误消息的详细
使用oledb读写excel出现“操作必须使用一个可更新的查询”的解决办法
使用oledb读写excel出现“操作必须使用一个可更新的查询”的解决办法   要求将结果写入xls文件的一个sheet中,我随便写了个语句以为可以立马搞掂,没想到居然出现了“操作必须使用一个可更新的查询”。因为读取结果正常,我开始以为是excel文件所处的文件夹没有写权限所致。增加了相应权限后,结果依然如故。没办法还是检查程序吧,仔细检查了一下,问题发现了,原来开始只是为了读取exc
Microsoft Access 操作必须使用一个可更新的查询
错误提示: Microsoft OLE DB Provider for ODBC Drivers 错误 '80004005'  [Microsoft][ODBC Microsoft Access 驱动程序] 操作必须使用一个可更新的查询。 /inc/bottom.asp, 行 9 故障分析:数据库没有写入权限: 解决办法: 最普遍的原因是用户对该数据库文件没有写权限。要解决这个问题在管
[Microsoft][ODBC Microsoft Access Driver] 操作必须使用一个可更新的查询(解决办法)
<br />  这个错误是由不能写入造成的。<br />  如果没有设置只读,请看下所在分区格式,如果是NTFS格式,需要把access文件所在文件夹的读写修改权限给予"IUSR_机器名"这个帐号,方法是在该文件夹上右键,属性=》安全。<br />如果没有这个选项,先在我的电脑中 工具=》文件夹选项=》查看,然后把“使用简单文件共享”前边的勾去掉,然后确定。这样, 就能设置权限了。
DW开发中出现无法插入记录问题的解决方案(access数据库)
Dreamweaver开发过程中无法向Access数据库插入记录出现“操作必须使用一个可更新的查询”
关于“操作必须使用一个可更新的查询”错误提示!
今天发布网站的时候突然发现了这个问题,折腾了好久以后发现,是数据库写入权限的问题,只要为数据库添加访问者的写入权限,问题就可以解决,唉,折磨人啊。。。 
Microsoft JET Database Engine (0x80004005)操作必须使用一个可更新的查询
技术信息(用于支持人员)   错误类型:Microsoft JET Database Engine (0x80004005)                    操作必须使用一个可更新的查询。   在网上找到了原因,折腾了我好几天,终于搞定了,呵呵 有几个主要的错误原因: 这个错误发生在当你的程序试图执行更新数据库或其它类似操作时。这是因为 ADO由于以下的几个原因而不能够写数据库
C#ADO连接修改Paradox表时“操作必须使用一个可更新的查询”错误的处理办法
现象: 在C#中使用ADO连接到Paradox表,使用Update修改Paradox表内数据时,系统提示“操作必须使用一个可更新的查询。”原因:Paradox无主索引的表在C#环境中不支持修改。解决办法:在Database desktop中打开Paradox表,选择唯一性字段,为其创建一个索引。在Paradox表的目录中会产生一个与表同名、扩展名为px索引文件。
关闭