Kylix2安装问题!

li_zhifu 2002-02-06 01:14:56
近日弄到一KYLIX2企业版,用命令sh setup.sh安装,出错:
信息为
:command.....
.
.
.
:line 86 Error....
好象是执行到86行便出错。
这份kylix大概有385MB,根目录下只有
DEPLOY
INSTALL
PREINSTALL
README

license.txt


setup.sh
不知这份拷贝是否人问题?不知该如何安装。。。。。
Mandrake Linux 8.0,在Kylix 2说明里说得很明确,Kylix 2是可以安装在Mandrake Linux 8.0里的。

小弟先谢过各位,特赠送一个地址
http://202.96.70.229/cakk/delphi/app/Kylix2.zip
...全文
19 12 打赏 收藏 举报
写回复
12 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
mopege 2002-04-11
可是你这个好像只是适用于kylix1,不使用于kylix2啊.我正在为这个苦恼啦
  • 打赏
  • 举报
回复
li_zhifu 2002-04-08
问题没有解决,不过拖得时间太长了,结贴给分了。
  • 打赏
  • 举报
回复
chechy 2002-03-01
这是从一个新闻组考来的,希望对你有用:

关于这个问题,许多人零零散散写了许多篇帖子,现在做个总结。

1、Kylix安装的最低要求:
- Linux Kernel 2.2或更高,最好不要用测试版的内核(别问我为什么:)
- libgtk.so 1.2或更高(只在安装程序中使用)
- libjpeg 6.2或更高
- X11R6兼容的X服务器,如XFree86
- glibc 2.1.2或更高,要注意,并不是只满足版本号需求就行,必须要没有loader错
误才行,比如TurboLinux6,虽然glibc的版本号是2.1.2-15,但是因为这个错误没有修
正,所以必须要升级。
- QT 2.2.4或更高(奇怪,更高不一定行,至少现在的那个QT3测试版肯定不行)

Borland“官方”宣布支持的Linux有:
RedHat 6.2
RedHat 7.0
Mandrake 7.2
SuSE 7.0
注意,以上的版本并不是“推荐”版本,只是Borland在其上进行了比较广泛的测试而
已。
另外,以下的版本已经得到成功安装的消息:
Mandrake 8
SuSE 7.1
*RedHat 7.1
**Slackware 7
***Caldera eDesktop 2.4

*RedHat7.1自带的RPM有错,参见下文“不使用RPM的安装”
**Slackware不包含RPM,参见下文“不使用RPM的安装”
***Caldera eDesktop 2.4需要补丁,但是并没有“官方”的补丁

1、普通安装(使用root)
在简单不过了,运行kylixcd/borpretest/borpretest测试你的系统是否满足需求,如
果你得到了诸如:
Checking loader....lib-a.so: cannot open shared object file: No such file or
directory
这样的消息,可以不管它。
如果测试通过,你就可以开始安装了,如果没有通过,那么你需要安装补丁,一般就是
glibc的补丁,Kylix上自带了一些版本,如果不适合,你需要到相应的Linux发行商那
里去找。
*如果你是用的是Caldera eDesktop 2.4,那么你可以安装Mandrake7.2的补丁,因为
Caldera还没有发布“官方”的补丁。有人说这样做成功了,但是我并不对此作任何承
诺。

2、普通安装(普通用户)
基本与1相同,只要你不使用root,那么就不会使用rpm,所以对于rpm不可用的Linux
(比如RH7.1和Slackware)来说,这也是一种方法。

3、不使用RPM的安装
很显然,补丁还是要打的,安装的时候使用
sh setup.sh -m
强制不使用rpm,对于RH7.1、Slackware和Debian来说,这也是目前唯一可行的用root
安装的方法。

注1:对于图形界面程序,你需要将kylix_dir/bin加入到LD_LIBRARY_PATH里面,虽然
可以直接加入/etc/ld.so.conf,但是不推荐这样做,最好是创建一个ShellScript运行
你的程序。

注2:MySQL新版(高于3.22.32)对于Kylix来说不可用,没办法,等补丁吧

--
昨天摔了一跤
希望今天不会在同一个地方再摔一跤。
  • 打赏
  • 举报
回复
ie4888 2002-03-01
哪里有下载企业版??????
分数多多!!!!!
  • 打赏
  • 举报
回复
Rewiah 2002-02-25
关注!

  • 打赏
  • 举报
回复
li_zhifu 2002-02-25
up
  • 打赏
  • 举报
回复
thedream 2002-02-07
好像装之前还要升级一个什么库吧
  • 打赏
  • 举报
回复
cobi 2002-02-07
收藏地址并关注
  • 打赏
  • 举报
回复
lks111 2002-02-07
关注!
  • 打赏
  • 举报
回复
li_zhifu 2002-02-07
to Linux2001:能发给我一份吗?或是告诉我地址也行啊
  • 打赏
  • 举报
回复
Linux2001 2002-02-07
网上有这个方面的文章的,我都有下一个
  • 打赏
  • 举报
回复
mattus_zhao 2002-02-06
你可以去www.linuxbyte.net上去问问。
  • 打赏
  • 举报
回复
发帖
Delphi
加入

5091

社区成员

Delphi 开发及应用
社区管理员
  • VCL组件开发及应用社区
申请成为版主
帖子事件
创建了帖子
2002-02-06 01:14
社区公告
暂无公告