• 全部
  • 问答

xml文件在window98(IE5.0)下不能解析的问题

ywduan 2004-03-29 02:17:39
用xsl表现xml数据在IE5。5以上都可以正常显示
但在IE5.0环境下却无法正常显示,把一些凌乱的源代码直接显示了出来
请问这个应该如何解决呢?
名称空间http://www.w3.org/1999/XSL/Transform
...全文
13 点赞 收藏 12
写回复
12 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
ywduan 2004-03-31
谢谢
再测试一下给分
回复
大可山人 2004-03-30
首先判断浏览器的版本,根据不同版本下载不同内容呈现。
我的做法是:在网站首页进行判断,如果支持XML则利用COOKIE锁定客户端下载XML,否则下载HTML内容呈现。

CSDN的做法值得参考:
XSL文件中:
<SCRIPT LANGUAGE="javascript"><xsl:comment>
<![CDATA[

function GetIEVersion()
{
try
{
if(!window.clientInformation)
return false;
if(window.clientInformation.appName.toLowerCase()!="microsoft internet explorer")
return false;
if(window.clientInformation.appVersion.toLowerCase().indexOf("msie")==-1)
return false;
var a=window.clientInformation.appVersion.toLowerCase().split(";");
for(var i=0;i<a.length;i++)
{
a[i]=a[i].replace(" ","");
if(a[i].indexOf("msie")==0)
{
var version=a[i].substr(4,a[i].indexOf(".")-2);
return version;
}
}
}
catch(exception)
{
}
return false;
}

window.IEVersion=GetIEVersion();
if(parseInt(window.IEVersion)<6)
document.write("<style>textarea.content { behavior:url('tacontent.htc')}</style>");
]]>
</xsl:comment>
</SCRIPT>

tacontent.htc的内容:
---------------------
<PUBLIC:COMPONENT>
<PUBLIC:ATTACH EVENT="oncontentready" ONEVENT="element.SetHeight()" />
<PUBLIC:ATTACH EVENT="ondetach" ONEVENT="On_Deatch()" />
<PUBLIC:METHOD NAME="SetHeight" />
<SCRIPT>
var TimerID=0;
function On_Deatch()
{
if(TimerID)
{
clearTimeout(TimerID);
TimerID=0;
}
}
function SetHeight()
{
if(window.IEVersion>5.0)
{
element.runtimeStyle.overflow="visible";
return;
}
TimerID=0;
var height=element.scrollHeight;
if(height<10)
{
TimerID=setTimeout(element.uniqueID+".SetHeight()",1000);
return;
}
element.runtimeStyle.height=height+"px";
}
</SCRIPT>
</PUBLIC:COMPONENT>
回复
gbliang 2004-03-30
/*判断IE版本是否低于6.0*/
try{
if(navigator.appVersion.indexOf("MSIE 6.0")==-1) throw "IE版本低于6.0";
}
catch(e){
tipFunc(e);
}
回复
zhangyubo 2004-03-30
升级客户端机器的msxml版本
回复
ywduan 2004-03-30
原来的版本是用的 这个命名空间http://www.w3.org/TR/WD-xsl
后来新版本因为要用的with-param元素和其他的一些元素所以改用新的命名空间
还有没有更好的解决方案
回复
zhangyubo 2004-03-30
用http://www.w3.org/TR/WD-xsl命名空间,可以在ie5.0上实现简单的xml显示
回复
donworld 2004-03-30
用asp + xml
asp判断用户的浏览器版本
回复
ywduan 2004-03-30
IE5.5以下必须得升级才行?
回复
bxh2dai 2004-03-29
xml要求ie5.5以上版本
回复
ywduan 2004-03-29
有没有什么折中的办法 因为客户系统有可能用的是IE5啊
怎样先判断一下msxml的版本或者IE的版本
然后弹出对话框让用户下载相应的解析器
回复
superauu 2004-03-29
xml要求ie5.5以上版本。
回复
jspxml 2004-03-29
下载IE5.0及以上的版本!
回复
相关推荐
发帖
XML/XSL
创建于2007-09-28

8810

社区成员

XML/XSL相关问题讨论专区
申请成为版主
帖子事件
创建了帖子
2004-03-29 02:17
社区公告
暂无公告