社区
ASP
帖子详情
向数据库内写文章。文章过长出现错误,该如何处理?
coolho
2004-04-07 11:33:57
堆栈溢出
/bfnews/admin/pr_addnews.asp,行66
处理中的数据超过允许的极限。
66行:content=request("content")
用的是SQL server库。字段用的是text
将字段改成ntext也是一样。所以认为现在的问题是变量溢出。请问如何处里?
...全文
126
48
打赏
收藏
向数据库内写文章。文章过长出现错误,该如何处理?
堆栈溢出 /bfnews/admin/pr_addnews.asp,行66 处理中的数据超过允许的极限。 66行:content=request("content") 用的是SQL server库。字段用的是text 将字段改成ntext也是一样。所以认为现在的问题是变量溢出。请问如何处里?
复制链接
扫一扫
分享
举报
写回复
配置赞助广告
用AI写文章
48 条
回复
切换为时间正序
请发表友善的回复…
发表回复
打赏红包
擒兽
2004-04-09
打赏
举报
回复
55555555555555555555555555555555555555555555
enctype="multipart/form-data"
我的还是没解决,还是不行!
coolho
2004-04-08
打赏
举报
回复
to: xhuad(DD.net)
才用二进制成功。谢谢
coolho
2004-04-08
打赏
举报
回复
to:cshadow(河狸(郁闷ing))
这个本来就是post的。
coolho
2004-04-08
打赏
举报
回复
to:fenlin(孤帆)
不行的。在dev-club上的解果是iis接受的数据有限造成的。。
你说的这个方法我也想过。我也试了一下,
Left(request("content"),1000)
一样会报错。。
cdcmtg4
2004-04-08
打赏
举报
回复
那里可以找到浏览器的原程序啊
enxi
2004-04-07
打赏
举报
回复
感谢使用微软产品!
SQL server 中,text类型允许存储的数据的最大长度多大2GB,但它实际数量收到全局变量@@Textsize的限制,默认情况下,@@Textsize的取值为4094Byte,共4kb。你可以通过下面的方式来设置@@Textsize的取值:
如:设置@@Textsize的值为40kb的语句:
set @@Textsize 40960
如果你想设置@@Textsize的值为默认值4kb:
set Textsize 0
coolho
2004-04-07
打赏
举报
回复
一样,还是溢出。没变化。
aducat
2004-04-07
打赏
举报
回复
把表单传送方法确定为post看看行不?
看看数据库字段属性
coolho
2004-04-07
打赏
举报
回复
conn.Execute "insert into news (content) values('"&request("content")&"')"
直接用SQl语句也会出错
/iisHelp/common/500-100.asp,行242 错误 '80020009'
发生意外。
/bfnews/admin/pr_addnews.asp,行69
driftarter
2004-04-07
打赏
举报
回复
数据库连接的问题你换一种数据方式试试
zjwz001
2004-04-07
打赏
举报
回复
关注中
coolho
2004-04-07
打赏
举报
回复
rs("content")=request("content")
直接向字段里写。出现这个错误
Provider 错误 '800a4005'
未知的运行时错误
/bfnews/admin/pr_addnews.asp,行84
coolho
2004-04-07
打赏
举报
回复
ctttw=request("content")
换成这样了。一样。还是溢出
Newrocky
2004-04-07
打赏
举报
回复
to coolho(coolho)
那你换个变量名看看?!
看看能把REQUEST("CONTENT")的值付过去不?!
Newrocky
2004-04-07
打赏
举报
回复
to sfply:
content不是保留字吧!
text字段可以存储4亿个字符的啊!
怎么会这样呢???关注!
swich
2004-04-07
打赏
举报
回复
用image试试
coolho
2004-04-07
打赏
举报
回复
但现在程序还没有执行到向库里存储就以经出错了。
出错的地方是向变量复值
尚和空四
2004-04-07
打赏
举报
回复
用image字段去处理,读出的时候转化
coolho
2004-04-07
打赏
举报
回复
应该不会的吧。。写内容少的文章时是没有问题的。
sfply
2004-04-07
打赏
举报
回复
难道content是sqlserver2000保留字段?
加载更多回复(28)
一篇
文章
讲解清楚,数据仓库和
数据库
的区别
数据仓库在企业中的应用非常广泛,包括销售分析、客户关系管理、库存管理、财务报告等。通过数据仓库,企业可以更好地了解业务状况,发现潜在问题,制定有效的策略,提高竞争力。
数据仓库和
数据库
有什么区别?
数据仓库和
数据库
是两种不同类型的数据存储解决方案,它们在设计、用途和功能上存在显著差异。首先,
数据库
主要用于事务
处理
系统,它们支持日常操作,如数据的插入、更新和删除。
数据库
通常具有高度规范化的结构,以减少数据冗余并确保数据一致性
数据仓库和
数据库
有什么区别?一篇
文章
讲解清楚
数据仓库的构建通常遵循数据抽取、清洗、转换和加载(ETL)的过程。首先,从各种业务系统中抽取数据,然后对数据进行清洗,消除不一致性和
错误
。接下来,对数据进行转换,将其转换成适合分析的格式
学数据仓库,看这篇
文章
就够了
Hive数据仓库一、数据仓库基础1、概念2、特点效率足够高数据质量扩展性3、数据模型二、Hive数据仓库1、概念2、优点3、缺点4、Hive体系结构及执行流程4.1、Hive体系结构4.2、Hadoop集群4.3、驱动器4.4、用户接口4.5、元数据存储4.6、Hive表与元数据的映射关系4.7、Hive执行流程5、Hive数据仓库和
数据库
比较三、Hive环境搭建1、MySQL安装及配置2、Hive安装及配置2.1、安装2.2、配置2.3、log日志配置四、Hive基础1、Hive数据类型2、Hive数据存
【数据仓库】数据漂移的
处理
本文摘自《大数据之路:阿里巴巴大数据实践》。 数据漂移的
处理
通常我们把从源系统同步进人数据仓库的第一层数据称为ODS或者staging层数据,阿里巴巴统称为ODS。数据漂移是ODS数据的一个顽疾,通常是指ODS表的同一个业务日期数据中包含前一天或后一天凌晨附近的数据或者丢失当天的变更数据。 由于ODS需要承接面向历史的细节数据查询需求,这就需要物理落地到数据仓库的ODS表按时间段来切分进行分区存储,通常的做法是按某些时间戳字段来切分,而实际上往往由于时间戳字段的准确性问题导致发生数据漂移。 通常
ASP
28,402
社区成员
356,940
社区内容
发帖
与我相关
我的任务
ASP
ASP即Active Server Pages,是Microsoft公司开发的服务器端脚本环境。
复制链接
扫一扫
分享
社区描述
ASP即Active Server Pages,是Microsoft公司开发的服务器端脚本环境。
社区管理员
加入社区
获取链接或二维码
近7日
近30日
至今
加载中
查看更多榜单
社区公告
暂无公告
试试用AI创作助手写篇文章吧
+ 用AI写文章