eclipse启动不了???

kvill 2004-04-07 08:47:04
新下载的eclipse3.0M7,解压后运行出现提示:
Problem during startup.Check the ".log" file in the ".metadata" directory of your workspace.

jdk1.4早已正常安装,运行测试也正常。
".metadata" directory 中的“.log”中这样写:(看不明白,请大家帮忙指点)

!SESSION ----------------------------------------------------------------------
!ENTRY org.eclipse.core.launcher 4 0 四月 07, 2004 20:22:40.343
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.NullPointerException
at org.eclipse.ui.keys.KeyStroke.hashCode(KeyStroke.java:308)
at java.util.HashMap.hash(HashMap.java:257)
at java.util.HashMap.get(HashMap.java:313)
at org.eclipse.ui.internal.commands.KeySequenceBindingNode.add(KeySequenceBindingNode.java:175)
at org.eclipse.ui.internal.commands.KeySequenceBindingMachine.validateTree(KeySequenceBindingMachine.java:231)
at org.eclipse.ui.internal.commands.KeySequenceBindingMachine.validateSolution(KeySequenceBindingMachine.java:210)
at

org.eclipse.ui.internal.commands.KeySequenceBindingMachine.getKeySequenceBindingsByCommandId(KeySequenceBindingMachine.java:7

3)
at org.eclipse.ui.internal.commands.CommandManager.calculateKeySequenceBindings(CommandManager.java:274)
at org.eclipse.ui.internal.commands.CommandManager.readRegistry(CommandManager.java:715)
at org.eclipse.ui.internal.commands.CommandManager.<init>(CommandManager.java:233)
at org.eclipse.ui.internal.commands.CommandManager.<init>(CommandManager.java:196)
at org.eclipse.ui.commands.CommandManagerFactory.getCommandManager(CommandManagerFactory.java:41)
at org.eclipse.ui.internal.commands.ws.WorkbenchCommandSupport.<init>(WorkbenchCommandSupport.java:49)
at org.eclipse.ui.internal.Workbench.init(Workbench.java:767)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1503)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:265)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:139)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:47)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:257)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:104)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.basicRun(Main.java:279)
at org.eclipse.core.launcher.Main.run(Main.java:742)
at org.eclipse.core.launcher.Main.main(Main.java:581)

...全文
31 点赞 收藏 5
写回复
5 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
kvill 2004-04-07
多谢,就是要用1.4.2以上才行。
回复
kvill 2004-04-07
cmd下运行:
F:\eclipse>eclipse -jvm c:\j2sdk1.4\jre
也启动不了;
还有,怎么我的c:\j2sdkee1.4和c:\j2sdkee1.3.1下都没有带\jre呢??
回复
oyp 2004-04-07
或j2sdk1.4.2以上版本
回复
oyp 2004-04-07
换成jdk1.4.2
回复
mingjava 2004-04-07
指定jvm看看 eclipse -jvm your_jre_dir/javaw.exe
回复
相关推荐
发帖
Web 开发
创建于2007-09-28

8.0w+

社区成员

Java Web 开发
申请成为版主
帖子事件
创建了帖子
2004-04-07 08:47
社区公告
暂无公告