各位大哥帮帮我啊

zhidao 2004-04-08 11:01:38
在xp下装了iis后,在调试时发现一个错误
0x800AOE7A
ADODB.Connection未找到提供程序,该程序未正确安装
我重装了几便iis都没用
不知问题出在哪,各位大哥帮帮我啊!
...全文
15 点赞 收藏 11
写回复
11 条回复
切换为时间正序
请发表友善的回复…
发表回复
sheng9hhd 2004-04-08
strProvider = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & Server.MapPath("\")& "\jxx\in.mdb"
回复
runlai 2004-04-08
mdac升级一下试试。
好像是这个http://www.microsoft.com/downloads/details.aspx?FamilyID=8e5f816c-4918-4250-b8bd-3794582c9089&displaylang=zh-cn
回复
zhidao 2004-04-08
我用的是access2000
回复
chendongqiang 2004-04-08
connStr="PROVIDER=SQLOLEDB;DATA SOURCE=127.0.0.1;UID=sa;PWD=cmr;DATABASE=bdname"
回复
liuyingzi 2004-04-08
数据库存在么?
显见个简单得网页重命名为*.asp刊能不能运行
应该是数据库的问题
回复
chendongqiang 2004-04-08
connStr ="PROVIDER=SQLOLEDB;DATA SOURCE=127.0.0.1;UID=sa;PWD=1;DATABASE=dbname"
回复
dafeifei 2004-04-08
连接语句的问题
你是用的什么数据库?
回复
zhidao 2004-04-08
<%
adopenkeyset=1
adlockoptimistic=3

set conn=Server.Createobject("ADODB.Connection")
strProvider="Driver={Microsoft Access Driver (*.mdb)}; DBQ="&Server.MapPath("\")& "\jxx\in.mdb;UID=;PWD=;"
conn.Open strProvider,3,3

set rs=server.createobject("adodb.recordset")
rs.open "bj1",conn,adopenkeyset,adlockoptimistic

%>
这是我连接数据库的代码,可我在2000或98下都没问题啊
在xp下怎么出了问题啊
回复
jinhaiou 2004-04-08
connStr="Provider=SQLOLEDB.1; Persist Security Info=True; Data Source=abby; Initial Catalog=article; User ID=sa; Password="
conn.Open connstr
回复
zhidao 2004-04-08
可我在2000或98下都没问题啊
回复
superauu 2004-04-08
应该不是iis的错误,你再看看你的连接数据库的语句对不对。
回复
发动态
发帖子
ASP
创建于2007-09-28

2.8w+

社区成员

ASP即Active Server Pages,是Microsoft公司开发的服务器端脚本环境。
申请成为版主
社区公告
暂无公告