新手!请教ANT!高分相送!

lordofthering 2004-04-13 06:35:13
我安装Ant后。运行>Ant 命令,当前目录下没有Build.xml文件。
命令:C:\ant

输出以下信息:
Usage: java [-options] class [args...]
(to execute a class)
or java -jar [-options] jarfile [args...]
(to execute a jar file)

where options include:
-client to select the "client" VM
-server to select the "server" VM
-hotspot is a synonym for the "clien
The default VM is client.

-cp -classpath <directories and zip/jar f
set search path for applica
-D<name>=<value>
set a system property
-verbose[:class|gc|jni]
enable verbose output
-version print product version and e
-showversion print product version and c
-? -help print this help message
-X print help on non-standard
-ea[:<packagename>...|:<classname>]
-enableassertions[:<packagename>...|:<cla
enable assertions
-da[:<packagename>...|:<classname>]
-disableassertions[:<packagename>...|:<cl
disable assertions
-esa | -enablesystemassertions
enable system assertions
-dsa | -disablesystemassertions
disable system assertions

即使放一个合适的build.xml 文件,也是输出这些信息!是不是Ant安装后还需要配置什么!请指教!
...全文
45 8 打赏 收藏 举报
写回复
8 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
jkit 2004-04-14
刚又看了一下,你的classpath和ant_home设置的不对。
-classpath "xx.jar,yyy.jar" // 分隔符应该是分号,而不是逗号
"-Dant.home=D:\Ant\" // 这里应该是 D:\Ant 而不是 D:\Ant修改办法:改正环境变量里面的classpath和ANT_HOME
  • 打赏
  • 举报
回复
ChinaHopes 2004-04-14
楼主醒目!

我知道是怎么回事!!


你的

ANT_HOME应该是:d:\ant

而不应该是:d:\ant
!!!



给分!!!!!
  • 打赏
  • 举报
回复
huangk 2004-04-14
你可以试着再重装一遍,并检查你的build.xml的正确性。
另外,如果你装的有TOMCAT的话,要确保你用的是%ANT_HOME%\lib下的ant.jar,而不是%TOMCAT_HOME%\lib下的ant.jar。
  • 打赏
  • 举报
回复
lordofthering 2004-04-14
我现在能看出来,是在运行ant.bat过程中,调用java -classpath "xx.jar,yyy.jar" "-Dant.home=D:\Ant\" org.apache.tools.ant.Main
时出的错!不知道,这该怎么处理!
  • 打赏
  • 举报
回复
lordofthering 2004-04-14
再顶一下!
如果当前目录下没有build.xml文件,应该输出:The build.xml file isn't exist! 才对!可怎么用,都是先输出这样的错误信息!
  • 打赏
  • 举报
回复
jkit 2004-04-13
是你的build.xml写的有问题。
安装ant后什么都不需要配置,如果为了方便,可以把<ant目录>\bin加到path里面就行了。
build.xml文件的编写可以参照ant本身的文档<ant目录>\docs
  • 打赏
  • 举报
回复
moke33 2004-04-13
CLASSPATH指向你的ant资源包
Path指向你的\bin目录
  • 打赏
  • 举报
回复
lordofthering 2004-04-13
再顶!
  • 打赏
  • 举报
回复
相关推荐
发帖
Java EE

6.7w+

社区成员

J2EE只是Java企业应用。我们需要一个跨J2SE/WEB/EJB的微容器,保护我们的业务核心组件(中间件),以延续它的生命力,而不是依赖J2SE/J2EE版本。
社区管理员
  • Java EE
加入社区
帖子事件
创建了帖子
2004-04-13 06:35
社区公告
暂无公告