快来救命!我要在J2ME下用这几个包,有什么办法没有?

ffgg 2004-04-29 08:42:40
我的模拟终端要接受gzip压缩后的文件,现在势必要用这几个包。

import java.net.PasswordAuthentication;
import java.net.Socket;
import java.net.URL;
import java.util.zip.GZIPInputStream;
import java.util.zip.Deflater;
import java.util.zip.InflaterInputStream;

可是我这个初学者才发现j2me里面啥都没有……
怎么办?有没有办法把这几个库添进来的???
真的救命啊,我急死了。
...全文
79 21 点赞 打赏 收藏 举报
写回复
21 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
世外结缘 2004-07-11
我也是刚学j2me的,给我发一份,谢谢!
tmlnc@163.com
  • 打赏
  • 举报
回复
网络咖啡 2004-07-10
没有办法
  • 打赏
  • 举报
回复
fogbound 2004-07-01
应该不行的吧,以前我也遇到过类似的问题,最后是改变了需求绕过这个问题!关注一下。
  • 打赏
  • 举报
回复
Piyongcai 2004-07-01
使用 Java 的WebServices
  • 打赏
  • 举报
回复
ericylw 2004-05-09
很简单,只要你用的包中调用了非j2me的api(即j2se中的东东),在j2me来说就是非法的,明白了?
  • 打赏
  • 举报
回复
ffgg 2004-05-08
谢谢楼上二位。
我目前的麻烦是,jdk中支持gzip等的几个包似乎是整合在java环境里的,并没有单独的jar或zip文件以提供。
我也是初学者,于这些方面不太熟,希望得到大家的进一步指点。。。
  • 打赏
  • 举报
回复
sea_lover 2004-05-06
对了,还有一个sun one,他与WTK是一样的!呵呵,也要用命令行的形式。但是如何用JB的方法在sun one下用,我还没有研究出来。希望有成功的高手们指点!

good luck!
  • 打赏
  • 举报
回复
sea_lover 2004-05-06
很简单,如果你用的是WTK来建立工程,你可以将你的包放到.../WTK/lib目录下,然后你运行你的程序的时候,这时候一定要用命令行的形式,因为,如果你用WTK直接Build的话,WTK不会找到你的包的,用命令行自己加入:
...\WTK21\bin\emulator.exe -classpath "...\WTK21\lib\你包的名字.zip;" -descriptor:"jad的路径"

如果你用的是JB来建立的工程,那么你先把你的包放在一个目录(建立与wtk或jdk的lib放在同一个地方,方便以后查找),在JB的中选择:project->project Properties,下面有一个required Libraries,在这里ADD你的包。这样用JB来运行程序的时候,他会自动加入这个包。如果你想把你的程序自己的包打入.jar里,那么create midlet suite时(也就是JB打包的第4步),下面的单选框选择2或3项,这样,他会自动打入你的.jar里。

好了,有什么问题,再联系。祝你好运!
  • 打赏
  • 举报
回复
witboy 2004-05-05
i f l y
  • 打赏
  • 举报
回复
dTianx 2004-05-04
All the class is APIs

fro example: Your program runs on win2k and just design on win2k

can it must run on win98 ??

All the functions are built in the mobiles, the class only told the machine to do what built in the set

So, you can not
  • 打赏
  • 举报
回复
ffgg 2004-05-04
楼上的方法,我准备试一试。等我成功了就来结账。
  • 打赏
  • 举报
回复
zzzle 2004-05-03
为什么不可以?
我把这些东西编译成class文件->Jar,jad文件难道还不行吗?
  • 打赏
  • 举报
回复
dTianx 2004-05-02
NO!

if you uz these packages ,your app will never run on mobiles!
  • 打赏
  • 举报
回复
superego 2004-04-30
这些包的确不支持!你要做什么,大家帮你看一下!有没有什么其他办法~~~~~~~~~~~~
  • 打赏
  • 举报
回复
yjawal8071 2004-04-30
不支持的
  • 打赏
  • 举报
回复
疯狂低调 2004-04-30
哈,抱歉,没办法了,
  • 打赏
  • 举报
回复
ffgg 2004-04-30
用http连接接收到以gzip方式的encoded content,也许是xhtml文件或是其他。自然要先先针对gzip进行decode。java.util.zip中的这几个包是常用的,可惜不能用。
有没有其他方法??
  • 打赏
  • 举报
回复
sy5591 2004-04-30
up
  • 打赏
  • 举报
回复
flyingghost 2004-04-30
j2me里没有这几个。
要是功能简单自己写吧。
要是功能复杂到网上开源社区找吧。
  • 打赏
  • 举报
回复
ffgg 2004-04-29
ft,问题就是j2me里面这些包不存在,我才问有没有其他方法可以使用。
  • 打赏
  • 举报
回复
加载更多回复
相关推荐
发帖
J2ME
加入

1.3w+

社区成员

Java J2ME
申请成为版主
帖子事件
创建了帖子
2004-04-29 08:42
社区公告
暂无公告