我在windows2003下面安装jbuilder X出现下面错误!!这种错误我还是第一次见

luming711115 2004-05-05 04:09:46
我在win2003下安装JBuilderX出现下面错误
Fatal Application Error

This Application has Unexpectedly Quit
invocation of this java Application has caused an invocation
TargetException. This application will now exit(LAX)
错误的细节如下:
java.lang.StringIndexOutOfBoundsException: String index out of range: -92
at java.lang.String.substring(String.java:1444)
at java.lang.String.substring(String.java:1411)
at ZeroGlh.a(Unknown Source)
at com.zerog.ia.installer.util.magicfolders.JavaHomeMF.a(Unknown Source)
at com.zerog.ia.installer.util.magicfolders.JavaHomeMF.b(Unknown Source)
at com.zerog.ia.installer.util.magicfolders.MagicFolder.initializeAllMagicFolderPaths(Unknown Source)
at com.zerog.ia.installer.Main.d(Unknown Source)
at com.zerog.ia.installer.Main.c(Unknown Source)
at com.zerog.ia.installer.Main.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at com.zerog.lax.LAX.launch(Unknown Source)
at com.zerog.lax.LAX.main(Unknown Source)

请问是怎么回事,在win2k和XP下面安装没有问题
...全文
70 8 点赞 打赏 收藏 举报
写回复
8 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
Ianliu 2004-05-08
"你个笨驴"
禁止进行人身攻击
  • 打赏
  • 举报
回复
xwjing 2004-05-08
jbuilder9挺好使的~~~~
  • 打赏
  • 举报
回复
leonzhao 2004-05-08
jb 不是 OS 的,从这个区出去吧~
  • 打赏
  • 举报
回复
hermits 2004-05-07
你个笨驴,我是说微软公司为了解决某些应用程序不能够在2003下运行的问题,就设计了兼容模式在2003下模拟2000,98,xp的运行方式,其实就是解决你所提的问题的!具体和你说说吧!
在jbuilder的可执行文件也就是那个.exe文件右击,选属性,进入兼容性选项卡勾选用兼容模式运行这个程序,随便选xp或者是2000都可以,很简单的!我以前在csdn上问过这个问题的啊!没错的!你按我的步骤做绝对没错的啊!好了么?再不行的话,你可就真的笨死了!
  • 打赏
  • 举报
回复
hermits 2004-05-06
你个笨驴,在xp或者2000的兼容模式下运行就没问题了!这个小问题还问!真没意思,如果不行给我发电子邮件!
  • 打赏
  • 举报
回复
Giantjava 2004-05-06
建议使用JBuilder9
  • 打赏
  • 举报
回复
luming711115 2004-05-06
我还不知道在XP和2k下面可以运行,因为我讨厌XP,嫌弃200太慢!我就是要在2003下面运行啊 !你才笨呢 有好东西不用
  • 打赏
  • 举报
回复
minghuitian 2004-05-05
gz
  • 打赏
  • 举报
回复
相关推荐
发帖
Java EE
加入

6.7w+

社区成员

J2EE只是Java企业应用。我们需要一个跨J2SE/WEB/EJB的微容器,保护我们的业务核心组件(中间件),以延续它的生命力,而不是依赖J2SE/J2EE版本。
申请成为版主
帖子事件
创建了帖子
2004-05-05 04:09
社区公告
暂无公告