Applet 在JDK哪个版本下编译,不用装JDK,IE保证能运行?

pjzsz 2004-05-08 12:18:49
Applet 在JDK哪个版本下编译,不用装JDK,IE保证能运行?
望各位指点迷经!
...全文
46 6 点赞 打赏 收藏 举报
写回复
6 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
htl 2004-05-10
用老的java版本下的组件来编写,最好是jdk1.1版本下的,就可以在浏览器中直接看到
  • 打赏
  • 举报
回复
panpan221 2004-05-08
Applet要运行就要IE安装java2 plug-in插件
你把
<SCRIPT language="VBSCRIPT" src="http://java.sun.com/products/plugin/1.4/autod1/autodownload.vbs">
</SCRIPT>
加入你写的Applet网页,这样如果ie没有安装插件,它就会自动下载。
  • 打赏
  • 举报
回复
rombus 2004-05-08
Applet要运行就要IE安装java2 plug-in插件
你把
<SCRIPT language="VBSCRIPT" src="http://java.sun.com/products/plugin/1.4/autod1/autodownload.vbs">
加入你写的Applet网页,这样如果ie没有安装插件,它就会自动下载。
  • 打赏
  • 举报
回复
wuyaxlz 2004-05-08
学习,强烈学习
  • 打赏
  • 举报
回复
CrazyHippo 2004-05-08
是的,IE只认jdk1.1。所以,如果你不想装插件,必须做两件事情:
1、使用jdk1.1提供的核心包编写程序,不能用1.2之后的;
2、编译程序时加"javac -target 1.1 "选项。
  • 打赏
  • 举报
回复
Acylas 2004-05-08
ie等浏览器默认的是1。1版本的,如果在这个版本下编译就可以不用另外安装jre就能运行
  • 打赏
  • 举报
回复
相关推荐
发帖
Java SE
加入

6.2w+

社区成员

Java 2 Standard Edition
申请成为版主
帖子事件
创建了帖子
2004-05-08 12:18
社区公告
暂无公告