急呀.我做了一个程序,在本地测试,什么问题也没有.可是上传后怎么出问题了呢???提示如下.

gccr 人人贷 服务器端工程师  2004-09-06 04:39:26
“/”应用程序中的服务器错误。
--------------------------------------------------------------------------------

运行时错误
说明: 服务器上出现应用程序错误。此应用程序的当前自定义错误设置禁止远程查看应用程序错误的详细信息(出于安全原因)。但可以通过在本地服务器计算机上运行的浏览器查看。

详细信息: 若要使他人能够在远程计算机上查看此特定错误信息的详细信息,请在位于当前 Web 应用程序根目录下的“web.config”配置文件中创建一个 <customErrors> 标记。然后应将此 <customErrors> 标记的“mode”属性设置为“Off”。


<!-- Web.Config 配置文件 -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


注释: 通过修改应用程序的 <customErrors> 配置标记的“defaultRedirect”属性,使之指向自定义错误页的 URL,可以用自定义错误页替换所看到的当前错误页。


<!-- Web.Config 配置文件 -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

...全文
168 25 打赏 收藏 举报
写回复
25 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
hebookboy 2004-09-11
看来是程序的问题了
  • 打赏
  • 举报
回复
savagewang1978 2004-09-11
将配置改为
<configuration>
<system.web>
<customErrors mode="Off" />
</system.web>
</configuration>
  • 打赏
  • 举报
回复
colderboy 2004-09-11
不用重做吧??把你编译生成的dll考到根目录的bin目录,其它文件照传试试
  • 打赏
  • 举报
回复
gccr 2004-09-11
我怎么解决的???哈哈。
我用asp重做了一个一样功能的东东传上去就好使了。
  • 打赏
  • 举报
回复
ZLiu 2004-09-11
看看你的虚拟目录,设置成应用程序,然后重启IIS.在试试。
  • 打赏
  • 举报
回复
qixiao 2004-09-11
搂主怎么解决这个问题,我也遇到这个问题了?
  • 打赏
  • 举报
回复
dfg35_-433 2004-09-11
一个虚拟目录不能有多个配置文件,如果是小程序 也不需要建立虚拟目录的,直接把编译好的DLL传到根目录下BIN下面 然后公用根目录的配置文件
  • 打赏
  • 举报
回复
gccr 2004-09-11
我知道怎么回事了。
是因为我这个程序传到一个net空间上了。但不是新建的虚拟目录,而是在虚拟目录下面建了一个文件夹,所以出现了如此的问题。
  • 打赏
  • 举报
回复
gccr 2004-09-07
dpmcy()
我用的是Server.MapPath(database)+"/数据库名",应该没有问题的。

程序在本地是很好的。

ark_matrix(matrix)
我在CuteFtp里,直接看的,也是mode="Off",肯定是改对了。

还有。我那个页里面全是HTML代码,只是加了一个搜索控件而已,其它的aspx页也都打不开啦。
  • 打赏
  • 举报
回复
lc789q 2004-09-07
我也遇到这样的问题,程序应该没问题,会不会是服务器配置有问题,我已经删除了web.config,
我把.htm改成.aspx都有问题
  • 打赏
  • 举报
回复
ark_matrix 2004-09-07
你改的是哪个web.config啊,不是改错文件了吧
  • 打赏
  • 举报
回复
noimpulse 2004-09-07
程序有问题
  • 打赏
  • 举报
回复
goody9807 2004-09-07
<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>


---------------
<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
把 defaultRedirect="mycustompage.htm珊了
  • 打赏
  • 举报
回复
HellKid 2004-09-07
这个肯定是你程序的问题~~~~你仔细检查一下
  • 打赏
  • 举报
回复
dpmcy 2004-09-07
你应该检查一下你的程序,你的程序肯定是有问题的,我遇到过类似的问题,比如联接数据库了,你是否是联接的你上传到服务器上的数据库啊,还有一些类似的小问题。你检查一下吧
  • 打赏
  • 举报
回复
gccr 2004-09-07
已经改为
<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
了。可是还是显示出这个信息。是不是有点不可能呀。但是却是事实。
  • 打赏
  • 举报
回复
vzxq 2004-09-06
把自定义错误页支了
  • 打赏
  • 举报
回复
ark_matrix 2004-09-06
把customErrors mode设为"Off" ,defaultRedirect="mycustompage.htm"去掉
  • 打赏
  • 举报
回复
yichuan1982 2004-09-06
up
  • 打赏
  • 举报
回复
gccr 2004-09-06
大家帮帮忙呗!!!!
怎么回事??
  • 打赏
  • 举报
回复
加载更多回复
相关推荐
发帖
.NET社区
加入

6.0w+

社区成员

.NET技术交流专区
帖子事件
创建了帖子
2004-09-06 04:39
社区公告

.NET 社区是一个围绕开源 .NET 的开放、热情、创新、包容的技术社区。社区致力于为广大 .NET 爱好者提供一个良好的知识共享、协同互助的 .NET 技术交流环境。我们尊重不同意见,支持健康理性的辩论和互动,反对歧视和攻击。

希望和大家一起共同营造一个活跃、友好的社区氛围。