一个简单的问题,急!!!!!!!

qiukiller1981 2004-09-13 02:26:49
现在原来的linux系统上有一个mysql3.23.49版本的数据库,我现在要卸载掉它,装一个mysql3.23.41的数据库。安装文件我已经下好了mysql-max-3.23.41-pc-linux-gnu-i686.tar.rar,请问具体的在linux下的具体的卸载和安装命令是怎么样的?我是root用户,各位大哥,小弟不太懂linux的命令,请说的详细点,谢谢!!!!!
...全文
45 点赞 收藏 3
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
pwtitle 2004-09-13
如果你不是以rpm方式安装的就不能使用rpm命令。而且你下的mysql-max-3.23.41-pc-linux-gnu-i686.tar.gz不是rpm包,你只能手工编译。
rpm包的后缀为.rpm

卸载
rpm -e 包名

升级
rpm -Uvh 包名

安装
rpm -i 报名
回复
pwtitle 2004-09-13
1、停止当前mysql或是cp到其他地方去
2、安装/升级(rpm -U)或是编译安装新版本的mysql4
3、使当前新安装的mysql4可以正常运行。
4、停止mysql4
5、cp 以前的mysql的data目录到新版本的mysql4的data目录,覆盖啊。
6、启动mysql4,

恭喜你,你升级成功了.............
回复
julise 2004-09-13
给你一个网址,去看一下吧:
http://www.enet.com.cn/eschool/inforcenter/A20040212285229.html
回复
相关推荐
发帖
MySQL
创建于2007-09-28

5.5w+

社区成员

MySQL相关内容讨论专区
申请成为版主
帖子事件
创建了帖子
2004-09-13 02:26
社区公告
暂无公告