怎样在eclipse里添加jboss服务器?

Sun_Libra 2004-09-16 05:29:17
eclipse版本是3,jboss版本是3.2.5
添加后出错信息如下:
Severity Description Resource In Folder Location Creation Time
2 Project TestJ2EE is missing required library: 'D:jboss-3.2.5/lib/jboss-boot.jar' TestJ2EE 2004年9月16日 16:13:21

Severity Description Resource In Folder Location Creation Time
2 Project TestJ2EE is missing required library: 'D:jboss-3.2.5/server/default/lib/javax.servlet.jar' TestJ2EE 2004年9月16日 16:13:21

Severity Description Resource In Folder Location Creation Time
2 The project cannot be built until build path errors are resolved TestJ2EE 2004年9月16日 16:13:21

那两包我看了,jboss里根本没有啊,为什么要找那个包呢?怎么配制?
请各位高手帮忙了!!
...全文
277 点赞 收藏 6
写回复
6 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
Sun_Libra 2004-09-17
找到解决问题的办法了,原来是要更新jboss325.server文件
http://www.csse.monash.edu.au/courseware/cse3450/Downloads/jboss325.server
回复
Sun_Libra 2004-09-17
我想我的lomboz在eclipse里的添加是正确的,我新建了项目用tomcat4.0.4做服务器,都可以正常起启动……
必须下载低版本么?怎么越来越倒退呢?有没有别的解决办法?
回复
snowsavage 2004-09-16
jboss-boot.jar和javax.servlet.jar在jboss-3.0.7中有,可以下个这个版本的jboss把这两个文件拷贝过去,我就是这么解决的。或者干脆装3.0.7版本,这个版本比较稳定。
回复
baffling 2004-09-16
我的错误和楼主完全是一样的(连Project TestJ2EE的名字也一样,晕)。
我的eclipse是3.0.0版,lomboz是3.0.1(?反正下载的文件名是lomboz.301.zip,而且下载的网站说支持eclipse3)。我下了JBoss3.0.8,但提示找不到javax.servlet.jar的错误。
我配的weblogic能用,但Jboss就是出错,真是郁闷啊
回复
charlie0895 2004-09-16
jboss和eclipse 的版本不存在什么要一样,主要是你下的 lomboz版本要和eclipse版本号一样,然后就可以看到window里有lomboz,然后在和你机子上装的jboss连接就可以了
回复
gjxemail 2004-09-16
Jboss与eclipse配置的版本不对
回复
发帖
Java EE
创建于2007-09-28

6.6w+

社区成员

J2EE只是Java企业应用。我们需要一个跨J2SE/WEB/EJB的微容器,保护我们的业务核心组件(中间件),以延续它的生命力,而不是依赖J2SE/J2EE版本。
申请成为版主
帖子事件
创建了帖子
2004-09-16 05:29
社区公告
暂无公告